System bootet nicht (fstab-Fehler)

Dieses Thema im Forum "Allgemein" wurde erstellt von noonecanhide, 9. Okt. 2014.

  1. noonecanhide

    noonecanhide New Member

    Hallo,

    ich setze die aktuellste ISPConfig-Version auf einer virtuellen Maschine ein. Nach den heutigen Ubuntu-Patches war ein reboot des Hosts nötig, folglich musste diese VM auch neugestartet werden. Allerdings kam die ISPConfig-VM dann nicht mehr hoch, während alle anderen VMs wieder in Betrieb waren.

    Ein Blick per VNC auf die Konsole ergab, dass die VM nach dem Mounten der ext4 und swap Partitionen einfach hängenblieb. Dateisystemüberprüfungen waren fehlerfrei, der nächste Blick galt der /etc/fstab. Dabei ist mir das folgende aufgefallen, die Log-Verzeichnisse der beiden letzten Kunden wurden offensichtlich mit der Option "_netdev" in die fstab eingefügt.

    Code:
    /dev/vda1 on /var/www/clients/client15/web55/log type none (rw,bind)
    /dev/vda1 on /var/www/clients/client7/web56/log type none (rw,bind)
    /dev/vda1 on /var/www/clients/client6/web6/log type none (rw,bind,_netdev)
    /dev/vda1 on /var/www/clients/client5/web59/log type none (rw,bind,_netdev)
    
    Nachdem ich den _netdev Eintrag entfernt hatte und die VM neugestartet hatte kam diese ohne Probleme wieder online.
    Aus Interesse habe ich testweise eine neue Webseite angelegt, doch auch bei dieser taucht der "_netdev" Eintrag wieder auf.

    Kommt das von ISPConfig, oder hat Ubuntu da irgendetwas geändert ?

    Angaben zum System:
    kvm/qemu VM mit 100GB HDD, 8GB RAM, 4 CPU Kerne.
    Partitionierung: root (ext4, 100GB), swap 8GB
    OS: Ubuntu 12.04.5 LTS
    ISPConfig: 3.0.5.4p3 (Apache, Courier, Postfix)
     
  2. Till

    Till Administrator

    Die _netdev Option kommt von ISPConfig, das sollte aber eine Probleme machen und ist nur eine Vorsichtsmaßnahme falls die Partition über das netz gemountet wird. Ich habe das gerade mal hier auf meinem Ubuntu 14.04 Testserver getestet und es gibt keine Probleme beim booten. Mal sehen ob ich irgendwo noch ein altes Ubuntu habe. Ist irgend was besonderes bei Eurer Server Konfiguration?
     
  3. noonecanhide

    noonecanhide New Member

    Hallo Till,

    danke für die schnelle Antwort. An dem Server ist eigentlich nichts spezielles, installiert wurde er als 10.04 LTS, und hat regulär das Upgrade auf 12.04 bekommen. Sonst ist an sich alles Standard, mit Ausnahme der Netzkonfiguration, die /etc/network/interfaces wird nicht durch ISPConfig verwaltet - der Server benötigt eine statische IP Adresse mit Gateway und pointopoint auf den Host. Sollte aber auch nicht sooo ungewöhnlich sein ;)

    Sämtliche Ubuntu-Logfiles sind m.E. absolut unauffällig, hast du eine Idee wo ich noch nachschauen könnte ?

    Anbei ein Screen der VM, an der Stelle wo sie stehenbleibt (Recovery Boot, bei Standard-Boot sieht man gar nichts). Der Fail bei Graphic ist es jedenfalls nicht. Max Mount Count etc ist es auch nicht, habe ich inwzischen testweise komplett deaktiviert. SnipImage.jpg
     
  4. Till

    Till Administrator

    Als vorübergehende Lösung kannst Du das _netdev in ispconfig entfernen, durchsuch mal die Datei /usr/local/ispconfig/server/plugins-available/apache2_plugin.inc.php bzw wenn Du nginx verwendest, dann das nginx Plugin im selben Verzeichnis.
    Ich hab das mal in den Bugtracker eingefügt und werde versuchen das zu reproduzieren. Ich denke aber dass es eine rechte seltene Kombination sein muss da es noch nicht oft aufgetreten ist und wir eine sehr hohe Anzahl an Installatinen haben, vielleicht irgend ein Kernel Modul oder ähnliches.
     
  5. nowayback

    nowayback Well-Known Member

    wird wohl irgendwie mit netfs zusammenhängen...
    wäre evtl. sinnvoll zu checken ob nfs läuft
     
  6. Till

    Till Administrator

    Das geht da ja nicht nur um nfs sondern es kann auch glusterfs sein oder etwas anderes. An sich soll die Option je nur dafür sorgen dass die mounts erst aktiv werden nachdem der Netzwerk Stack initialisiert ist und das schadet auch nicht auf Systemen die kein Netzlaufwerk nutzen, denn die mounts werden von keinem Daemon zur Startzeit benötigt und einen Netzwerk Stack hat jeder Server. Brauche tut man die mounts erst wenn ein Kunde per ssh oder FTP auf seine Logs zugreifen will, es it also kein Problem sie in der Reihenfolge nach hinten zu schieben.

    Warum das aber auf dem System ein Problem ist kann ich noch nicht sagen.
     
  7. Till

    Till Administrator

    Ok, hab gerade in der manpage gesehen dass es tatsächlich nur nfs ist:
    Dann werde ich das irgendwie zusätzlich abprüfen müssen. Komisch dass da sonst kein System ohne nfs ein Problem damit hat...

    --update --
    wobei das auch ein Fehler in der Ubuntu Doku sein kann:
    http://arstechnica.com/civis/viewtopic.php?f=16&t=1224111
    laut diesem Thraed tut _netdev das was ich oben gesagt habe "Delay until network stack is up" und was in diesem fall gewünscht ist. Also mal weiter suchen.
     
  8. Till

    Till Administrator

    Ich hab es jetzt mal auf Ubuntu 12.04 LTS getestet (Referenzsystem für perfect server anleitung, entspricht also exakt dem veröffentlichten Setup), alle Updates installiert, sowohl Ubuntu als auch ISPConfig, in der fstab steht:

    Code:
    /var/log/ispconfig/httpd/test.int /var/www/clients/client0/web1/log    none    bind,nobootwait,_netdev    0 0
    und der Server bootet einwandfrei damit.
     
  9. noonecanhide

    noonecanhide New Member

    Danke für Eure Mühe, echt super !

    Ich suche gerade nach Altleichen, denn mir ist noch eingefallen, dass der Server war einmal Teil einer FS-Replikation über GlusterFS. Das Paket war zwar gelöscht und auch nicht mehr aktiv, aber die Konfigurationsdateien waren noch da. Das war aber auch nicht die Ursache, ich schaue jetzt noch ob noch irgendwo Spuren übrig sind, die den Start verhindern... NFS oder andere Netzwerkdateisysteme sind nicht aktiv, und auch nicht geladen.
     
  10. Till

    Till Administrator

    Hast Du mal mit dmesg geschaut, ob es da irgend was an Fehlermeldungen gibt?
     
  11. florian030

    florian030 Member

    Ich mag mich täuschen, aber in der fstab sollte auch nobootwait stehen (und das steht auch so in den server-plugins).
     
  12. Moppi

    Moppi New Member

    Ich kann das bestätigen, der Fehler tritt vor allem dann auf wenn besonders viele Einträge in der fstab sind.
    Betroffen bei mir sind mehrere Ubuntu Server 12.04 und 14.04. Erst das Entfernen von _netdev aus der fstab lässt die Kiste booten.

    Diesbezüglich auch ein +1 von mir: http://bugtracker.ispconfig.org/index.php?do=details&task_id=3699
     
  13. Till

    Till Administrator

    Die Netdev option läst sich doch bereits seit einiger Zeit an / aus schalten. Siehe System Server config > web,
     
  14. Moppi

    Moppi New Member

    Ja, die Option gibt es, greift aber bei mir nicht. In der apache2_plugin.inc.php gibt es auch die entsprechende if-abfrage, und in der Datenbank ist auch ein "network_filesystem=n" eingetragen. Liegt es vielleicht am Multiserver-Setup?

    Viele Grüße,
    Moppi
     
  15. Till

    Till Administrator

    Die Abfrage beeinflusst nur neue webseiten, keine alten. Denn der fstab eintrag wird nicht neu geschrieben. Und du musst es beim passenden Zielserver eingestellt haben.
     
  16. Moppi

    Moppi New Member

    Hallo Till!
    Es funktioniert auch bei neu angelegten Seiten nicht, er schreibt konsequent das _netdev rein. Auf allen (beiden) Webservern ist die Option "Netzlaufwerk" nicht angekreuzt und in den Datenbanken jeweils das network_filesystem=n vermerkt.

    Viele Grüße,
    Moppi
     
  17. Till

    Till Administrator

    Und Du nutzt die aktuelle Version, 3.0.5.4p5 ?
     
  18. Moppi

    Moppi New Member

    Hallo Till,
    There are no updates available for ISPConfig 3.0.5.4p5.
    Mein zweiter Webserver im Multiserver-Setup ist erst letzte Woche dazu gekommen.

    Viele Grüße
    Moppi
     

Diese Seite empfehlen