Tägliches Auto-Backup umplanen/verschieben

Dieses Thema im Forum "Tipps - Tricks - Mods" wurde erstellt von marburger93, 29. Jan. 2017.

  1. marburger93

    marburger93 New Member

    Guten Abend,

    ich habe nun schon Google misshandelt, in verschiedenen Suchmustern nach dem Problem gesucht jedoch keine Lösung gefunden. Ich hoffe, dass ein Nutzer aus dem Forum mir helfen kann.

    Aktuell startet das tägliche, von ISPConfig eigene Backup für Webseiten, Datenbanken und E-Mails immer in der Nacht. Auf Grund mehrerer großen Datenbanken (> 4 GB) ist für ca. 5-10 Minuten die Webseite nicht erreichbar. Ich möchte das tägliche Backup umplanen, es soll gegen 5 Uhr starten.

    Ich habe mich schon selbst auf die Suche gemacht und folgende Datei gefunden:
    /usr/local/ispconfig/server/lib/classes/cron.d/500-backup.inc.php

    In diesem Script befindet sich das komplette Backup-Script. Schon in der ersten Zeile der Class "cronjob_backup" dachte ich mein Problem gefunden zu haben:
    PHP:
        protected $_schedule '0 0 * * *';
    Ich änderte die Zeile...
    PHP:
        protected $_schedule '0 5 * * *';
    ...aber musste diese Nacht feststellen, dass die Zeile keine Änderung erzieht hat. Das Backup wurde wieder um Mitternacht durchgeführt.

    Im Script selbst konnte ich keinen Zeitplan erkennen, lediglich mit einer IF-Prüfung ob im Interface ein tägliches, wöchentliches oder monatliches Backup ausgewählt worden ist.

    Meine Frage: Wie kann ich den Zeitplan für das Backup in ISPConfig 3.1.1p1 anpassen?
     
  2. Till

    Till Administrator

    Das ist schon die richtige Stelle, warte mal noch einen Tag.
     
  3. marburger93

    marburger93 New Member

    Ich habe nun eine Woche gewartet (Thread vergessen), dennoch hat sich nichts geändert. Das Backup startet immer noch um Mitternacht.

    Muss ich noch etwas anderes ändern/anpassen?
     
  4. Croydon

    Croydon Super-Moderator

    Es gibt unter System -> Server Konfig eine Einstellung für die Backup-Zeit, die die Angabe in der cron-Datei für das Backup überschreibt.
     
    marburger93 gefällt das.
  5. marburger93

    marburger93 New Member

    Perfekt, vielen Dank! Diese Option habe ich wohl komplett übersehen (oder muss mit dem neuen Design auch neu dazu gekommen sein).
    Wenn ich mich nicht zurück melde, dann hat die Einstellung funktioniert.
     
  6. marburger93

    marburger93 New Member

    Folgende Änderung habe ich gegen 19 Uhr vorgenommen:

    [​IMG]
    Trotz der Einstellung wurde das Backup um Mitternacht gestartet:
    [​IMG]
    Ich weiß nicht mehr weiter, vermutlich muss ich selbst Hand anlegen und das Script anpassen. Wenn noch jemand eine Idee hat, bitte melden.
     
  7. Till

    Till Administrator

    Warte nochmal einen Tag. Das Cron system cached den nächsten Startzeitpunkt.
     

Diese Seite empfehlen