The Perfect Server - CentOS 5.2

Dieses Thema im Forum "Fragen zu Howtos" wurde erstellt von scarabeuz, 29. Aug. 2010.

  1. scarabeuz

    scarabeuz New Member

    Hallo liebe Community,
    bei der Suche nach der Erstellung von einem eigenen Webserver bin ich auf das HowTo von Falko Timme gestoßen (Link), bin auch (wenn auch ohne Vorkenntnisse in Unix-Systemen) ziemlich gut durchgekommen und nun am Ende angelangt...

    Wenn ich den komplett eingerichteten Server nun starte gibt es Fehler beim starten von einzelnen Diensten.
    Vielleicht könnt ihr mir da ein wenig auf die Sprünge helfen wo sich da eventuelle Tippfehler eingeschlichen haben könnten...

    Anzeige beim Start der Dienste:
    Code:
    ..............
    Locating /var/named/chroot//etc/named.conf failed:
    
    portmap starten:                       [fehlgeschlagen]
    
    ...........
    Anzeige beim Runterfahren:
    Code:
    ..............
    killall starten: Postfix beenden                       [fehlgeschlagen]
    
    ...........
    Ausserdem lässt sich proftpd weder starten oder stoppen noch lässt sich chkconfig auf das prog ausführen, da zeigt er an:
    Code:
    Dienst proftpd unterstützt chkconfig nicht
    Möglicherweise könnte es auch daran liegen, dass ich statt proftpd version 1.3.1 die Version 1.3.3 installiert hab und statt CentOS 5.2 Version 5.5 ...
     
    Zuletzt bearbeitet: 29. Aug. 2010
  2. Till

    Till Administrator

  3. scarabeuz

    scarabeuz New Member

    Nein das ist n Server der bei mir im Raum steht.
    Danke, das howto schein ich wohl übersehen zu haben...
    ich werd mal schauen..

    lg

    //edit

    Fehler selbst gefunden:

    ich hatte bei proftpd (vi /etc/init.d/proftpd) die auskommentierten Zeilen weggelassen, dachte die werden nicht beachtet wenn das Prog startet.
    Und in /etc/postfix/main.cf & /etc/doofkopf.conf hatten sich auch nette Fehler eingeschlichen.

    Naja jetzt läuft alles und ISPConfig ist auch schon drauf :D
    Trotzdem danke...
     
    Zuletzt bearbeitet: 29. Aug. 2010
  4. scarabeuz

    scarabeuz New Member

    Eine Frage hab ich noch...

    Wie wird denn nun meine Domain eingestellt, dass das alles dann auch funzt (also die domain die im Beispiel server1.example.com heisst)?

    Gibt es dazu auch ein HowTo?
     
  5. Laubie

    Laubie Member

    Es darf keine Domain - bzw. was du eigentlich meinst "Seite" - geben, die auf den namen server1.example.com hört.

    Wenn du aber eine Seite namens "example.com" bzw. "www.example.com" anlegen willst,
    so machst du das Unter dem Reiter "Sites".
    Dort dann "Neue webseite hinzufügen"
    der rest sollte eigentlich selbsterklärend sein.

    Wenn nicht, guck mal ins Wiki:
    http://ispc-wiki.org/
     
  6. Till

    Till Administrator

    Die Anleitung auf ispc-wiki.org ist nur für ISPConfig 3. Da Du aber ispconfig 2 verwendest, findest Du alle Anleitungen und das handbuch auf der ISPConfig Webseite:

    http://www.ispconfig.org/ispconfig-2/documentation/

    Schau mal in den first steps guide.
     
  7. Laubie

    Laubie Member

    upsa... glatt überlesen...
     
  8. scarabeuz

    scarabeuz New Member

    Oh nee ich meine meinen Server, der schimpft sich jetzt zB host.domain.com ...
    Aber wenn ich host.domain.com eingebe dann komm ich doch nicht auf meinen Server (also kann ip nicht durch Hostnamen erstetzen..)
    Ich hoffe ihr versteht was ich meine :eek:
     
  9. Till

    Till Administrator

    Wenn Du mit host.domain.com nicht auf Deinen Server kommst, dann hast Du vergessen einen DNS A-Record für host.domain.com anzulegen der auf die IP Deines Servers verweist.
     

Diese Seite empfehlen