The Perfect Server :: Debian Wheezy - nginx - Webseiten Autoalias

#1
Ich versuche gerade zum 1. mal eine Installation debian 7.5,nginx nach der Anleitung von Falko Timme. Nach durchlaufener Installation - stelle ich unter Serverkonfiguration -> Web -> Webseiten Autoalias auf [website_domain].
Ich dachte, dass ich damit die Webseite mit der URL: website_domain.serverdomain.de erreichen kann.
Leider klappt das nicht so einfach ... :confused:
Woran kann das liegen - was muß ich noch einstellen - vielleicht habt ihr mal Zeit für einen kurze Wink mit dem Zaunspfahl ...
 

Till

Administrator
#2
Hast Du denn in der DNS Zone der Domain serverdomain.de einen wildcard record für *.serverdomain.de angelegt, welcher auf die IP des Servers verweist?
 
#5
ISPConfig Version: 3.0.5.4p1

Kann ich das irgendwie per Konsole prüfen, ob und wie er auf die Webseiten_domain reagiert ?

Hab in den Logfiles versucht was zu finden - aber eben nur versucht :)

die erzeugte vhost Datei fängt so an :::
************************************
server {
listen *:80;
server_name maniaxneu.de maniaxneu.de www.maniaxneu.de;
root /var/www/maniaxneu.de/web;
*****************************************

Sollte ich vielleicht mal apache probieren ????
 

Till

Administrator
#6
Das funktioniert sowohl mit apache als auch nginx. Seht das da exakt so in der datei?

"server_name maniaxneu.de maniaxneu.de www.maniaxneu.de;"

oder hast Du da was geändert? Was genau steht im Webseiten Autoalias Feld?
 

Till

Administrator
#8
Du hast die Domain vergessen im autoalias Feld. Da muss z.B. stehen

[website_domain].deinedomain.de

denn wenn da nur [website_domain] steht, dann nimmt er als alias ja auch nur die domain der webseite, die ja nicht erreichbar ist. macht also keinen Sinn so die Einstellung.
 
#9
ui ... und schon funktioniert es ... :eek:
Also doch erstmal das Handbuch kaufen und richtig lesen ...
Danke für die Hilfe - dann kann ich ja mal weiterschauen, wo bei mir die nächste Baustelle kommt :)
 

Werbung

Top