The Perfect Setup - Debian Etch (Debian 4.0) - Page 5

Dieses Thema im Forum "Fragen zu Howtos" wurde erstellt von wiseguy, 9. Nov. 2008.

  1. wiseguy

    wiseguy New Member

    [erledigt]The Perfect Setup - Debian Etch (Debian 4.0) - Page 5

    Hallo,

    bin nach diesem HowTo vorgegangen und hab beim Überprüfen (wie am Ende von 11 Postfix With SMTP-AUTH And TLS mit telnet angegeben) folgende Ausgabe:
    Code:
    220 meinedomain.de ESMTP Postfix (Debian/GNU)
    ehlo localhost
    250-meinedomain.de
    250-PIPELINING
    250-SIZE 50000000
    250-ETRN
    250-AUTH PLAIN DIGEST-MD5 LOGIN CRAM-MD5
    250-AUTH=PLAIN DIGEST-MD5 LOGIN CRAM-MD5
    250-ENHANCEDSTATUSCODES
    250-8BITMIME
    250 DSN
    Genau die zwei Zeilen 250-STARTTLS und 250-AUTH PLAIN LOGIN hab ich nun nicht so stehen.

    Was könnte ich falsch gemacht haben? Es ist natürlich schwierig jetzt zu rekonstruieren, wo genau der Fehler in der Umsetzung des HowTos liegt, aber vielleicht weiß ja jemand was da genau fehlen könnte und an welcher Stelle im HowTo ich den Fehler "begangen" haben könnte...

    mfg
     
    Zuletzt bearbeitet: 12. Nov. 2008
  2. Till

    Till Administrator

    Hast Du Postfix nach der Konfiguration neu gestartet?
     
  3. wiseguy

    wiseguy New Member

    ja mit /etc/init.d/postfix restart. Und mit /etc/init.d/saslauthd start hab ich auch die authentifizierung gestartet.

    Hier mal eine rekonstruktion von dem was ich gemacht hab:
    Code:
    [LIST]
    [*][B]apt-get install postfix libsasl2 sasl2-bin libsasl2-modules libdb3-util procmail[/B]
    [*]'[COLOR=Blue][B][I]Internet Site[/I][/B][/COLOR]' ausgewählt
    [*]'[COLOR=Blue][B][I]meinedomain.de[/I][/B][/COLOR]' als Mail name eingetragen
    [*][B]dpkg-reconfigure postfix[/B]
    [*]'[I][B][COLOR=Blue]Internet Site[/COLOR][/B][/I]' ausgewählt
    [*]nichts bei 'Where should mail for root go' eingetragen
    [*]'[B][I][COLOR=Blue]meinedomain.de[/COLOR][/I][/B]' als Mail name eingetragen
    [*]'[B][I][COLOR=Blue]meinedomain.de, localhost[/COLOR][/I][/B]' als Other destinations to accept mail for eingetragen
    [*]'[B][I][COLOR=Blue]yes[/COLOR][/I][/B]' bei Force synchronous updates on mail queue angegeben (im HowTo hats hier 'no' geheißen, aber ich dachte mir, lieber etwas mehr Sicherheit statt Geschwindigkeit - ich weiß ja nicht, was das an Geschwindigkeit ausmacht. Sollte aber ja mi dem Problem nichts zu tun haben)
    [*]'[B][I][COLOR=Blue]127.0.0.0/8[/COLOR][/I][/B]' bei Local networks eingetragen
    [*]'[B][I][COLOR=Blue]yes[/COLOR][/I][/B]' bei Use procmail for local delivery angegeben
    [*]'[B][I][COLOR=Blue]0[/COLOR][/I][/B]' bei Mailbox size limit angegeben
    [*]'[B][I][COLOR=Blue]+[/COLOR][/I][/B]' bei Local address extension character angegeben (was ist das eigentlich?)
    [*]'[B][I][COLOR=Blue]all[/COLOR][/I][/B]' bei Internet protocols to use angegeben
    [*][B]postconf -e 'smtpd_sasl_local_domain =[/B]
    (evtl. hängts daran; aber so stands im Howto...)
    [*][B]postconf -e 'smtpd_sasl_auth_enable = yes'[/B]
    [*][B]postconf -e 'smtpd_sasl_security_options = noanonymous'[/B]
    [*][B]postconf -e 'broken_sasl_auth_clients = yes'[/B]
    [*][B]postconf -e 'smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination'[/B]
    [*][B]postconf -e 'inet_interfaces = all'[/B]
    [*][B]echo 'pwcheck_method: saslauthd' >> /etc/postfix/sasl/smtpd.conf[/B]
    [*][B]echo 'mech_list: plain login' >> /etc/postfix/sasl/smtpd.conf[/B]
    [*][B]mkdir /etc/postfix/ssl[/B]
    [*][B]openssl genrsa -des3 -rand /etc/hosts -out smtpd.key 1024[/B]
    [*]ein Passwort (sagen wir mal '[B][I][COLOR=Blue]password[/COLOR][/I][/B]') angegeben
    [*][B]chmod 600 smtpd.key[/B]
    [*][B]openssl req -new -key smtpd.key -out smtpd.csr[/B]
    [*]'[B][I][COLOR=Blue]DE[/COLOR][/I][/B]' bei Country Name angegeben
    [*]nichts bei State or Province Name angegeben
    [*]nichts bei Locality Name angegeben
    [*]'[B][I][COLOR=Blue]Privat[/COLOR][/I][/B]' bei Organization Name angegeben
    [*]nichts bei Organizational Unit Name angegeben
    [*][COLOR=Black]meinen Namen[/COLOR] bei Common Name angegeben
    [*]nichts bei Email Address angegeben
    [*]nichts bei A challenge password angegeben
    [*]nichts bei An optional company name angegeben
    [*][B]openssl x509 -req -days 365 -in smtpd.csr -signkey smtpd.key -out smtpd.crt[/B]
    [*]'[B][I][COLOR=Blue]password[/COLOR][/I][/B]' angegeben (also das vorhin vergebene Passwort)
    [*][B]openssl rsa -in smtpd.key -out smtpd.key.unencrypted[/B]
    [*]'[B][I][COLOR=Blue]password[/COLOR][/I][/B]' angegeben (wieder das oben vergebene Passwort)
    [*][B]mv -f smtpd.key.unencrypted smtpd.key[/B]
    [*][B]openssl req -new -x509 -extensions v3_ca -keyout cakey.pem -out cacert.pem -days 365[/B]
    [*]'[B][I][COLOR=Blue]DE[/COLOR][/I][/B]' bei Country Name angegeben
    [*]nichts bei State or Province Name angegeben
    [*]nichts bei Locality Name angegeben
    [*]'[B][I][COLOR=Blue]Privat[/COLOR][/I][/B]' bei Organization Name angegeben
    [*]nichts bei Organizational Unit Name angegeben
    [*]meinen Namen bei Common Name angegeben
    [*]nichts bei Email Address angegeben
    [*][B]postconf -e 'smtpd_tls_auth_only = no'[/B]
    [*][B]postconf -e 'smtp_use_tls = yes'[/B]
    [*][B]postconf -e 'smtpd_use_tls = yes'[/B]
    [*][B]postconf -e 'smtp_tls_note_starttls_offer = yes'[/B]
    [*][B]postconf -e 'smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key'[/B]
    [*][B]postconf -e 'smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt'[/B]
    [*][B]postconf -e 'smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem'[/B]
    [*][B]postconf -e 'smtpd_tls_loglevel = 1'[/B]
    [*][B]postconf -e 'smtpd_tls_received_header = yes'[/B]
    [*][B]postconf -e 'smtpd_tls_session_cache_timeout = 3600s'[/B]
    [*][B]postconf -e 'tls_random_source = dev:/dev/urandom'[/B]
    [*][B]postconf -e 'myhostname = meinedomain.de'[/B]
    [*][B]/etc/init.d/postfix restart[/B]
    [*][B]mkdir -p /var/spool/postfix/var/run/saslauthd[/B]
    [*][I][B][COLOR=Red]/etc/default/saslauthd[/COLOR][/B][/I] angepaßt:
    [B][I][COLOR=Blue]START=yes[/COLOR][/I][/B]
    Zeile [I][COLOR=Blue]OPTIONS="-c"[/COLOR][/I] in [B][I][COLOR=Blue]OPTIONS="-c -m /var/spool/postfix/var/run/saslauthd -r"[/COLOR][/I][/B] geändert
    [*][B]/etc/init.d/saslauthd start[/B][/LIST]
    (natürlich ist meinedomain.de hier eingesetzt, damit ich meine ganzen domainnamen hier nicht nennen brauch ;-))
     
  4. Till

    Till Administrator

    Sieht gut aus. poste bitte mal den Inhalt der main.cf, Kommentarzeilen kannst Du weglassen.
     
  5. wiseguy

    wiseguy New Member

    Hallo,

    hier meine main.cf
    Code:
    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    biff = no
    append_dot_mydomain = no
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
    myhostname = meinedomain.de
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    mydestination = meinedomain.de, localhost
    relayhost = 
    mynetworks = 127.0.0.0/8
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    inet_protocols = all
    smtpd_sasl_local_domain = 
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
     
  6. Till

    Till Administrator

    Kann da auf Anhieb keinen Fehler entdecken. Poste bitte mal die Ausgabe von:

    ls -la /etc/postfix/ssl
     
  7. wiseguy

    wiseguy New Member

    Hallo,

    hier die Ausgabe von ls -la /etc/postfix/ssl
    Code:
    user@host:~$ ls -la /etc/postfix/ssl
    total 28
    drwxr-xr-x 2 root root 4096 Nov  9 21:21 .
    drwxr-xr-x 4 root root 4096 Nov  9 21:35 ..
    -rw-r--r-- 2 root root 1021 Nov 11 11:40 cacert.pem
    -rw-r--r-- 2 root root  963 Nov 11 11:40 cakey.pem
    -rw-r--r-- 2 root root  774 Nov 11 11:38 smtpd.crt
    -rw-r--r-- 2 root root  611 Nov 11 11:38 smtpd.csr
    -rw------- 1 root root  963 Nov 11 11:36 smtpd.key
    Hab die Zertifizierung Heute noch mal gemacht...
     
  8. Till

    Till Administrator

    Sieht ok aus. Da fällt mir im Moment erstmal nichts mehr ein. Dein Mailsystem sollte so auf jedem Fall generell funktionieren. Teste es doch bitte mal mit einem richtigen Mailclient wenn Du mitd em Setup fertig bist.
     
  9. wiseguy

    wiseguy New Member

    Hallo,

    ich merk grad noch was:
    ich hab die Domain geändert - sehe aber grad, dass bei der Begrüßung (wenn ich mit telnet auf Port 25 gehe) ein anderer Host sich meldet (nämlich den, den ich vorher hatte, dessen Host leider nur ein dummy Name war...diesen nenne ich im weiteren mal falschedomain.de) (Diese Änderung ist im Zuge meiner Domainumbenennung im oberen Post geändert worden).

    Ich hab gerade nochmal dpkg-reconfigure postfix laufen lasen und die Domains erneut eingestellt. Allerdings werd ich immer noch von dem "falschen" Host begrüßt.

    Zur verdeutlichung hier mal die Ausgabe von telnet localhost 25
    Code:
    user@host:~$ [B]telnet localhost 25[/B]
    Trying xx.xx.xx.xx...
    Connected to [COLOR=Red]localhost.falschedomain.de[/COLOR].
    Escape character is '^]'.
    220 [COLOR=Red]www1.falschedomain.de[/COLOR] ESMTP Postfix (Debian/GNU)
    quit
    221 2.0.0 Bye
    Connection closed by foreign host.
    Also falschedomain ist nun eigentlich nirgends mehr eingetragen:
    in dem menü bei dpkg-reconfigure postfix nicht
    in /etc/hostname nicht
    in /etc/mailname nicht
    in /etc/postfix/main.cf nicht
    in der main.cf steht ja folgende Zeile:
    Code:
    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    Deshalb habe ich mal direkt in der Konsole die Variablen $myhostname und $mail_name überprüft, aber sie sind leider leer.

    Hat jemand ne Idee, wo ich noch suchen kann?

    Evtl. liegt daran das Problem, weil der Dmainname nicht übereinstimmt...

    Ich hab auch mal in /etc mit
    Code:
    find . -type f |xargs grep "falschedomain.de"
    nach einer config gesucht in der das stehen könnte. Leider ohne Erfolg. Allerdings könnte es natürlich auch sein, dass ich noch an anderer Stelle suchen muss.

    EDIT1: Ich hab grad gesehn, dass es beim Linux vserver diese standardmäßige Einstellung des Hostnamen gibt - vermutlich liegt das daran. Wenn dem so ist: Kann mein Authentifizierungsproblem überhaupt damit zusammenhängen? Oder hat das damit einfach gar nichts zu tun? (dann brauch ich auch nicht weiter an dem Hostnamen herumdoktoren, weil mir eigentlich egal ist, wie der da heißt)
     
    Zuletzt bearbeitet: 12. Nov. 2008
  10. Till

    Till Administrator

    Also wenn Du mit Telnet auf localhost verbindest, erhältst Du immer die Antworten vom lokalen Server. Der Domainname der zurückgeliefert wird ist da eher Kosmetik, außer dass bei Dir in der /etc/hosts Datei localhost nicht auf die IP 127.0.0.1 verweist. Du kannst ja mal testweise probieren:

    telnet 127.0.0.1

    und dann:

    ehlo localhost
     
  11. wiseguy

    wiseguy New Member

    Hallo,

    Es hängt tatsächlich mit dem Rechnernamen zusammen:
    Wenn ich, so wie Till geraten hat, direkt auf die localhost IP gehe, wird meine richtige domain genommen und dann bekomme ich die Ausgabe, so wie im Howto beschrieben - also mit STARTTLS und so.

    Das ich den Hostnamen nicht ändern kann liegt daran, dass es ein vserver ist - und eigentlich sollte das (laut Aussage des Serverbetreibers) über die Webconfig-Oberfläche für linux vserver gehen...

    Aber das hat ja mit dem HowTo selbst nix zu tun.

    Ich denke also mal, das mein Problem gelöst ist = Es liegt am -richtigen- falschen Hostnamen.


    PS: Danke Till
     
    Zuletzt bearbeitet: 12. Nov. 2008

Diese Seite empfehlen