Thunderbird Mails senden: TLS library problem

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von DripleX, 10. Nov. 2009.

  1. DripleX

    DripleX New Member

    Seit kurzem habe ich ein Problem mit senden von E-Mails über Thunderbird.
    Es kommt immer ein Fehler:
    Code:
    "Webseiten zertifiziert von unbekannter Zertifizierungsstelle"
    Dies tritt nur bei meiner Hauptdomain auf. Bei den 3 weiteren Domains hab ich den Fehler nicht, dort funktioniert das versenden einwandfrei. Die Kontoeinstellungen sind auch gleich.

    Anfangs hatte ich das gleiche Problem bei allen Domains, dann hab ich einfach die Zertifikate neu erstellt und dann hats funktioniert. Aber nun geht ja nur eine Domain nicht.

    Mein Server läuft mit der aktuellen ISPConfig 3 Version auf Debian Lenny.

    Folgender Fehler kommt dann bei Mail Warn-Protocoll:
    Code:
    Nov 10 16:30:03 server1 postfix/smtpd[716]: warning: TLS library problem: 716:error:14094418:SSL routines:SSL3_READ_BYTES:tlsv1 alert unknown ca:s3_pkt.c:1053:SSL alert number 48:
    telnet localhost 25 ehlo:
    Code:
    250-server1.xxxx.de
    250-PIPELINING
    250-SIZE
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-AUTH LOGIN PLAIN
    250-AUTH=LOGIN PLAIN
    250-ENHANCEDSTATUSCODES
    250-8BITMIME
    250 DSN
    Die Main.cf:
    Code:
    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    biff = no
    append_dot_mydomain = no
    readme_directory = /usr/share/doc/postfix
    smtpd_tls_cert_file = /etc/postfix/smtpd.cert
    smtpd_tls_key_file = /etc/postfix/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/demoCA/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    tls_random_prng_update_period = 3600s
    myhostname = server1.XXXX.de
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    mydestination = server1.XXXX.de, localhost, localhost.localdomain
    relayhost =
    mynetworks = 127.0.0.0/8 [::1]/128
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    html_directory = /usr/share/doc/postfix/html
    virtual_alias_domains =
    virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf,     mysql:/etc/postfix/mysql-virtual_email2email.cf
    virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
    virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
    virtual_mailbox_base = /var/vmail
    virtual_uid_maps = static:5000
    virtual_gid_maps = static:5000
    smtpd_sasl_auth_enable = yes
    broken_sasl_auth_clients = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated,     check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, rejec    t_unauth_destination
    smtpd_tls_security_level = may
    transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
    relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
    virtual_create_maildirsize = yes
    virtual_maildir_extended = yes
    virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_    limit_maps.cf
    virtual_mailbox_limit_override = yes
    virtual_maildir_limit_message = "The user you are trying to reach is over qu    ota."
    virtual_overquota_bounce = yes
    proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $    virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_    recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipi    ent_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mail    box_limit_maps
    smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/mysql-vir    tual_sender.cf
    smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-vir    tual_client.cf
    maildrop_destination_concurrency_limit = 1
    maildrop_destination_recipient_limit = 1
    virtual_transport = maildrop
    header_checks = regexp:/etc/postfix/header_checks
    mime_header_checks = regexp:/etc/postfix/mime_header_checks
    nested_header_checks = regexp:/etc/postfix/nested_header_checks
    body_checks = regexp:/etc/postfix/body_checks
    content_filter = amavis:[127.0.0.1]:10024
    receive_override_options = no_address_mappings
    message_size_limit = 0
    Die smtp.conf
    Code:
    pwcheck_method: saslauthd
    mech_list: plain login
    allow_plaintext: true
    auxprop_plugin: mysql
    sql_hostnames: 127.0.0.1
    sql_user: ispconfig
    sql_passwd: *zensiert*
    sql_database: dbispconfig
    sql_select: select password from mail_user where email = '%u'
    Die saslauthd:
    Code:
    START=yes
    DESC="SASL Authentication Daemon"
    NAME="saslauthd"
    MECHANISMS="pam"
    OPTIONS="-c -m /var/spool/postfix/var/run/saslauthd -r"
    Hab ich vielleicht etwas falsch eingestellt?
    Das senden über roundcube geht allerdings einwandfrei, es ziggt nur Thunderbird rum.
     
    Zuletzt bearbeitet: 10. Nov. 2009
  2. DripleX

    DripleX New Member

    Sorry wg. Doppelpost wollte nur was aktuelles sagen.

    Ich hab bemerkt, dass die Einstellungen von beiden SMTP Postfächer nicht identisch sind. Ich kann nur Mails versenden, wenn ich "Verschlüsselte Verbindung benützen" auf "Nie" stelle.
    D.h. bei mir funktioniert kein TLS.

    Was muss ich tun, damit dies funktioniert?
     
  3. Till

    Till Administrator

    Poste mal die Ausgabe von:

    ls -la /etc/postfix
     
  4. DripleX

    DripleX New Member

    Hier die Ausgabe von ls -la /etc/postfix

    Code:
    server1:~# ls -la /etc/postfix
    insgesamt 196
    drwxr-xr-x  5 root root     4096 17. Nov 15:14 .
    drwxr-xr-x 88 root root     4096 10. Nov 05:58 ..
    -rw-r--r--  1 root root        0 18. Okt 10:24 body_checks
    drwxr-xr-x  6 root root     4096 27. Sep 22:26 demoCA
    -rw-r--r--  1 root root      373 19. Sep 13:26 dynamicmaps.cf
    -rw-r--r--  1 root root        0 18. Okt 10:24 header_checks
    -rw-r--r--  1 root root     3625 17. Nov 15:14 main.cf
    -rw-r--r--  1 root root     3604 18. Okt 10:24 main.cf~
    -rw-r--r--  1 root root     3604 18. Okt 10:24 main.cf~2
    -rw-r--r--  1 root root     5003 18. Okt 10:24 master.cf
    -r--------  1 root root     5003 18. Okt 10:24 master.cf~
    -rw-r--r--  1 root root        0 18. Okt 10:24 mime_header_checks
    -rw-r-----  1 root postfix   231 18. Okt 10:24 mysql-virtual_client.cf
    -rw-r-----  1 root postfix   231 18. Okt 10:24 mysql-virtual_client.cf~
    -rw-r-----  1 root postfix   221 18. Okt 10:24 mysql-virtual_domains.cf
    -rw-r-----  1 root postfix   221 18. Okt 10:24 mysql-virtual_domains.cf~
    -rw-r-----  1 root postfix   218 18. Okt 10:24 mysql-virtual_email2email.cf
    -rw-r-----  1 root postfix   218 18. Okt 10:24 mysql-virtual_email2email.cf~
    -rw-r-----  1 root postfix   230 18. Okt 10:24 mysql-virtual_forwardings.cf
    -rw-r-----  1 root postfix   230 18. Okt 10:24 mysql-virtual_forwardings.cf~
    -rw-r-----  1 root postfix   287 18. Okt 10:24 mysql-virtual_mailboxes.cf
    -rw-r-----  1 root postfix   287 18. Okt 10:24 mysql-virtual_mailboxes.cf~
    -rw-r-----  1 root postfix   252 18. Okt 10:24 mysql-virtual_recipient.cf
    -rw-r-----  1 root postfix   252 18. Okt 10:24 mysql-virtual_recipient.cf~
    -rw-r-----  1 root postfix   224 18. Okt 10:24 mysql-virtual_relaydomains.cf
    -rw-r-----  1 root postfix   224 18. Okt 10:24 mysql-virtual_relaydomains.cf~
    -rw-r-----  1 root postfix   249 18. Okt 10:24 mysql-virtual_sender.cf
    -rw-r-----  1 root postfix   249 18. Okt 10:24 mysql-virtual_sender.cf~
    -rw-r-----  1 root postfix   227 18. Okt 10:24 mysql-virtual_transports.cf
    -rw-r-----  1 root postfix   227 18. Okt 10:24 mysql-virtual_transports.cf~
    -rw-r--r--  1 root root        0 18. Okt 10:24 nested_header_checks
    -rw-r--r--  1 root root    18231 14. Sep 2008  postfix-files
    -rwxr-xr-x  1 root root     7421 14. Sep 2008  postfix-script
    -rwxr-xr-x  1 root root    22774 14. Sep 2008  post-install
    drwxr-xr-x  2 root root     4096 17. Nov 15:15 sasl
    -rw-r--r--  1 root root     3282 27. Sep 22:26 server-crt.pem
    -r--------  1 root root      891 27. Sep 22:26 server-key.pem
    -rw-r--r--  1 root root      798 27. Sep 22:26 server-req.pem
    -rw-r--r--  1 root root     1554 19. Sep 13:48 smtpd.cert
    -rw-r-----  1 root root     1675 19. Sep 13:48 smtpd.key
    drwxr-xr-x  3 root root     4096 15. Nov 10:23 ssl
    
     
  5. DripleX

    DripleX New Member

    mh.... hat keiner eine Ahnung, was bei mir nicht funktioniert bzw. ob etwas falsch eingestellt ist? :confused:
     
  6. Till

    Till Administrator

    In Der Datei master.cf musst das Kommentarzeichen vor der Zeile smtps und tlsmgr entfernt werden. Dann postfix neu starten.
     
  7. DripleX

    DripleX New Member

    Danke, die Zeile mit smtps war auskommentiert.

    Nun funktioniert es. Danke Nochmal!
     

Diese Seite empfehlen