TPS CentOS 6.4 (Dovecot) Kein SMTP möglich + viele shared libraries fehler

lehan

New Member
#1
Hallo,

habe nach obiger Anleitung den Server installiert.
Habe nun bereits den zweiten Fehler beim Thema E-Mails.

1. Fehler (ist aber hoffentlich bereits behoben) war folgende Meldung (in einer "Undelivered Mail Returned to Sender"-Nachricht:
Code:
 Command died with status 127:     "/usr/libexec/dovecot/deliver". Command output:     /usr/libexec/dovecot/deliver: error while loading shared libraries:     libdovecot-lda.so.0: cannot open shared object file: Error 23
Hatte den Fehler auch ab und zu bei einem einfachen ll bzw. ls -la. Habe jetzt das Verzeichnis in dem die libdovecot-lda.so.0 liegt manuell in die /etc/ld.so.conf eingetragen. Hoffe das es nun funktioniert.


2. Fehler
Ich kann mich nicht über SMTP einloggen. Mails versenden über Webinterface geht ohne Probleme. Aber es ist kein Login via SMTP möglich.
Ports sind an der firewall freigeschaltet.
netstat -ntap
Code:
[root@hosting /]# netstat -ntap | grep dovecot
tcp        0      0 0.0.0.0:993                 0.0.0.0:*                   LISTEN      1628/dovecot
tcp        0      0 0.0.0.0:995                 0.0.0.0:*                   LISTEN      1628/dovecot
tcp        0      0 0.0.0.0:110                 0.0.0.0:*                   LISTEN      1628/dovecot
tcp        0      0 0.0.0.0:143                 0.0.0.0:*                   LISTEN      1628/dovecot
tcp        0      0 1.2.3.4:143           5.6.7.8:5859            ESTABLISHED 23850/dovecot/imap-
tcp        0      0 1.2.3.4:143           5.6.7.8:5864            ESTABLISHED 23867/dovecot/imap-
tcp        0      0 1.2.3.4:143           5.6.7.8:5878            ESTABLISHED 23959/dovecot/imap-
tcp        0      0 1.2.3.4:143           5.6.7.8:5872            ESTABLISHED 23942/dovecot/imap-
tcp        0      0 1.2.3.4:143           5.6.7.8:5873            ESTABLISHED 23944/dovecot/imap-
tcp        0      0 127.0.0.1:995               127.0.0.1:41535             ESTABLISHED 23847/dovecot/pop3-
tcp        0      0 1.2.3.4:143           5.6.7.8:56650           ESTABLISHED 15867/dovecot/imap-
tcp        0      0 :::993                      :::*                        LISTEN      1628/dovecot
tcp        0      0 :::995                      :::*                        LISTEN      1628/dovecot
tcp        0      0 :::110                      :::*                        LISTEN      1628/dovecot
tcp        0      0 :::143                      :::*                        LISTEN      1628/dovecot
Versuche ich auf Port 25 zu connecten, finde ich folgenden Fehler im Log:

Code:
May  1 16:38:42 hosting dovecot: imap-login: Error: dovecot/imap-login: error while loading shared libraries: libssl.so.10: cannot open shared object file: Error 23
May  1 16:38:42 hosting dovecot: master: Error: service(imap-login): child 24225 returned error 127
Erhalte im Thunderbird einen Timeout wenn ich über 25 connecte. Über die anderen Ports kommt keinerlei Verbindung zustande (und auch nichts in den Logs).

Warum sind bekomme ich soviele "loading shared libraries" Fehler? Muss ich jetzt jedes shared librarie manuell in die /etc/ld.so.conf aufnehmen?

Dankbar um jede Hilfe!

Viele Grüße


Edit:

Habe jetzt noch ein bischen die Logs beobachtet: habe wieder viele Fehler:

Code:
May  1 16:43:42 hosting dovecot: imap-login: Error: dovecot/imap-login: error while loading shared libraries: libdovecot-login.so.0: cannot open shared object file: No such file or directory
May  1 16:43:42 hosting dovecot: master: Error: service(imap-login): child 24273 returned error 127
May  1 16:43:42 hosting dovecot: master: Error: service(imap-login): command startup failed, throttling
May  1 16:43:42 hosting dovecot: ssl-params: Error: dovecot/ssl-params: error while loading shared libraries: libdovecot.so.0: cannot open shared object file: No such file or directory
May  1 16:43:42 hosting dovecot: master: Error: service(ssl-params): child 24274 returned error 127
May  1 16:43:42 hosting dovecot: master: Error: service(ssl-params): command startup failed, throttling
May  1 16:43:42 hosting dovecot: imap-login: Fatal: Corrupted SSL parameters file: /var/lib/dovecot/ssl-parameters.dat
May  1 16:44:01 hosting postfix/master[1740]: warning: process /usr/libexec/postfix/smtpd pid 24277 exit status 127
May  1 16:44:01 hosting postfix/master[1740]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
May  1 16:44:02 hosting master[24279]: fatal: master_spawn: exec /usr/libexec/postfix/showq: Too many open files in system
May  1 16:44:02 hosting postfix/master[1740]: warning: process /usr/libexec/postfix/anvil pid 24278 exit status 127
May  1 16:44:02 hosting postfix/master[1740]: warning: /usr/libexec/postfix/anvil: bad command startup -- throttling
May  1 16:44:03 hosting postfix/master[1740]: warning: process /usr/libexec/postfix/showq pid 24279 exit status 1
May  1 16:44:03 hosting postfix/master[1740]: warning: /usr/libexec/postfix/showq: bad command startup -- throttling
Warum jetzt wieder libdovecot.so.0?? Habe das Verzeichnis doch hinzugefügt! Was ist hier los?

Danke!
 
Zuletzt bearbeitet:

Werbung