typo3 und suphp auf ispconfig, geht das

Dieses Thema im Forum "Allgemein" wurde erstellt von Rupertt, 2. Feb. 2011.

  1. Rupertt

    Rupertt New Member

    Hallo,

    ich wollte gerade eine zentrale typo3 auf meinr ispconfig3 Umgebung installieren.

    Die erste Instanz habe ich am laufen, als ich nun den 2ten Client einrichten möchte bekomme ich folgenden Error:

    Code:
    [Wed Feb 02 14:50:22 2011] [error] [client 192.168.1.30] SoftException in Application.cpp:405: Mismatch between target UID (5034) and UID (5016) of file "/srv/www/clients/client5/web81/web/typo3/install/index.php"
    [Wed Feb 02 14:50:22 2011] [error] [client 192.168.1.30] Premature end of script headers: index.php
    
    Die Frage ist welche Berechtigungen die sourcen im hauptrepository haben müssen damit typo3 sauber läuft?



    Gruß
     
  2. Moestchen

    Moestchen New Member

    Hast du den Pfad deiner Typo3-sourcen im openbasedir deines webs aufgenommen?
     
  3. Rupertt

    Rupertt New Member

    ja, problem ist ja das die zentralen sourcen dem ersten User gehören und suphp will die nicht ausführen, weil es ja nur dateien ausführt die dem User gehören der auch php ausführt.
     
  4. Moestchen

    Moestchen New Member

    Und wenn du dir:
    1. auf der shell für die sourcen einen neuen user + gruppe anlegst, z.b. www-typo3 und
    2. diesen user dann der Gruppe deines webs hinzfügst
    dann sollte es doch gehen, oder?
    Hatte es so glaube ich mal auf meinem alten Server zu laufen. Auf dem neuen bin ich noch icht zur Einrichtung gekommen.
     
  5. Till

    Till Administrator

    Jede Typo3 Installation sollte seine eigenen sourcen haben. Zentrale Sourcen sind sehr unsicher da du dafür alle Sicherheitsmaßnahmen für die webseites wie suexec oder suphp entfernen müsstest und auch alle Webs auf diese sourcen zugreifen können müssten. Das
    bedeutet dann, sollte jemals eine der typo3 installationen einen security bug in einem der addons haben, verlierst Du bei einem Hack alle Websites.

    Also würde ich Dir empfehlen grundsätzlich getrennte sourcen für Typo3 zu verwenden. Ich mache das seit vielen Jahren so und hab damit gute Erfahrungen gemacht.
     
  6. Rupertt

    Rupertt New Member

    Hallo,

    danke für den input.
    Auf die Sicherheit wollen wir nicht verzichten, daher werden es dann doch einzelne Installationen. Dachte mir schon das ich suphp usw. ziemlich abspecken muss um das zum laufen zu bekommen.

    DIe Seite läuft jetzt aus suphp, einzige problem bis hier ist das das phpmyadmin plugin nicht tut, ich bekomme folgende meldung.

    Code:
    Die Sitzung konnte nicht ohne Fehler gestartet werden, schauen Sie  bitte in das Fehlerprokoll von PHP und/oder Ihres Webservers und  konfigurieren Sie PHP entsprechend (session.save_path, Schreibrechte).
    
    der typo3tmp ordner hat schreiberechte für den user
     
    Zuletzt bearbeitet: 3. Feb. 2011
  7. Till

    Till Administrator

    Ich würde Dir raten das web von suphp auf php-fcgi + suexec umzustellen, das ist deutlich schneller und macht quasi das gleiche wie suphp, nur dass es einen fcgi php prozess gibt und daher php nicht bei jedem request neu gestartet werden muss. Ich verwende die kombination bei diversen Typo3 Installationen.

    Zur phpmyadmin Fehlermeldung:

    1) mach mal den webbrowser komplett zu und logge dich danach mal neu in typo3 ein. Wenn der phpmode oder so geändert worden ist, dann kann es sein dass die session dem falschen Linux User gehört.

    2) Wenn 1) nicht hilft, dann erstelle mal eine phpinfo() Datei und scahu nach, auf welches Verzeichnis der session.save_path gesetzt ist.
     
  8. Moestchen

    Moestchen New Member

    Hallo Till,
    da ich gerade dabei war meine TYPO3-Installationen zu planen, komme ich nochmal darauf zurück.
    Gerade unter Unix/Linux ist doch der Vorteil durch die Symlinks auf die zentralen Sourcen, das mit einem Update alle webs geupdatet werden und dies nicht einzeln gemacht werden muss oder man doch mal ein Web vergisst!?

    Habs jetzt nicht nochmal ausprobiert, aber ist der Weg mit dem zusätzlichen User verkehrt bzw. nicht funktionsfähig?
     
  9. Till

    Till Administrator

    Du kannst zentrale sourcen nur verwenden wenn alle Webs unter einem User laufen, also z.B. mit mod_php. das ist aber sehr unsicher da Du dann eben alle Funktionen zur Isolierung der web Prozesse deaktivieren musst. Daher ist es keine gute Idee mit einem einzigen source Directory für alle Installationen zu arbeiten. Außerdem schafft das noch einige weitere Probleme, nämlich dann wenn mal eine der Installationen mit den neuen Sourcen nicht funktioniert.

    Das Symlink setup bei typo3 nimmt man im allgemeinen ja nicht dafür dass sich mehrere webs die sourcen teilen sondern damit sich ein einzenles web besser updaten lässt. Nämlich indem Du die neuen sourcen einfach parallel installierst und dann nur den symlink änderst. Im Falle eines Fehlers hast Du dann nämlich nicht die alte Installation überschrieben und kannst den Symlink einfach wieder zurück ändern, bis das problem behoben ist.
     
  10. Rupertt

    Rupertt New Member

    Hallo,

    ich habe das jetzt auf suexec mit fcgi laufen, geht alles bis auf die uplods, typ3 sagt nur "fehler 303" aber keine meldungen in den logfiles o.ä.

    Ich habe die rechte auch schon für die Gruppe auf w gesetzt, hilft aber noch nicht.

    DAs ganze läuft in einer chroot Umgebung mit jailkit
     
    Zuletzt bearbeitet: 4. Feb. 2011
  11. Till

    Till Administrator

    das ist nicht notwendig, da die scripte unter dem User des webs laufen.

    Du meinst für ssh user? Das hat auf apache keinen Einfluß.

    Zu Deinem upload problem: Führe bitte aus:

    chown -R web1:client1 /var/www/deinedomain.de/web

    wobei Du den Pfad sowie User und Gruppe anpassen musst.
     
  12. Rupertt

    Rupertt New Member

    k, danke.

    Leider hat das anpassen der rechte nichts genutzt.

    Es kommt eine kurze Meldung "zu viele Dateien", dann das typo3 Fehlerfenster mit der 303.
    ----
    Laut manuel müsste ich ja folgende Option in den custom php.ini settings stehen haben können:

    upload_max_filesize 16M

    dies scheint aber auch nicht zu greifen.
     
  13. Till

    Till Administrator

    Erhöhe auch mal die max post size auf 16M. Und denk daran dass Änderungen ca. 1 Minute brauchen, um geschrieben zu werden.
     
  14. Rupertt

    Rupertt New Member

    leider auch ohne erfolg.
    Im Installtool werden alle Folder grün markiert, anlegen von Dateien im Backend geht auch.
    Ich glaub langsam an einen Fehler im typo.


    gruß
     
  15. Till

    Till Administrator

    Kann mir kaum vorstelen das bei sowas grundlegendem ein Bug in typo3 ist. Aber ich weiß leider auch nicht was genau die da überprüfen das zu dem Fehler führt.

    Und das memory Limit ist auch hoch genug?

    Checke bitte nochmal die erzeugte php.ini Datei (pfad siehst Du im phpinfo() ) und starte mal apache auf der shell neu.
     

Diese Seite empfehlen