Überwachung -> Mailwarteschlange

Dieses Thema im Forum "Allgemein" wurde erstellt von ralf-isi, 29. Juli 2011.

  1. ralf-isi

    ralf-isi New Member

    Hallo zusammen

    Bei mir läuft ISPConfig Version: 3.0.3.2 auf openSUSE 11.2 im Grossen und Ganzen einfandfrei.
    Zu den anstehenden Mail - 'Problemen' werde ich für jedes einzelne einen Beitrag eröffnen und bedanke mich schon jetzt für die Hilfe.

    Zum Ersten:
    Der Server mit dem ISPConfig läuft hier im Hause im internen Netzwerk (192.168.2.x) hinter einer IPCop - Firewall die den Zugang von Aussen regelt. Funktioniert auch alles bestens.

    Doch ich finde immer wieder solche Einträge unter Überwachung -> Mailwarteschlange:
    Code:
    -Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
    5AD9660850    18289 Wed Jul 27 00:00:31  webmaster@domain.ch
    (host 127.0.0.1[127.0.0.1] said: 451 4.5.0 Error in processing,  id=04318-11, virus_scan FAILED: virus_scan: ALL VIRUS SCANNERS FAILED:  ClamAV-clamd av-scanner FAILED: run_av error: Too many retries to talk  to /var/run/clamav/clamd (Can't connect to UNIX socket  /var/run/clamav/clamd: No such file or directory) at (eval 101) line  325.; ClamAV-clamscan av-scanner FAILED: run_av error: run_av: Exceeded  allowed time at (eval 101) line 532. (in reply to end of DATA command))
                                             empfaenger@domain1.ch
    Wie behebe ich das?

    Viele grüsse
    ralf
     
  2. Till

    Till Administrator

    Start mal calamav neu und scahu in die clamav logs.
     
  3. ralf-isi

    ralf-isi New Member

    BINGO
    Danke Till - das war es.
    Nicht ganz kar ist mir jedoch wieso der Dienst gestoppt war (im Runlevel auf Nein) jedoch ist auch die grafische Oberfläche ausgefallen. Nun funktioniert es wieder und ich denke, ich kann mich mit den nächsten 'Problemen' befassen.

    Im Mail-Warn - Protokoll finde ich Einträge die so lauten:
    Zum grössten Problem (Mails werden nicht zugestellt) mache ich dann mal einen eigenen Tread auf.

    Wünsche schon jetzt allen ein schönes Wochenende
    ralf
     
  4. ralf-isi

    ralf-isi New Member

    Hab ich mich zu früh gefreut?

    IM Mail-Error - Protokoll steht:
    Da stimmt doch was nicht?

    Danke für die Hilfe zur Bereinigung.
    ralf
     
  5. Till

    Till Administrator

    Zum Fehler mit der canonical datei, diese Datei gehört nicht zu ISPConfig. Schau mal wo sie in der postfix main.cf drin steht und nimm sie da ggf mal raus.

    Zum ClamAV Fehler, poste mal die Ausgabe von:

    ls -la /var/run/clamav/
     
  6. ralf-isi

    ralf-isi New Member

    Hallo Till

    danke für Deine Zeit und Hilfestellung.

    Irgendwas scheint da schon nicht in Ordnung zu sein. Beim stöbern hab ich gefunden, dass man in main.cf von postfix
    Code:
    smtpd_bind_adress = 123.456.789.00
    eintragen soll. Hab ich gestern mal gemacht, logisch auf die öffentliche IP.

    In der main.cf ist das das Einzigste was ich finde
    Code:
    canonical_maps = hash:/etc/postfix/canonical
    Meinst Du das ausschalten?
    Im Dir liegen 2 File canonical und canonical.db das erste stammt vom 10. Mai, das 2-te vom 6. März.

    Code:
    ls -la /var/run/clamav/ 
    bringt die Fehlermeldung, dass dies nicht gefunden wurde. Calmd läuft jedoch ganz sicher.

    Daher kommen wohl auch diese Fehlermeldungen:
    und auch dies:
    Soll ich die main.cf von Postfix wegsichern, Postfix löschen und neu installieren?

    Bin dankbar für jede Hilfe und Grüsse
    ralf
     
  7. Till

    Till Administrator

    Zu Canonical maps.

    Kommentier die canonical maps bitte mal in der main.cf aus und starte postfix neu.

    Zu clamav: Wahrscheinlich verwendet der Clamav bei Dir ein anderes Verzeichnis. da bei openSuSE die Pakete zum Teil aus dem Buildservice kommen, kann das je nach maintainer variieren. Du müsstest slao mal versuchen das Socket von Deinem clamd zu finden und dann den Pfad in der amavisd Konfiguration anpassen. Den Pfad zum clamd Socket könntest Du möglicherweise irgendwo in der clamav bzw. clamd Konfigurationsdatei finden.

    zum pop3d Problem, erhähe bitte das connection Limit in der courier pop3 Konfigurationsdatei.

    Postfix neu zu installieren wird nichts bringen, also das besser nicht machen.
     
  8. ralf-isi

    ralf-isi New Member

    Hallo Till

    ich bedanke mich (ein mal Mehr!) bei Dir für die Hilfe. Ist schon toll und ich muss mal schauen, dass Deine Café-Tasse nicht so viel Luft drin hat.

    Ich habe alle Deine Empfehlungen befolgt, Änderungen gemacht, Dienste neu gestartet und zum Schluss die ganze Kiste neu gebootet.

    Und was habe ich?
    - mal wieder etwas gelernt dank Dir.
    - etwas mehr Ahnung vom Ganzen (auch dank Dir).
    - absichtlich etwas gewartet und das (Mail-)System getestet, gestresst.
    - noch kein Sicherheit ob nun alles im Grünen ist.

    Aber langsam:
    gemacht und ich finde auch keine Einträge mehr dazu. Scheint allso zu passen.
    Stimmt, liegt unter /var/lib/clamav und heisst wohl clamd.pid den Pfad eingetragen (ohne .pid)
    Danke. die 4 auf 10 erhöht weil ich mal annehme, dass keine Domain mehr wie 10 Postfächer hat die vom gleichen User(/IP) abgefragt werden.
    Mache ich auch lieber nicht .... so faul bin ich. :)

    Der letzte Eintag im Mail-Error Protokoll lautet:
    doch der ist nun fast eine Stunde alt und seit dem wurde das System auch neu gebootet.

    Scheint also zu laufen. Ich habe mal an mehrere Accounts Mail gesandt. Alle angekommen. Bis auf eine mit einem Anhang >5MB nicht, auf die warte ich noch.

    Ich behalte das Ganze mal im Auge.

    Welches BS ist eigentlich das Beste / macht am wenigsten Probleme um ISPConfig darauf laufen zu lassen? (Mir graut jetzt schon vor dem Umzug :) )

    Vielen Dank für die Bemühungen und Hilfe, viele Grüsse vom National-Feiertag ... äh aus der Schweiz
    ralf
     
  9. Till

    Till Administrator

    Debian Linux.
     
  10. ralf-isi

    ralf-isi New Member

    Danke. Dann mache ich mich in einer stillen Minute mal schlau zum Thema umziehen.

    Nun sollte bei mir E-Mail eigentlich funktionieren. Im Mail-Warn steht nur noch das drin:
    Kann ich die im config-file ebenfalls ausschalten?

    Nochmals vielen Dank für die Hilfe und einen schönen Tag wünscht
    ralf
     
  11. Till

    Till Administrator

    Ja, die sind auch beide nicht von ISPConfig.
     

Diese Seite empfehlen