ufw alle Ports gesperrt

#1
Hallo,

ich habe in Server config die Firewall auf ufw umgestellt. Immer wenn ich dann über ISPConfig die Firewall aktiviere, dann werden sämtliche Ports auf der Maschine geblockt.

Ich sehe zwar über die Konsole das die Ports auf allow tcp stehen aber die Maschine macht komplett dicht. Erst wenn ich über die Konsole ufw wieder deaktiviere, dann komme ich per SSH auf die Maschine.

Hat jemand eine Idee?
 
#3
Habe ich schon gemacht.

Ich habe den Record gelöscht, dann ein paar Minuten gewartet und wieder neu angelegt. Danach sind alle Ports auf der Maschine dicht.

Wenn ich auf der Console "ufw status" ausführe, dann sehe ich die Portfreigaben aber die Maschine ist komplett dicht.
 

Till

Administrator
#4
dann muss irgend was generell mit ufw nicht funktionieren, denn ispconfig konfiguriert die ports ja auch nur über die normalen ufw kommandos. Ist das ein virtueller server?
 

Till

Administrator
#6
komisch, wenn eine neue firewall in ispconfig angelegt wird macht ispconfig folgendes:

exec('ufw --force disable');
exec('ufw --force reset');
exec('ufw default deny incoming');
exec('ufw default allow outgoing');

und dann wedren alle tcp und udp ports einer nach dem anderen eigefügt:

exec('ufw allow '.$port.'/tcp');

exec('ufw allow '.$port.'/udp');

und zum schluss:

exec('ufw reload');

sollte an sich alles sein.
 
#7
Ich habe jetzt mal etwas herumgetestet.

Ich habe jetzt herausgefunden, das sowohl über ISPConfig als über die Konsole angelegte Regeln dazu führen, dass der Server dicht macht.

Ich verstehe nur nicht warum.
 

Till

Administrator
#8
Was für eine Virtualisierung? Und bist Du sicherass Du überhaupt eine firewall brauchst, wenn Du nur die Dienste laufen hast die auch für Kunden erreichbar sein sollen, bringt Dir eine Firewall nichts.
 
#9
Es ist eine Parallels Virtualisierung.

Über die Firewall laufen ein paar Skripte um böse Jungs auszusperren. Sicherlich könnte man das auch per iptables lösen aber ufw wäre schon schön.
 

Werbung

Top