UFW keine Funktion unter Ispconfig 3.1a1

#1
Guten Morgen zusammen
Habe mich für UFW entschieden wegen dem ipv6 Support nach dem Installieren und Updaten hat Ispconfig 3 UFW erkannt. In Ispconfig 3 sehen die Regeln so aus:
Code:
http://pastebin.com/XUxQhg95
Auf der Command sieht es aber so aus:
Code:
Status: active

To                         Action      From
--                         ------      ----
22                         ALLOW       Anywhere
80/tcp                     ALLOW       Anywhere
8080/tcp                   ALLOW       Anywhere
22                         ALLOW       Anywhere (v6)
80/tcp                     ALLOW       Anywhere (v6)
8080/tcp                   ALLOW       Anywhere (v6)
Scheinbar übergibt Ispconfig 3 die regeln zu der UFW nicht.

LG
 

Till

Administrator
#2
Hast Du die firewall in ispconfig entfernt (also in der ispconfig ui gelöscht) bevor Du gewechselt bist? UFW ist statisch, der liets also keine bestehende firewall ein. Du musst sie entfernen, dann unter system > server config auf ufw umschalten und dann die firewall neu anlegen.
 
#3
Ich habe nichts entfernt ich habe erst die ufw installiert und dann ispconfig installiert. hmmm da gibt es ein Problem in der 3.1a1 Funktioniert system > server config nicht wenn ich dort mein Server auswähle und klicke passiert Garnichts ;-)
 
#4
In den Logs konnte ich folgendes entnehmen:
Code:
mod_fcgid: stderr: PHP Parse error:  syntax error, unexpected ';', expecting ')' in /usr/local/ispconfig/interface/web/admin/form/server_config.tfor$
 
#7
Habe es geändert und jetzt komme ich in die Einstellung rein.

Hast Du die firewall in ispconfig entfernt (also in der ispconfig ui gelöscht) bevor Du gewechselt bist? UFW ist statisch, der liets also keine bestehende firewall ein. Du musst sie entfernen, dann unter system > server config auf ufw umschalten und dann die firewall neu anlegen.
Habe ich so gemacht aber dir Firewall übernimmt nichts:
Code:
root@sv01:~# ufw status
Status: active
 
#8
Hast Du firewall_plugin.inc.php in /usr/local/ispconfig/server/plugins-enabled ?

Wenn nicht, dann mach mal
Code:
ln -s /usr/local/ispconfig/server/plugins-available/firewall_plugin.inc.php /usr/local/ispconfig/server/plugins-enabled
 
#12
Habe da noch ein Fehler drin ich habe den FTP Port bei mir geändert im Ispconfig habe ich es der Firewall auch mitgeteilt und UFW hat es übernommen kann aber bei Aktivierter UFW nicht Verbinden wenn ich UFW Deaktiviere Funktioniert es.

LG
 

Till

Administrator
#20
So, habe es gerade mal getestet, ich kann problemlos ":" für Port Ranges in 3.1a1 angeben in der Firewall. Vielleicht hattest Du ja irgendwo ein leerzeicehn drin?
 

Werbung

Top