UFW keine Funktion unter Ispconfig 3.1a1

Dieses Thema im Forum "Entwicklerforum" wurde erstellt von mzips, 22. März 2016.

  1. mzips

    mzips Member

    Guten Morgen zusammen
    Habe mich für UFW entschieden wegen dem ipv6 Support nach dem Installieren und Updaten hat Ispconfig 3 UFW erkannt. In Ispconfig 3 sehen die Regeln so aus:
    Code:
    http://pastebin.com/XUxQhg95
    
    Auf der Command sieht es aber so aus:
    Code:
    Status: active
    
    To                         Action      From
    --                         ------      ----
    22                         ALLOW       Anywhere
    80/tcp                     ALLOW       Anywhere
    8080/tcp                   ALLOW       Anywhere
    22                         ALLOW       Anywhere (v6)
    80/tcp                     ALLOW       Anywhere (v6)
    8080/tcp                   ALLOW       Anywhere (v6)
    
    Scheinbar übergibt Ispconfig 3 die regeln zu der UFW nicht.

    LG
     
  2. Till

    Till Administrator

    Hast Du die firewall in ispconfig entfernt (also in der ispconfig ui gelöscht) bevor Du gewechselt bist? UFW ist statisch, der liets also keine bestehende firewall ein. Du musst sie entfernen, dann unter system > server config auf ufw umschalten und dann die firewall neu anlegen.
     
  3. mzips

    mzips Member

    Ich habe nichts entfernt ich habe erst die ufw installiert und dann ispconfig installiert. hmmm da gibt es ein Problem in der 3.1a1 Funktioniert system > server config nicht wenn ich dort mein Server auswähle und klicke passiert Garnichts ;-)
     
  4. mzips

    mzips Member

    In den Logs konnte ich folgendes entnehmen:
    Code:
    mod_fcgid: stderr: PHP Parse error:  syntax error, unexpected ';', expecting ')' in /usr/local/ispconfig/interface/web/admin/form/server_config.tfor$
    
    
     
  5. Till

    Till Administrator

    Ist bekannt, steht im Bugtracker.
     
  6. florian030

    florian030 Member

    Ich hab damit keine Probleme. Zu dem Fehler: ersetz mal in der Datei in Zeile 173 das Semikolon durch ein Komma. So
     
  7. mzips

    mzips Member

    Habe es geändert und jetzt komme ich in die Einstellung rein.

    Habe ich so gemacht aber dir Firewall übernimmt nichts:
    Code:
    root@sv01:~# ufw status
    Status: active
     
  8. florian030

    florian030 Member

    Hast Du firewall_plugin.inc.php in /usr/local/ispconfig/server/plugins-enabled ?

    Wenn nicht, dann mach mal
    Code:
    ln -s /usr/local/ispconfig/server/plugins-available/firewall_plugin.inc.php /usr/local/ispconfig/server/plugins-enabled
     
  9. mzips

    mzips Member

    Danke das war es was mir fehlte warum weshalb keine Ahnung aber dank dir funzt es tadelos bin beeindruckt danke dir.
     
  10. florian030

    florian030 Member

    Das hat gefehlt, weil ufw beim install nicht vorhanden war und das plugin deswegen auch nicht aktiviert wurde.
     
  11. mzips

    mzips Member

    Leider doch ich habe vor der Ispconfig Installation UFW Installiert
     
  12. mzips

    mzips Member

    Habe da noch ein Fehler drin ich habe den FTP Port bei mir geändert im Ispconfig habe ich es der Firewall auch mitgeteilt und UFW hat es übernommen kann aber bei Aktivierter UFW nicht Verbinden wenn ich UFW Deaktiviere Funktioniert es.

    LG
     
  13. robotto7831a

    robotto7831a Member

    Ist der Port auch bei UFW eingetragen?
     
  14. mzips

    mzips Member

    Ja ist eingetragen das ist ja das was mich wundert
     
  15. robotto7831a

    robotto7831a Member

    Und UFW hat die ISPConfig Einstellung auch übernommen?

    FTP benötigt mehrere Ports. Hast Du alle freigeschaltet?
     
  16. mzips

    mzips Member

    Ist es richtig das FTP port 20 und 21 braucht?
    Ich habe den 21 auf 18*** umgestellt und auch in der Firewall den Port hinzugefügt
     
  17. mzips

    mzips Member

  18. robotto7831a

    robotto7831a Member

    @Till Das wäre dann aber ein Bug. In der alten Version funktioniert der Doppelpunkt.
     
  19. Till

    Till Administrator

    Ja, wenn das nicht geht dann ist es ein bug.
     
  20. Till

    Till Administrator

    So, habe es gerade mal getestet, ich kann problemlos ":" für Port Ranges in 3.1a1 angeben in der Firewall. Vielleicht hattest Du ja irgendwo ein leerzeicehn drin?
     

Diese Seite empfehlen