Umlaute mit übernehmen bei Export- u. Import MySQL

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von ZauberFee, 9. Mai 2008.

  1. ZauberFee

    ZauberFee New Member

    Hallo,

    ich habe von meinem alten MYSQL-Server (MySQL - 5.0.18) auf den neuen
    MySQL-Server (Server Version: 5.0.32) unter ISPConfig unter der Perfekt-
    Debian Installation nachfolgendes Problem mit dem Zeichensatz wohl - die
    Umlaute werden größtenteils als "?" ausgegeben.

    Ich habe den Export im Shell des alten Servers mit nachfolgendem Kommando
    durchgeführt:

    Code:
    mysqldump --user=root --password=looser05 usr_web3_1 >mysql.sql
    
    ..und danach auf dem "neuen" Server via Shell diesen wieder eingespielt, es
    wurden keine Fehler beim Import ausgegeben:

    Code:
    mysql --user=web3u1 --password=babuschka --database=web3db1 <mysql.sql
    
    Ich habe auch schon probiert, mit "--default-character-set=utf8" bei Import
    sowie als auch Export zu nutzen, aber ohne Erfolg.

    Das auf dem "web3" installierte Forum läuft soweit zwar, aber alle Umlaute
    werden halt als "?" ausgegeben - jemand eine Idee?

    so long,
    ZauberFee.
     
  2. Till

    Till Administrator

    Stell bitte sicher dass der default characterset in der my.cnf Datei auf dem aletn und neuen Server gleich ist.
     
  3. ZauberFee

    ZauberFee New Member

    Hi,

    ich vermute mal, das der Eintrag "language=xxxx" damit gemeint ist? :)

    so long,
    ZauberFee.
     

Diese Seite empfehlen