Umlaute werden im "ISP Server Status" nicht richtig dargestellt

#1
Auf der Startseite werden in der Übersicht die Umlaute in der Tabelle für das Dateisystem nicht richtig dargestellt.

Grund sind die verschiedenen Charsets die verwendet werden.

Der User "admispconfig" unter dem der Apache - Server läuft, hat wohl als DefaultCharset "UTF-8". In der httpd.conf habe ich "AddDefaultCharset ISO-8859-1" eingetragen, damit die Umlaute aus den Konfigurations-Dateien für die Sprache richtig dargestellt werden. Dann noch in der Datei
/home/admispconfig/ispconfig/lib/plugins/check_disk.plugin.php Zeile 79 durch diese
if($mln < 6 and $value != "") $html_out .= '<td bgcolor="#FFFFFF" class="'.$font_class.'" align="'.$align.'">'.iconv("UTF-8", "ISO-8859-1", $value).'</td>';
ersetzen.

Eigentlich muß man nur in der angegebenen Zeile "$value" durch "iconv("UTF-8", "ISO-8859-1", $value)" ersetzen.

dann sieht das alles wieder hübsch aus.
 
#3
Habe Heute
ISPConfig
Version: 2.2.21
(c) ISPConfig 2008
installiert.

Gleiches Problem, wie oben beschrieben. Aber es gibt ja eine Lösung dafür, ein Neustart ist es nicht.
 

hahni

Active Member
#4
warum ist der fehler dann bei mir merkwürdigerweise seit dem neustart weg? ist ja da apache-server, der von isp-config ausgeliefert und kompiliert wird. also die voraussetzungen müssten auf meinem rechner weitestgehend die gleichen sein wie bei euch!

hast du fail2ban im einsatz?
 

Till

Administrator
#5
Das Problem hat nicht nur mit ISPConfig zu tun, wenn Du Dich z.B. mit putty per SSH einloggst, sind die Umlaute auch falsch. Um den Fehler zu beheben, kannst Du:

dpkg-reconfigure locales

aufrufen und dann als locale de_DE@euro auswählen.
 
#6
ich hänge mich mal mit hier dran. Habe nämlich das selbe Problem.
Wenn ich das hier mache:

dpkg-reconfigure locales

aufrufen und dann als locale de_DE@euro auswählen.
bekomme ich das hier als Antwort:

Generating locales (this might take a while)...
de_DE.ISO-8859-15@euro... done
Generation complete.
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "de_DE.utf8",
LC_ALL = "de_DE.utf8",
LANG = "de_DE.utf8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "de_DE.utf8",
LC_ALL = "de_DE.utf8",
LANG = "de_DE.utf8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
Kan mir da jemand weiterhelfen. Ich stehe n bischen aufm Schlauch ...
 
#8
Weitere Möglichkeit, wenn es sich um nur wenige Seiten handelt bzw. die ganze Site dynamisch über eine index.php läuft…
PHP:
header("Content-Type: text/html;charset=ISO-8859-1");
ganz oben im Code einfügen, bevor irgendein Output gesendet wird

Cheers
 

planet_fox

Super-Moderator
#9
habe das Problem eigendlich nur bei awstats das unter dem isp apache server läuft mit den umlauten.

Habe auch

gemacht hab da folgendes drin

Code:
Generating locales (this might take a while)...
  de_DE.ISO-8859-1... done
  de_DE.UTF-8... done
  de_DE.UTF-8@euro... done
  de_DE.ISO-8859-15@euro... done
  en_US.ISO-8859-1... done
  de_DE.ISO-8859-1... done
  en_US.ISO-8859-15... done
  en_US.UTF-8... done
Generation complete.
 
#10
Bei mir wurden auch einige PHP generierte Seiten falsch dargestellt (keine Umlaute).
Obwohl es eigentlich schon auf de_DE@euro stand.

Ich habe dann nochmal dpkg-reconfigure locales ausgeführt und nun stimmt es plötzlich alles.
 

Werbung

Top