Umlautprobleme?

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von iceget, 13. Aug. 2008.

  1. iceget

    iceget Member

    Hallo Liebe Community,

    und zwar folgendes problem..
    .

    Habe auf einem Hetzner Server (wo Default Debian Etch 64 Bit minimal installiert ist) das ISPConfig installiert.

    Nun , es läuft alles einwandfrei ausser, das wenn ich die Umlaute nicht mit dem HTML Code schreibe, nur Kästchen erhalten (also umlaute und sonderzeichen müssen im HTML Format geschrieben werden, das dieses so funktioniert). jedoch funktioniert das bei einem anderen server problemlos.

    Welche Konfiguration muss ich ändern, damit auch die Plaintext umlaute und sonderzeichen angezeigt werden?

    Vielen Dank!

    glg mAx
     
  2. planet_fox

    planet_fox Super-Moderator

  3. iceget

    iceget Member

    hallo Planet Fox,

    ich habe das Problem (lt der Anleitung in deinem Beitrag) lösen können.

    Ich habe einfach ind er /etc/apache2/apache2.conf in Zeile 446 das

    #AddDefaultCharset ISO-8859-1

    in

    AddDefaultCharset ISO-8859-1

    geändert, und den Apache restartet.

    Fertig!

    Danke nochmals!

    glg mAx
     
  4. JeGr

    JeGr Member

    Hallo zusammen,

    ich hätte einen anderen Vorschlag. Den Default auf UTF-8 zu lassen, ist nicht das Verkehrteste. Auch Webentwickler wissen, dass es Zeit ist, ihre Seiten in UTF-8 zu schreiben (gerade wenn es nicht nur deutsch, englisch und vielleicht noch französisch wird, sondern auch asiatische Sprachen dazukommen). Als Setup also auf dem ganzen Server UTF-8 zu verwenden ist kein Problem.

    Ich hatte bei der Übernahme von einem Web unseres alten Service auch das Problem, dass die Seiten noch mit Western-1252 oder ISO-8859-1 codiert waren. Da sich hier aber keiner die Mühe machen wollte, das zu konvertieren habe ich einfach in die Apache-Direktive des Webs die Zeile

    Code:
    AddDefaultCharset iso-8859-15
    eingefügt, und siehe da, aus den Kästen sind die normalen Umlaute geworden (konnte man vorab im FF bspw. auch testen, indem man die Codierung gewechselt hat bis es stimmt).

    Wäre im Kopf der Seite die richtige Codierung per (X)HTML Tag schon angegeben gewesen, wäre das auch kein Problem gewesen, aber die Programmierer hatten wohl grad faule Tage ;)

    Es funktioniert also auch auf "per Web Basis" und man muss nicht den kompletten Apache auf ISO-8859-1(5) verbiegen.

    Werte Grüße
    Grey
     

Diese Seite empfehlen