Umleitung auf apache2-default

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von daff, 2. Dez. 2007.

  1. daff

    daff New Member

    Hallo

    ich hab es jetzt endlich hinbekommen ISPConfig zu installieren (nachdem ich das Tutorial Perfect Setup - Debian Etch angewandt habe) und hab jetzt das Problem, dass alle Seiten auf Index of / umgeleitet werden. Wie kann ich das beheben ? Vorher wurde immer alles auf apache2-default weitergeleitet was ich mit dem auskommentieren von
    Code:
    RedirectMatch ^/$ /apache2-default/
    in der Datei /etc/apache2/sites-available/default behoben habe.

    MfG
    Daff

    EDIT: mist, falscher Titel
     
  2. Till

    Till Administrator

    Das von Dir beschriebene Phänomen tritt auf, wenn Du die falsche IP Adresse für die Webseite in ISPConfig ausgewählt hast.
     
  3. daff

    daff New Member

    hm ich hab nur eine IP für den Server und die müsste richtig sein
    mir is auch aufgefallen dass die datei /etc/apache2/mods-enabled/php5.conf bei der installation gefehlt hat... ich hab se manuell angelegt
     
  4. Till

    Till Administrator

    Am besten gehst Du nochmal das ganze perfect setup durch. die phpü5.conf kann nicht fehlen, wenn Du das ganze setup gemacht hast, denn dann hast Du kein PHP5 installiert.
     
  5. daff

    daff New Member

    Ich hab das hier

    Code:
    apt-get install libapache2-mod-php5 php5 php5-common php5-curl php5-dev php5-gd php5-idn php-pear php5-imagick php5-imap php5-json php5-mcrypt php5-memcache php5-mhash php5-ming php5-mysql php5-ps php5-pspell php5-recode php5-snmp php5-sqlite php5-tidy php5-xmlrpc php5-xsl
    
    nochmal ausgeführt und der sagt dass alle Pakete installiert sind
     

Diese Seite empfehlen