Unknown Interpreter: php

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von stefanw, 25. Aug. 2010.

  1. stefanw

    stefanw New Member

    Hallo,

    ich hab bei ener Domain wo in ISPCP3 folgendes eingestellt ist,

    [​IMG]

    das php nicht mehr ausgeführt wird. In der vhost Datei steht folgendes:

    Code:
        # suexec enabled
        SuexecUserGroup web33 client20
        # Clear PHP settings of this website
        <FilesMatch "\.ph(p3?|tml)$">
            SetHandler None
        </FilesMatch>
        # suphp enabled
        <Directory /var/www/clients/client20/web33/web>
            suPHP_Engine on
            # suPHP_UserGroup web33 client20
            AddHandler x-httpd-suphp .php .php3 .php4 .php5
            suPHP_AddHandler x-httpd-suphp
        </Directory>
    
        # add support for apache mpm_itk
        <IfModule mpm_itk_module>
          AssignUserId web33 client20
        </IfModule>
     
  2. Till

    Till Administrator

    poste mal die suphp.conf Datei.
     
  3. stefanw

    stefanw New Member

    Code:
    [global]
    ;Path to logfile
    logfile=/var/log/suphp/suphp.log
    
    ;Loglevel
    loglevel=info
    
    ;User Apache is running as
    webserver_user=www-data
    
    ;Path all scripts have to be in
    docroot=/var/www:${HOME}/public_html
    
    ;Path to chroot() to before executing script
    ;chroot=/mychroot
    
    ; Security options
    allow_file_group_writeable=false
    allow_file_others_writeable=false
    allow_directory_group_writeable=false
    allow_directory_others_writeable=false
    
    ;Check wheter script is within DOCUMENT_ROOT
    check_vhost_docroot=true
    
    ;Send minor error messages to browser
    errors_to_browser=false
    
    ;PATH environment variable
    env_path=/bin:/usr/bin
    
    ;Umask to set, specify in octal notation
    umask=0022
    
    ; Minimum UID
    min_uid=100
    
    ; Minimum GID
    min_gid=100
    
    
    [handlers]
    ;Handler for php-scripts
    application/x-httpd-suphp="php:/usr/bin/php-cgi"
    
    ;Handler for CGI-scripts
    x-suphp-cgi="execute:!self"
    x-httpd-suphp=php:/usr/bin/php-cgi
    
     
  4. Till

    Till Administrator

    Ändere mal die Zeile:

    x-httpd-suphp=php:/usr/bin/php-cgi

    in:

    x-httpd-suphp="php:/usr/bin/php-cgi"

    und starte apche neu.
     
  5. stefanw

    stefanw New Member

    Danke, das wars!
     

Diese Seite empfehlen