Unterordner - phpMyAdmin

#1
Hallo zusammen,

wo muss ich genau Verknüpfungen hinlegen, damit diese auch aufgerufen werden können?

phpMyAdmin -> phpmyadmin
webmail -> roundcube
phpmyadmin -> /usr/share/phpmyadmin
roundcube -> /usr/share/roundcube

In /var/www/ hab ich diese angelegt.
Würde gerne auch einen Passwortschutz einfügen eventeull über htaccess.
Wo müssten diese hingelegt werden?
Wo kann ich einstellen, das diese nur von der Haupt-IP aus zu erreichen ist sowie die Weiterleitung von http auf https?

Gibt es dazu eigene vhost, sowie ein eigenen ErrorLog?
Bekomme bei RoundCube nämlich einen 500ter und finde den Log nicht :-(

Danke euch!!
 
Zuletzt bearbeitet:

nowayback

Well-Known Member
#2
wo muss ich genau Verknüpfungen hinlegen, damit diese auch aufgerufen werden können?

phpMyAdmin -> phpmyadmin
webmail -> roundcube
phpmyadmin -> /usr/share/phpmyadmin
roundcube -> /usr/share/roundcube
/etc/apache2/sites-enabled/

Falsch und unnötig

Wenn du eine der Anleitungen befolgt hättest, wären diese Fragen gar nicht gekommen, also frage ich: Warum befolgst du keine der Anleitungen?

Grüße
nwb
 
#5
Sry, aber wo ist dort das erklärt was ich suche?
Installiert ist es, ich suche die entsprechenden Log-Files und weitere Verknüpfungen (zuachten auf Groß- & Kleinschreibung).

Unter /var/log/apache2 ist nichts zufinden und weiter LogFiles sind Kundenspezifisch, für phpmyadmin gibt es aber keinen Kunden. syslog steht auch nichts. Also nun nochmal, welches HowTo hilft da?

Übrigens handelt sich um Debian!
 
Zuletzt bearbeitet:
#7
Okay,... Danke für den Hinweis.
Leider finde ich da nirgends eine entsprechende Datei, bin jetzt alle durchgegangen, aber ein verweis auf phpMyAdmin oder roundcube habe ich nicht gefunden.

Vielen Dank für euere Bemühungen.
 

Till

Administrator
#8
Die Dateien werden von apt während der Installation der Pakete erstellt wenn Du wie im Tutorial beschrieben auswählst dass die Pakete für apache2 konfiguriert werden sollen. Wenn Du das nicht ausgewählt hast, dann legt apt die Dateien nicht an und folglich kannst Du auch nicht auf phpmyadmin zugreifen.

Du kannst mit:

dpkg-reconfigure phpmyadmin

apt anweisen das Paket neu zu konfigurieren und da´bei auswählen dass er es für apache2 konfigurieren soll.
 
#9
phpMyAdmin funktioniert, ist aber nur über phpmyadmin und nicht phpMyAdmin erreichbar.
Gleiches gilt für roundcube, ausser das ich dafür noch den log suche da ich dort einen 500er bekommen.
 

Till

Administrator
#10
Mach bitte das rekonfigure wie beschrieben damit der die Datei anlegt. Danch kannst Du dann in der Datei einen 2. Alias für die andere Schreibweise einfügen.

Gleiches gilt für roundcube, ausser das ich dafür noch den log suche da ich dort einen 500er bekommen.
Der Fehler steht im error.log der webseite, über die Du roundcube aufgerufen hast. Vermutlich nutzt die Webseite php-fcgi (was auch die beste Wahl ist) aber Du hast die Änderungen zu PHP wie im Tutorial für squirrelmail beschrieben nicht in der roundcube.conf vorgenommen, so dass roundcube noch über fastcgi und nicht über mod_php läuft. Das ist notwendig da das roundcube Paket von Debian nicht in /var/www sondern /usr/share/ installiert ist.
 
#11
Hallo,

die conf Datein habe ich jetzt angelegt und auch soweit wir möglich die Einstellungen von roundcube an squirremail angepasst.
Dennoch der 500ter und ich finde auch nicht dne Error Log in dem User Log finde ich es nicht.

Wo stelle ich einzelnt noch mod_php für roundcube ein, die Zeilen aus dem HowTo habe ich eingefügt!

Code:
root@static:/var/lib/roundcube# ls -la
insgesamt 28
drwxr-xr-x  7 root     root     4096 24. Mär 12:50 .
drwxr-xr-x 51 root     root     4096 15. Mär 19:51 ..
lrwxrwxrwx  1 root     root       24 15. Mär 19:22 bin -> /usr/share/roundcube/bin
drwxr-xr-x  2 root     root     4096 15. Mär 19:22 config
lrwxrwxrwx  1 root     root       30 15. Mär 19:22 .htaccess -> /usr/share/roundcube/.htaccess
lrwxrwxrwx  1 root     root       30 15. Mär 19:22 index.php -> /usr/share/roundcube/index.php
lrwxrwxrwx  1 root     root       19 15. Mär 19:22 logs -> ../../log/roundcube
drwxr-xr-x 13 root     root     4096 17. Mär 14:03 plugins
lrwxrwxrwx  1 root     root       28 15. Mär 19:22 program -> /usr/share/roundcube/program
lrwxrwxrwx  1 root     root       31 15. Mär 19:22 robots.txt -> /usr/share/roundcube/robots.txt
drwxr-xr-x  3 www-data adm      4096 15. Mär 19:22 skins
drwxr-x---  2 www-data www-data 4096 16. Mär 06:25 temp
drwxr-xr-x  2 www-data root     4096 24. Mär 12:50 tmp
root@static:/var/lib/roundcube# cd /usr/share/roundcube/
root@static:/usr/share/roundcube# ls -la
insgesamt 56
drwxr-xr-x   4 root root  4096 21. Mär 18:41 .
drwxr-xr-x 142 root root  4096 15. Mär 19:56 ..
drwxr-xr-x   2 root root  4096 15. Mär 19:22 bin
lrwxrwxrwx   1 root root    25 15. Mär 19:22 config -> /var/lib/roundcube/config
-rw-r--r--   1 root root  1111 22. Sep 2009  .htaccess
-rw-r--r--   1 root root  9829 31. Okt 2009  index.php
lrwxrwxrwx   1 root root    23 15. Mär 19:22 logs -> /var/lib/roundcube/logs
-rw-r--r--   1 root root 18294 18. Okt 2010  main.inc.php.dist
lrwxrwxrwx   1 root root    26 15. Mär 19:22 plugins -> /var/lib/roundcube/plugins
drwxr-xr-x   7 root root  4096 15. Mär 19:22 program
-rw-r--r--   1 root root    26 22. Mär 2008  robots.txt
lrwxrwxrwx   1 root root    24 15. Mär 19:22 skins -> /var/lib/roundcube/skins
lrwxrwxrwx   1 root root    23 15. Mär 19:22 temp -> /var/lib/roundcube/temp
Code:
# Those aliases do not work properly with several hosts on your apache server
# Uncomment them to use it or adapt them to your configuration
#    Alias /roundcube/program/js/tiny_mce/ /usr/share/tinymce/www/
#    Alias /roundcube /var/lib/roundcube

Alias /roundcube/program/js/tiny_mce/ /usr/share/tinymce/www/
Alias /roundcube /var/lib/roundcube
Alias /webmail /var/lib/roundcube

# Access to tinymce files
<Directory "/usr/share/tinymce/www/">
      Options Indexes MultiViews FollowSymLinks
      AllowOverride None
      Order allow,deny
      allow from all
</Directory>

<Directory /var/lib/roundcube/>
  Options +FollowSymLinks
  # This is needed to parse /var/lib/roundcube/.htaccess. See its
  # content before setting AllowOverride to None.
  AllowOverride All
  order allow,deny
  allow from all
</Directory>

# Protecting basic directories:
<Directory /var/lib/roundcube/config>
        Options -FollowSymLinks
        AllowOverride None
</Directory>

<Directory /var/lib/roundcube/temp>
        Options -FollowSymLinks
        AllowOverride None
        Order allow,deny
        Deny from all
</Directory>

<Directory /var/lib/roundcube/logs>
        Options -FollowSymLinks
        AllowOverride None
        Order allow,deny
        Deny from all
</Directory>

<Directory /usr/share/roundcube>
  Options FollowSymLinks
  <IfModule mod_php5.c>
    AddType application/x-httpd-php .php
    php_flag magic_quotes_gpc Off
    php_flag track_vars On
    php_admin_flag allow_url_fopen Off
    php_value include_path .
    php_admin_value upload_tmp_dir /var/lib/roundcube/tmp
    php_admin_value open_basedir /usr/share/roundcube:/etc/roundcube:/var/lib/roundcube:/etc/hostname:/etc/mailname
    php_flag register_globals off
  </IfModule>
  <IfModule mod_dir.c>
    DirectoryIndex index.php
  </IfModule>

  # access to configtest is limited by default to prevent information leak
  <Files configtest.php>
    order deny,allow
    deny from all
    allow from 127.0.0.1
  </Files>
</Directory>
Auch ohne Error Log behaupte ich, dass es an den Berechtigungen liegt!

------------------
[OT]
Warum ist mein Server nicht nur unter der IP aufzurufen und warum zeigt die https://IP auf eine meiner Kunden Domains?
 
Zuletzt bearbeitet:
#13
Code:
SoftException in Application.cpp:221: File "/usr/share/roundcube/index.php" is not in document root of Vhost
Premature end of script headers: index.php
Das interessante ist , das alle Fehler in diesem einem Web zusammen laufen, welcher die geringste ID hat!
Egal welche Domain ich aufrufe.
Selbst die IP über http und https verweisen an diese Domain.
Erst als ich die IP als Kunden angelegt habe, ist diese Weiterleitung nicht mehr vorhaden, welches das Problem mit den Logs aber nicht löst!
 
Zuletzt bearbeitet:

Till

Administrator
#14
Das interessante ist , das alle Fehler in diesem einem Web zusammen laufen, welcher die geringste ID hat!
Dann waren die Webs vorher nicht richtig konfiguriert. Typischer Fehler ist es * und IP Adresse zu mischen, denn eine IP wird vom apache bevorzugt. Wenn apache kein web mit passenden Einstellungen findet, dann wird das erste Web angezeigt.

Die Fehlermeldungen findest Du in der Logdatei des Webs, also nicht im globalen error.log sondern in dem der Webseite.
 
#15
Die Fehlermeldungen findest Du in der Logdatei des Webs, also nicht im globalen error.log sondern in dem der Webseite.
Die Fehlermeldungen finde ich eben nicht in den Logdatein des Webs sondern in einer Log Datei von einem Web statt allen!!
Aber egal.

-------------------------

Nun mal zurück zum tatsälichem Problem!
RoundCube mit IPSConfig3

Code:
SoftException in Application.cpp:221: File "/usr/share/roundcube/index.php" is not in document root of Vhost
Premature end of script headers: index.php
Soll ich dafür einen eigenen Thread aufmachen?
 

Till

Administrator
#16
Natürlich steht das nur in einer Logdatei und zwar in der des webs über das apache die Zugriffe routet. Habe ich oben beschrieben wie apache zugriffe im Fall einer nicht eindeutigen Konfiguration routet.

Die Ursache des Problems ist eindeutig, nämlich dass Du roundcube in einem aus Sicht des apache falschen Verzeichnisses installiert hast denn bei Verwendung von fastcgi und erst recht suexec überprüft apache die Zugriffe und erlaubt nur welche auf /var/www/. Das Umgeht man noralerweise durch die Konfiguration von mod_php im roundcube folder. Das hast Du auch gemacht nur die Konfiguration die Du erstellt hast scheint nicht vom apache gelesen zu werden oder aber sie wird anderso wieder überschrieben und danach solltest Du jetzt suchen.
 

Werbung