Update auf 2.2.19 : Postfix problem

#1
Hallo !

Hatte ein funktionierendes System mit 2.2.18
Update auf 2.2.19 problemlos durchgefuehrt. Konnte alles normal nutzen. Bis auf eMail. Angeblich waren die Benutzer nicht bekannt

Recipient address rejected: User unknown in local recipient table; from=<newsletter@ispconfig.org> to=<ispconfig.org@*******.de>


Das hat definitiv vor dem Update funktioniert.

Backup von heute morgen zurueckkopiert. Hups, geht wieder alles.

Was kann ich noch beisteuern ?
 
Zuletzt bearbeitet:

Till

Administrator
#2
Hast Du die Daten des nicht funktionierenden Systems gesichert? Ansonsten wird es schwierig, das nach zu vollziehen.

Interessant wäre:

a) War die Emailadresse noch in /etc/postfix/virtusertable
b) War die Emailadresse noch in der ispconfig mysql Datenbank in der Tabelle isp_isp_user
 
#3
Hast Du die Daten des nicht funktionierenden Systems gesichert? Ansonsten wird es schwierig, das nach zu vollziehen.

Interessant wäre:

a) War die Emailadresse noch in /etc/postfix/virtusertable
b) War die Emailadresse noch in der ispconfig mysql Datenbank in der Tabelle isp_isp_user

Zu a : ja, die waren noch vorhanden
Zu b : auch dort waren die Daten vorhanden.

Das hat mich ja auch so verwundert. Ich habe gerade erst mein System auf die 2.2.18 durch Backup zurueckgesetzt. Ich werd das Ganze nochmal in einer VMWare Session nachspielen. Evt. kann ich Dir dann das Ganze zukommen lassen.

Ich habe allerdings daraus gelernt, erst im virtuellen System testen ud kontrollieren.
 

Till

Administrator
#4
Dann kann es eigentlich nur sein, dass in der postfix main.cf die beiden Zeilen für die virtusertable und local-host-names fehlten.
 
#5
Hi,
ich hab auch ein Postfix-Problem:
Mein Thunderbird lässt mich keine mails mehr verschicken und bringt ständig das Fenster zur Eingabe des Nutzernamens und Passwort.
Beides stimmt 100%!
Mailadresse sowohl in der /etc/postfix/virtusertable vorhanden als auch in der
isp_ips_user Datenbank.

Komisch ist, dass das versenden von Mails über den Webmailer klappt.

Leider weiß ich nicht mehr welche version drauf ist.. die 19 is es aber sicher nicht.
 

Till

Administrator
#6
@Knobibrot: Schau mal in Deinem mail log nach, welche Fehler Du erhältst. Außerdem solltest Du mal nachsehen, ob der Email user in /etc/passwd drin steht.

Mach bitte nächstes mal einen neuen Thread im Forum, wenn Du ein Problem posten möchtest.
 
#7
Sorry, Till!
Ich bin von anderen Foren gewohnt einen passenden Beitrag zu suchen und dort rein zuposten. Werd das nächstel mal einen neuen Erstellen.

Zum Problem:
Nutzer sind in der /etc/passwd drin. ich kann mich auch via SSH anmelden und der Empfang via pop3 im Thunderbird geht auch ohne Probleme.

hier der log-Auszug:
Code:
Jan 10 13:09:29 217-20-127-23 postfix/smtpd[10191]: connect from p5B1551EC.dip.t-dialin.net[91.21.81.236]
Jan 10 13:09:33 217-20-127-23 postfix/smtpd[10191]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
Jan 10 13:09:33 217-20-127-23 postfix/smtpd[10191]: warning: SASL authentication failure: Password verification failed
Jan 10 13:09:33 217-20-127-23 postfix/smtpd[10191]: warning: p5B1551EC.dip.t-dialin.net[91.21.81.236]: SASL PLAIN authentication failed: generic failure
Jan 10 13:09:33 217-20-127-23 postfix/smtpd[10191]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
Jan 10 13:09:33 217-20-127-23 postfix/smtpd[10191]: warning: p5B1551EC.dip.t-dialin.net[91.21.81.236]: SASL LOGIN authentication failed: generic failure
Jan 10 13:09:35 217-20-127-23 postfix/smtpd[10191]: disconnect from p5B1551EC.dip.t-dialin.net[91.21.81.236]
 

Till

Administrator
#8
Sorry, Till! Ich bin von anderen Foren gewohnt einen passenden Beitrag zu suchen und dort rein zuposten.
Macht nichts :) Das ist generell auch richtig und gilt auch für dieses Forum, nur leider passt der Eintrag nicht so richtig zum Thread, da es bei diesem Thread um ein Problem beim Update von ISPConfig 2.2.18 auf 2.2.19 geht und insebesondere um Probleme beim Mail Empfang. Bei Dir geht jedoch der Mailempfang und Du hast auch kein Update durchgeführt.

Bei Dir scheint der saslauthd daemon nicht gesatrtet zu sein. Satrte ihn bitte mal mit dem Script in /etc/init.d/ , wenn das nichts hilft, vergleiche bitte mal Deine aktuelle sasl Konfiguartion mit der aus dem Perfect setup howto für Deine Linuxdistribution.
 
#9
Also, ich hab einen restart des saslauthd daemons gemacht, aber ohne Erfolg.
Als ich dann gelesen hab, dass ich meine config mit der des perfect-setup howto vergleich soll, ist mir eingefallen, dass ich vor kurzem auf Debian 4.0 upgedated hab. Vorher war 3.1 drauf. Ich nehme also mal an mit der config des debian4.0-howto vergleichen.

Bei Erfolg meld ich mich wieder.
 
#10
Hab den ganzen Abschnitt des perfect-setup howto debian 4.0 eMails betreffend, komplett nochmal neu durch gemacht. Jetzt läuft auch TLS, aber versenden kann ich immer noch nicht. Immer noch der gleiche Fehler.

folgendes aus dem mail.log:
Jan 10 14:29:30 217-20-127-23 postfix/smtpd[14852]: TLS connection established from p5B1551EC.dip.t-dialin.net[91.21.81.236]: TLSv1 with cipher DHE-RSA-AES2$
Jan 10 14:29:35 217-20-127-23 postfix/smtpd[14852]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
Jan 10 14:29:35 217-20-127-23 postfix/smtpd[14852]: warning: SASL authentication failure: Password verification failed
Jan 10 14:29:35 217-20-127-23 postfix/smtpd[14852]: warning: p5B1551EC.dip.t-dialin.net[91.21.81.236]: SASL PLAIN authentication failed: generic failure
Jan 10 14:29:36 217-20-127-23 postfix/smtpd[14852]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
Jan 10 14:29:36 217-20-127-23 postfix/smtpd[14852]: warning: p5B1551EC.dip.t-dialin.net[91.21.81.236]: SASL LOGIN authentication failed: generic failure
Jan 10 14:29:37 217-20-127-23 postfix/smtpd[14852]: disconnect from p5B1551EC.dip.t-dialin.net[91.21.81.236]
 

Till

Administrator
#11
dass ich vor kurzem auf Debian 4.0 upgedated hab.
Ok ,dass ist das Problem. Bitte immer sagen, wenn Du etwas umkonfiguriert oder aktualisiert hast und nicht einfach nur sagen dass mail senden nicht geht!

Die SASL Konfigurationsdateien haben sich von debian 3.1 auf 4.0 geändert. Vergleiche sie bitte nochmal Zeile für Zeile mit dem Debian 4.0 howto. Es geht hierbei umd sasl und nicht postfix, du brauchst also nicht in doie postfix main.cf und so schauen.
 
#12
also ich habe mir jetzt schon mehrere howto angeschaut, aber es geht immer noch nicht.
Ich poste mal meine sasl-confdatei.. evt seht ihr ja mehr als ich:
smtp.conf

pwcheck_method: saslauthd
mech_list: PLAIN LOGIN
saslauthd_path: /var/spool/postfix/var/run/saslauthd
autotransition:truepwcheck_method: saslauthd
/etc/default/saslauthd
#
# Settings for saslauthd daemon
#

# Should saslauthd run automatically on startup? (default: no)
START=yes

# Which authentication mechanisms should saslauthd use? (default: pam)
#
# Available options in this Debian package:
# getpwent -- use the getpwent() library function
# kerberos5 -- use Kerberos 5
# pam -- use PAM
# rimap -- use a remote IMAP server
# shadow -- use the local shadow password file
# sasldb -- use the local sasldb database file
# ldap -- use LDAP (configuration is in /etc/saslauthd.conf)
#
# Only one option may be used at a time. See the saslauthd man page
# for more information.
#
# Example: MECHANISMS="pam"
MECHANISMS="pam"

# Additional options for this mechanism. (default: none)
# See the saslauthd man page for information about mech-specific options.
MECH_OPTIONS=""

# How many saslauthd processes should we run? (default: 5)
# A value of 0 will fork a new process for each connection.
THREADS=5

# Other options (default: -c)
# See the saslauthd man page for information about these options.
#
# Example for postfix users: "-c -m /var/spool/postfix/var/run/saslauthd"
# Note: See /usr/share/doc/sasl2-bin/README.Debian
OPTIONS="-c -m /var/spool/postfix/var/run/saslauthd -r"
 
Zuletzt bearbeitet:
#14
hier die Ausgabe:
ls -la /var/spool/postfix/var/run/saslauthd

insgesamt 940
drwxr-xr-x 3 root sasl 4096 2008-01-10 19:22 .
drwxr-xr-x 3 root root 4096 2006-11-19 14:18 ..
-rw------- 1 root root 0 2008-01-10 18:50 cache.flock
-rw------- 1 root root 945152 2008-01-10 18:50 cache.mmap
drwxrwxrw- 2 root sasl 4096 2008-01-08 14:40 mux
-rw------- 1 root root 0 2008-01-10 19:16 mux.accept
--w------T 1 root root 0 2008-01-10 19:16 saslauthd.pid.lock
 
#16
Nach Update 2.2.19 kein login mit email-adresse möglich

Hallo an alle,

nach dem Update auf die 19er Version berichten User, dass sie sich nicht mehr mit ihrer Mailadresse über Outlook oder OE anmelden können. Mit dem Usernamen geht es natürlich nach wie vor.

Im webmail-frontend geht es wie gehabt mit der Mailadresse.

Leider ist der Beitrag etwas von der Richtung abgekommen (erstes Posting), wurde das Problem von lindesbs gelöst?

adressen befinden sich in der /etc/postfix/virtusertable

Eure Hilfe wäre mal wieder notwendig - und hat bisher immer geholfen

Gruss

logfiles zeigen folgenden Inhalt mit emailadresse:

Jan 24 15:54:47 xxx004 courierpop3login: LOGIN FAILED, user=sila@xxxxxxx.ch, ip=[::ffff:217.8.211.90]

und mit normalem Usernamen:

Jan 24 15:53:23 xxx004 courierpop3login: LOGIN, user=xxxxxxxx.ch_sila, ip=[::ffff:217.8.211.90]
 
Zuletzt bearbeitet:

Till

Administrator
#17
Mit der Mailadresse kann man sich bei ISPConfig nicht mit Outlook oder anderen externen Mailclients anmelden, außer Du hast ISPConfig verändert. Wenn Du ISPConfig gepatcht hast, um emailadressen als login zu ermöglichen, musst Du das nach einem Update wiederholen.
 
#18
email adresse ispconfig outlook

Vielen Dank

für die rasche Hilfe!

Ja ich hatte einen Patch hier aus dem Forum benutzt - hoffe ich finde den Beitrag wieder.

Gibt es denn keine Möglichkeit bei einem Update diese Ämderungen beizubehalten. Habe dieses auch bei openDNS, der Eintrag muss immer wieder in der named.master.conf angepasst werden. Nach dem letzten Update hat sich inder Datei der Pfad {BINDDIR} geändert - nach einspielen meiner Datei startete dann der DNS nicht mehr. Habe dann fast ne halbe Stunde das Problem gesucht, da nur im log, aber nicht beim start eine Fehlermeldung zu sehen war.

Ich würde mir wünschen, dass es einen gesonderten Bereich im ispconfig gibt, in dem eigene masterconfigs abgelegt werden können. Bitte nur als Vorschlag verstehen.


Danke und nen schönes Weekend
 

Till

Administrator
#19
Gibt es denn keine Möglichkeit bei einem Update diese Ämderungen beizubehalten.
Nein, da wir zum Update natürlich Dateien aktualisieren müssen. Wenn Du die user@domain Authentifizierung mit Dovecot genommen hättest, wäre kein Patch notwendig und somit würde auch kein Problem beim Updaten bestehen.

Ich würde mir wünschen, dass es einen gesonderten Bereich im ispconfig gibt, in dem eigene masterconfigs abgelegt werden können. Bitte nur als Vorschlag verstehen.
Gibt es doch. Du musst Dein Template nur ins Verzeichnis /root/ispconfig/isp/conf/customized_templates/ legen
 

Werbung

Top