Update auf 3.0.4

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von bernie, 3. Nov. 2011.

  1. bernie

    bernie Member

    Guten Abend

    Wir wollten gerade den Update auf 3.0.4 machen. Beim 'Checking ISPConfig database' dreht der Server jedoch durch. Der Serverload geht schlagartig in die Höhe, bis der Server nicht mehr reagiert.

    Ist dieses Problem bekannt, oder ist das bei mir ne einmalige Erscheinung?

    Vielen Dank und beste Grüsse aus Johannesburg
    Bernie
     
  2. nowayback

    nowayback Well-Known Member

    Hmm es kann schon sein, dass der Server dabei 100% CPU Last erzeugt, jedoch sollte die nach der Prüfung zurückgehen. Bei mir hat das Update ohne Probleme geklappt - außer dass der FTP Server gestartet wurde obwohl ich im ISP Config den Fileserver auf 0 gesetzt hatte. Der Grund dahinter scheint zu sein, dass das Installscript nicht prüft was es starten soll, sondern einfach startet und da ich den FTP Server trotzdem installiert hatte, wurde der halt mitgestartet... Damit kann ich leben.

    Zu deinem Problem konnte ich im Bugtracker nichts finden, aber evtl. beschreibst du Till & Co. mal wie du beim Update vorgegangen bist, postest evtl. existierende Logfiles sodass diese es nachvollziehen können.

    Grüße und viel Erfolg
    nwb
     
  3. Till

    Till Administrator

    Möglicherweise sind bei Dir mysql Tabellen defekt. Denn bei "Checking ISPConfig database" verbindet sich der Updater einfach nur mit der mysql DB und fragt die Versionsnummer ab. Logge Dich mal mit phpmyadmin als root user ein, gehe zur ISPConfig DB, selektiere alle Tabellen und wähle reparieren als Aktion aus.
     
  4. bernie

    bernie Member

    Vielen Dank für die Hilfe. Sorry, für die späte Antwort, aber bei uns haben sie wieder mal das Meereskabel gekappt. Keine Verbindung nach Europa ;-)

    Die DB hatte ich schon überprüft, die ist ok.

    Folgende Fehlermeldung spuckt mir das Log aus:

    DBI connect('database=dbispconfig;host=localhost:3306','ispconfig',...) failed: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) at /usr/local/ispconfig/server/scripts/vlogger line 514
    DBI Error: at /usr/local/ispconfig/server/scripts/vlogger line 514, <STDIN> line 13288.
    [Fri Nov 04 21:47:18 2011] [error] server reached MaxClients setting, consider raising the MaxClients setting
     
  5. bernie

    bernie Member

    Problem gelöst

    Komischerweise hat der Update Process einen von mir installierten Cronjob (/usr/bin/mysqlcheck) mehrfach ausgelöst. Dabei wurde der Server komplett überfordert. Nachdem ich mysqlcheck deaktiviert habe, ist der Update ohne Weiteres durchgelaufen. Vielen Dank für die Hilfe.

    Beste Grüsse aus Joburg
    Bernie
     

Diese Seite empfehlen