Update ispConfig & Debian - Problem mit phpmyadmin

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Racon, 9. Nov. 2011.

  1. Racon

    Racon New Member

    Hallo zusammen,

    nach meinem erfolgreichen Upgrade von Debian 5 auf 6 und der neuesten ispConfig Version, habe ich jetzt bemerkt, dass phpmyadmin nichtmehr richtig läuft.

    Dies ging bis vor dem Update noch ohne Probleme.

    Seit diesem bekomme ich nun ein Downloadfenster angezeigt wenn ich /phpmyadmin aufrufen möchte.

    Inhalt:

    Code:
    application/x-httpd-suphp
    Ich hoffe auf eine Antwort und verbleibe mit freundlichen Grüßen :)

    //EDIT: Wenn ich phpmyadmin einfach auf ein Webverzeichnis XY spiele, läuft es ohne Probleme.
     
    Zuletzt bearbeitet: 9. Nov. 2011
  2. Till

    Till Administrator

    In Debian 6 überschreibt das Debian suphp Paket die mod_php Konfiguration wodurch php für phpmyadmin deaktiviert wird. Editier die Datei:

    /etc/apache2/mods-available/suphp.conf

    und kommentier die Zeilen:

    AddType application/x-httpd-php .php .php3 .php4 .php5 .phtml
    suPHP_AddHandler application/x-httpd-php

    aus und starte apache neu.
     
  3. Racon

    Racon New Member

    Hallo Till,

    habe ich gemacht. Immer noch das selbe Problem :-(
     
  4. Till

    Till Administrator

    Das kann an sich nicht sein. Überprüf die Datei bitte nochmal und starte dann nochmal apache neu.
     
  5. Racon

    Racon New Member

    Hallo Till,

    ich habe es nochmal gemacht, geht leider nocht nicht!

    Code:
    userx3@62.75.x.x:~# nano /etc/apache2/mods-available/suphp.conf
    
    <IfModule mod_suphp.c>
    #AddType application/x-httpd-suphp .php .php3 .php4 .php5 .phtml
    #suPHP_AddHandler application/x-httpd-suphp
    
        <Directory />
            suPHP_Engine on
        </Directory>
    
        # By default, disable suPHP for debian packaged web applications as files
        # are owned by root and cannot be executed by suPHP because of min_uid.
        <Directory /usr/share>
            suPHP_Engine off
        </Directory>
    
    # # Use a specific php config file (a dir which contains a php.ini file)
    #       suPHP_ConfigPath /etc/php4/cgi/suphp/
    # # Tells mod_suphp NOT to handle requests with the type <mime-type>.
    #       suPHP_RemoveHandler <mime-type>
    </IfModule>
    
    userx3@62.75.x.x:~# /etc/init.d/apache2 restart
    Restarting web server: apache2 ... waiting ..
    
     
  6. Till

    Till Administrator

    Welchen PHP Modus hast Du denn in der Webseite ausgewählt, über die Du phpmyadmin aufrufst?
     
  7. Racon

    Racon New Member

    Hallo Till,

    ich habe phpmyadmin in ein anderes Verzeichnis installiert und die neueste Version verwendet, läuft jetzt wieder reibungslos.

    Trotzdem vielen Dank für deine Hilfe.

    MfG
     

Diese Seite empfehlen