Update vom Server gemacht und nun steht alles was im Apache laufen soll :(

Dieses Thema im Forum "Allgemein" wurde erstellt von Le-Seaw, 15. Mai 2013.

  1. Le-Seaw

    Le-Seaw Member

    Hallo alle,

    habe update gemacht und nun geht der Apache nicht mehr, bzw. er geht noch aber alles von ISPConfig ist tot.
    wenn ich auf die :8080 gehe wird mir download angeboten und die normalen Seiten geben Fehler wieder.
    Fehler 324 (net::ERR_EMPTY_RESPONSE): Server hat die Verbindung geschlossen. Es wurden keine Daten gesendet

    Email geht alles noch wie es scheint, nur Apache kommt nicht hoch.
    Ich denke er kann kein php mehr.
    Html Seiten gehen noch.
    An welcher Stelle habe ich den Bock geschossen??
    Danke für eine Antwort.
     
  2. nowayback

    nowayback Well-Known Member

    was sagen die logfiles?
     
  3. Le-Seaw

    Le-Seaw Member

    welche?
    die sagen alles okay das ist ja der witz :(

    apache restart bringt das:
    Restarting web server: apache2[Wed May 15 23:01:59 2013] [warn] NameVirtualHost *:80 has no VirtualHosts
    ... waiting [Wed May 15 23:02:00 2013] [warn] NameVirtualHost *:80 has no VirtualHosts

    urls laufen alle solange sie kein php wollen
    da steigt er aus.
     
  4. nowayback

    nowayback Well-Known Member

    Am besten du schaust mal in der error.log von einer betreffenden domain /var/log/ispconfig/httpd/domain/error.log

    alternativ kannst du eine php datei erstellen mit dem inhalt

    PHP:
    <?php
    phpinfo
    ();
    ?>
    und diese dann aufrufen, dann bekommst du - sofern php funktioniert - auch eine seite angezeigt.

    hast du nach dem update des systems auch ein ispconfig update durchlaufen lassen?
     
  5. Le-Seaw

    Le-Seaw Member

    volles programm

    und die phpinfo wird nicht gehen, ich habe kein php :(
    er weiss nix mit php anzufangen, apache hat keine ahnung das php läuft :(
    verdammte hacke das jetzt.
     
    Zuletzt bearbeitet: 16. Mai 2013
  6. nowayback

    nowayback Well-Known Member

    hmm das wäre ungewöhnlich aber mach mal:

    Code:
    apt-get install apache2 apache2.2-common apache2-doc apache2-mpm-prefork apache2-utils libexpat1 ssl-cert libapache2-mod-php5 php5 php5-common php5-gd php5-mysql php5-imap phpmyadmin php5-cli php5-cgi libapache2-mod-fcgid apache2-suexec php-pear php-auth php5-mcrypt mcrypt php5-imagick imagemagick libapache2-mod-suphp libruby libapache2-mod-ruby libapache2-mod-python php5-curl php5-intl php5-memcache php5-memcached php5-ming php5-ps php5-pspell php5-recode php5-snmp php5-sqlite php5-tidy php5-xmlrpc php5-xsl memcached
    das sollten alle betroffenen pakete sein.
     
  7. Le-Seaw

    Le-Seaw Member

    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut
    Statusinformationen werden eingelesen... Fertig
    libapache2-mod-ruby ist schon die neueste Version.
    php-auth ist schon die neueste Version.
    apache2 ist schon die neueste Version.
    apache2-doc ist schon die neueste Version.
    apache2-suexec ist schon die neueste Version.
    apache2-utils ist schon die neueste Version.
    apache2.2-common ist schon die neueste Version.
    libexpat1 ist schon die neueste Version.
    imagemagick ist schon die neueste Version.
    libapache2-mod-fcgid ist schon die neueste Version.
    mcrypt ist schon die neueste Version.
    phpmyadmin ist schon die neueste Version.
    ssl-cert ist schon die neueste Version.
    libapache2-mod-suphp ist schon die neueste Version.
    php-pear ist schon die neueste Version.
    php5 ist schon die neueste Version.
    php5-cgi ist schon die neueste Version.
    php5-cli ist schon die neueste Version.
    php5-common ist schon die neueste Version.
    php5-curl ist schon die neueste Version.
    php5-gd ist schon die neueste Version.
    php5-imagick ist schon die neueste Version.
    php5-imap ist schon die neueste Version.
    php5-mcrypt ist schon die neueste Version.
    php5-mysql ist schon die neueste Version.
    Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
    xfonts-encodings libilmbase6 libmagickcore3 libpython2.6 libmagickwand3 libcdt4 libsqlite0 xfonts-utils libmysqlclient16 libxfont1 libgmp3c2 libpathplan4 libopenexr6 libdjvulibre21 libfont-freetype-perl
    libgvc5 wwwconfig-common libxdot4 libanthy0 anthy-common libdb4.7 libgraph4 libdjvulibre-text javascript-common libjs-mootools
    Verwenden Sie »apt-get autoremove«, um sie zu entfernen.
    Die folgenden zusätzlichen Pakete werden installiert:
    aspell aspell-en libalgorithm-diff-xs-perl libaspell15 libberkeleydb-perl libclass-isa-perl libcompress-raw-zlib-perl libconvert-uulib-perl libcrypt-openssl-bignum-perl libcrypt-openssl-rsa-perl
    libdbd-mysql-perl libdbi-perl libevent-2.0-5 libffi5 libfont-freetype-perl libglib2.0-0 libhtml-parser-perl libicu48 liblocale-gettext-perl liblua5.1-0 libmemcached11 libming1 libnet-dns-perl
    libnet-libidn-perl libnet-ssleay-perl libnetaddr-ip-perl libpango1.0-0 libperl5.14 libpython2.7 librecode0 libruby1.9.1 libsensors4 libsnmp-base libsnmp15 libsocket6-perl libswitch-perl
    libtext-charwidth-perl libtext-iconv-perl libtidy-0.99-0 libunix-syslog-perl libuuid-perl libyaml-0-2 perl perl-base perl-modules pslib1 python python-minimal python2.7 python2.7-minimal vim vim-common
    vim-nox vim-runtime vim-tiny
    Vorgeschlagene Pakete:
    aspell-doc spellutils libapache2-mod-python-doc libdata-dump-perl ttf-baekmuk ttf-arphic-gbsn00lp ttf-arphic-bsmi00lp ttf-arphic-gkai00mp ttf-arphic-bkai00mp lm-sensors snmp-mibs-downloader
    libcache-memcached-perl libmemcached perl-doc libterm-readline-gnu-perl libterm-readline-perl-perl libpod-plainer-perl python-tk python2.7-doc binfmt-support ctags vim-doc vim-scripts cscope indent
    Die folgenden Pakete werden ENTFERNT:
    apache2-mpm-itk apt-listchanges defoma libdigest-sha1-perl libmagickcore3-extra libpango1.0-common libperl5.10 libwmf0.2-7 python-apt x-ttcidfont-conf
    Die folgenden NEUEN Pakete werden installiert:
    apache2-mpm-prefork aspell aspell-en libapache2-mod-php5 libapache2-mod-python libaspell15 libclass-isa-perl libevent-2.0-5 libffi5 libicu48 liblua5.1-0 libmemcached11 libming1 libperl5.14 libpython2.7
    librecode0 libruby1.9.1 libsensors4 libsnmp-base libsnmp15 libswitch-perl libtidy-0.99-0 libyaml-0-2 memcached php5-intl php5-memcache php5-memcached php5-ming php5-ps php5-pspell php5-recode php5-snmp
    php5-sqlite php5-tidy php5-xmlrpc php5-xsl pslib1 python2.7 python2.7-minimal
    Die folgenden Pakete werden aktualisiert (Upgrade):
    libalgorithm-diff-xs-perl libberkeleydb-perl libcompress-raw-zlib-perl libconvert-uulib-perl libcrypt-openssl-bignum-perl libcrypt-openssl-rsa-perl libdbd-mysql-perl libdbi-perl libfont-freetype-perl
    libglib2.0-0 libhtml-parser-perl liblocale-gettext-perl libnet-dns-perl libnet-libidn-perl libnet-ssleay-perl libnetaddr-ip-perl libpango1.0-0 libruby libsocket6-perl libtext-charwidth-perl
    libtext-iconv-perl libunix-syslog-perl libuuid-perl perl perl-base perl-modules python python-minimal vim vim-common vim-nox vim-runtime vim-tiny
    33 aktualisiert, 39 neu installiert, 10 zu entfernen und 96 nicht aktualisiert.

    nun mal sehen
     
  8. Le-Seaw

    Le-Seaw Member

    anscheinend läuft es wieder :)
    aber irgendwie ist die konsole beim update abgestürzt

    was natürlich mal wieder klasse ist, nun weiss ich nicht ob er noch auf eingaben wartet ;(

    aber danke dir erstmal für das bisherige
    Rest dann morgen.
    Ob es wirklich alles geklappt hat wie es soll.
     
    Zuletzt bearbeitet: 16. Mai 2013
  9. Till

    Till Administrator

    Solche Protesse sollte man besser über screen laufen lassen, dann macht es nichts wenn der client mal abstürzt oder die Verbindung abbricht.
     
  10. Le-Seaw

    Le-Seaw Member

    Zuletzt bearbeitet: 17. Mai 2013
  11. planet_fox

    planet_fox Super-Moderator

    Hast du mal versucht ISPCOnfig 3 drüber zu instalieren ?
     

Diese Seite empfehlen