Upgrade auf Ubuntu 14.04.1 - client denied by server configuration (Apache2)

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Mistralis, 13. Okt. 2014.

  1. Mistralis

    Mistralis New Member

    Moin,
    ich mag Euer Produkt. Es ist schnell, zuverlässig und wirklich gut zu nutzen! Insofern zunächst einmal ein dickes Lob an Euch. Bitte weiter so :)
    Nach dem Upgrade von Ubuntu 13 auf 14.04.1, kämpfe ich allerdings nun mit ein paar Problemen. Das meiste konnte ich fixen, nun stecke ich allerdings fest bzw. 'möchte' nicht weitermachen, da ich meiner Meinung nach zu viel manuell beheben würde und ispconfig so umgehen würde.

    Die Fehlermeldung lautet:
    Code:
     [access_compat:error] [pid 12850] [client 127.0.0.1:50971] AH01797: client denied by server configuration: /var/www/<DOMAIN>.de/
    Soweit ich das mitbekommen habe haben sich im Apache2 die Restriktionen bzgl. 'Deny from all' / 'Allow from all' geändert.
    Aus bisher
    Code:
    Order allow,deny
    Allow from all
    wird jetzt
    Code:
    Require all granted
    und aus
    Code:
    Order allow,deny
    Deny from all
    wird
    Code:
    Require all denied
    Zur Frage:
    Soll ich das jetzt in den ganzen Webseitenkonfigurationen manuell anpassen, oder wird es demnächst ein Update geben, was diesen Punkt beinhaltet?
    Oder bin ich auf dem Holzweg und meine Aussage stimmt gar nicht? ;-)

    Eine weitere Anpassung im Apache betrifft die Angabe der auszulesenden Konfigurationen. Siehe
    http://howproblemsolution.com/fix/updating-ispconfig-3-apache-configuration-2-4.22532/
    Hinweis:
    https://wiki.apache.org/httpd/ClientDeniedByServerConfiguration
    Gruß,
    Mistralis
     
  2. Till

    Till Administrator

    Apache 2.4 wird schon lange von ispconfig unterstützt und manuell musst Du da auch nicht das ändern was er da gepostet hat. Das was der Typ in dem von Dir geposteten Thread geschrieben hat basiert alles auf dem Fehler dass er das ISPconfig update vergessen hat und das resync der Webseiten und nicht ins aktuelle ubuntu setup gesehen hat. Es ist immer wieder tragisch wie viele falsche Dinge im Netz gepostet werden nur weil jemand nicht mal in einem Forum fragt in dem man sich mit der von ihm verwendeten Software auskennt.

    Hast Du ein ispconfig update mit "reconfigure services" gemacht? Wenn nicht, dann hast Dú noch apache 2.2config files aber mit dem ubuntu auf apache 2.4 aktualisiert. Also immer nach einem dist upgrade ispconfig mit reconfigure services upgraden. Bei einem apache 2.2 auf 2.4 wechsel muss man zusätzlich ein website resync machen, damit alle website config files auch auf 2.4 syntax aktualisiert werden.

    Des weiteren alle schritte vom apache Kapitel 14 aus http://www.howtoforge.com/perfect-s...hp-mysql-pureftpd-bind-dovecot-ispconfig-3-p4 ausführen, damit Du alle Pakete hast und sicher gestellt ist, dass Du auch die apache2.conf passend editiert hast.
     
  3. Mistralis

    Mistralis New Member

    Hallo Till,
    vielen Dank für die schnelle Antwort.

    Ja, ich habe natürlich ein update mit 'reconfigure services' durchgeführt. Auch bin ich die Anleitung nach dem dist upgrade durchgegangen und musste auch Pakete nachinstallieren :)

    Was noch fehlte war der resync. Nachdem ich diesen jetzt ausgeführt habe erhalte ich dennoch weiterhin die Meldung
    Code:
    [pid 19641] [client 127.0.0.1:51763] AH01630: client denied by server configuration: /var/www/<DOMAIN>.de/
    Die Meldung an sich ist grundsätzlich ja auch richtig, da (nach dem sync) in der vhost der Domain der Eintrag 'Require all denied' für das Verzeichnis '<DOMAIN>/' gesetzt ist. Nur für '<DOMAIN>/web' ist ein 'Require all granted' angegeben. Da allerdings scheinbar ein Cronjob alle paar Minuten diese Meldungen für alle Domains auslöst, sieht mir das nicht nach einem gewünschtem Verhalten aus, oder?

    Gruß,
    Marcus
     
  4. Till

    Till Administrator

    Es gibt für den Apache keinen Verweis auf /var/www/<DOMAIN>.de/ in der ispconfig Standardkonfiguration, daher wundert mich wie anfragen darauf ins Log kommen können. alle Vhosts verweisen auf das /web/ Unterverzeichnis. Oder hast Du eine custom vhost.conf.master?

    Wie oft taucht dass denn im log auf, also alle wieviel Minuten?

    Hast Du die apache2.conf wie im Tutorial beschrieben geändert?
     
  5. Mistralis

    Mistralis New Member

    Alle 60 Sekunden.

    Leider finde ich unter dem Link, den Du gepostet hast, keine spezifischen apache2.conf Angaben. Wo steht das genau?

    conf.d
    Code:
    lrwxrwxrwx 1 root root  24 Feb 28  2014 mailman.conf -> /etc/mailman/apache.conf
    -rw-r--r-- 1 root root  98 Jun 25 22:29 owncloud.conf
    lrwxrwxrwx 1 root root  28 Feb 28  2014 phpmyadmin.conf -> ../../phpmyadmin/apache.conf
    lrwxrwxrwx 1 root root  26 Oct 13 10:23 roundcube.conf -> /etc/roundcube/apache.conf
    sites-enabled (ohne die ganzen Domains selber)
    Code:
    lrwxrwxrwx 1 root root  39 Feb 28  2014 000-apps.vhost -> /etc/apache2/sites-available/apps.vhost
    lrwxrwxrwx 1 root root  35 Oct 12 18:26 000-default.conf -> ../sites-available/000-default.conf
    lrwxrwxrwx 1 root root  43 Feb 28  2014 000-ispconfig.conf -> /etc/apache2/sites-available/ispconfig.conf
    lrwxrwxrwx 1 root root  44 Feb 28  2014 000-ispconfig.vhost -> /etc/apache2/sites-available/ispconfig.vhost
    lrwxrwxrwx 1 root root  35 Oct 12 18:26 default-ssl.conf -> ../sites-available/default-ssl.conf
    Inhalt der 000-default.conf (daran wird es wohl liegen?!)
    Code:
    <VirtualHost <IP-Adresse>:80>
      ServerAdmin webmaster@localhost
    
      DocumentRoot /var/www
      <Directory />
      Options FollowSymLinks
      AllowOverride None
      </Directory>
      <Directory /var/www/>
      Options Indexes FollowSymLinks MultiViews
      AllowOverride None
      #Order allow,deny
      #deny from all
      Require all denied
      </Directory>
    ...
     
  6. Mistralis

    Mistralis New Member

    Ich habe die Seite einfach mal deaktiviert, daran lag es allerdings nicht. Die Meldungen kommen weiterhin.
     
  7. catfish

    catfish New Member

    Hallo, ich habe ein ähnliches Problem. Nach Upgrade auf Ubuntu 14.04 von 12.04.
    Owncloud ist bei mir in einem Unterverzeichnis eines vhost installiert. Unter dem vhost ist auch ein blog installiert.
    Der läuft weiterhin. Nur owncloud beendet sich mit
    "AH01630: client denied by server configuration: /var/www/clients/client4/web4/web/owncloud/remote.php"
    Muß ich die .htaccess von owncloud anpassen, damit sie mit dem neuen apache klarkommt?
    Danke vorab ;)
     
  8. nowayback

    nowayback Well-Known Member

    vhosts durchgucken und Allow from all durch
    Code:
    Require all granted
    ersetzen wenn ich mich richtig erinnere
     
  9. catfish

    catfish New Member

    jap, vollgendes hat geholfen:
    Code:
    <ifModule mod_authz_core.c>
    Require all granted
    #Require all denied
    </ifModule>
    
    merci ;)
     

Diese Seite empfehlen