Upgrade Debian Lenny->Squeeze

#1
Upgrade Debian Lenny->Squeeze(gelöst)

Nach upgrade Lenny->Squeeze funktioniert kein Mailversand mehr.
Ich benutze Basis ist ispconfig 3.03

Auf den Port 25 kann ich mit telnet server 25 aus der Ferne connecten.
Authentifizieren schlägt allerdings fehl. (auch mit telnet probiert)
Code:
telnet daucity.de 25
Trying 188.40.141.52...
Connected to daucity.de.
Escape character is '^]'.
220 rootgemeinschaft.de ESMTP Postfix (Debian/GNU)
EHLO daucity.de
250-rootgemeinschaft.de
250-PIPELINING
250-SIZE
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH PLAIN LOGIN
250-AUTH=PLAIN LOGIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
AUTH PLAIN YmVybmblblblblbxxxxxxxd2FyZTAz
535 5.7.8 Error: authentication failed: authentication failure
Das AUTH PLAIN habe ich mit
Code:
perl -MMIME::Base64 -e 'print encode_base64("name@daucity.de\0name@daucity.de\0PassWort");'
erstellt
Da ispconfig mit pam_mysql.so arbeitet, kann ich evtl. auch völlig falsch liegen

Einloggen per IMAP funktioniert, Mails kommen weiterhin an.
Webinterface Squirrelmail funktioniert.

Ich brauche einen Denkanstoß wo ich suchen kann.
Während ich dies hier schreibe, kommt mir die Idee, mal genauer die PAM Geschichte zu beleuchten... Vielleicht habe ich auch beim Upgrade an der falschen Stelle eine geänderte Config Datei des Maintainers akzepiert ?
Edit: Nein, scheinbar nicht
Fehlermeldungen:
Aug 22 20:17:39 rootgemeinschaft postfix/smtpd[30060]: warning: SASL authentication failure: Password verification failed
Aug 22 20:17:39 rootgemeinschaft postfix/smtpd[30060]: warning: 77-21-xx-xx-dynip.superkabel.de[77.21.xx.xx]: SASL PLAIN authentication failed: authentication failure
Aug 22 20:18:48 rootgemeinschaft postfix/smtpd[30060]: warning: SASL authentication failure: Password verification failed
Aug 22 20:18:48 rootgemeinschaft postfix/smtpd[30060]: warning: localhost[127.0.0.1]: SASL PLAIN authentication failed: authentication failure

Also Remote und Local, Fehlermeldung beim Auth
 
Zuletzt bearbeitet:

Till

Administrator
#2
Ich denke Du wirst da wo´hl eine Config datei beim Update überschrieben haben. ISPConfig 3 tar.gz runterladn, entpacken, update.php aufrufen und auswählen dass ISPConfig die Dienste neu konfigurieren soll.
 
#3
Gelöst.
Habe gestern wieder die /etc/pam.d/smtp hergestellt, die ich für Testzwecke geändert hatte.
Nun geht es wieder. Warum es vorher nicht ging? Keine Ahnung
Mail bringt mich nochmal ins Grab ::confused::
 

Werbung

Top