Upgrade von Wheezy auf Jessie schlägt fehl ...

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von nofreak, 28. Juli 2016.

  1. nofreak

    nofreak Member

    Hallo in die Runde,

    leider auf einem Produktivsystem ein Update gewagt (Daten sind vorher gesichert worden).

    Vorgegangen nach folgender Anleitung:

    https://www.howtoforge.com/tutorial/how-to-upgrade-debian-wheezy-to-jessie-stable-release/

    Beim apt-get dist-upgrade (auf Jessie) kam dann folgende Meldung:

    dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/php5-json_1.3.6-1_amd64.deb (--unpack):
    Versuch, »/usr/include/php5/ext/json/php_json.h« zu überschreiben, welches auch in Paket php5-dev 5.5.38-1~dotdeb+7.1 ist
    Fehler traten auf beim Bearbeiten von:
    /var/cache/apt/archives/php5-json_1.3.6-1_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    Nun hängt das gesamt Update fest.

    Ein apt-get -f install hilft nichts. Ein apt-get dist-upgrade bringt nun folgende Abhängigkeitsprobleme:

    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.
    Statusinformationen werden eingelesen.... Fertig
    Abhängigkeiten werden korrigiert ... fehlgeschlagen.
    Die folgenden Pakete haben unerfüllte Abhängigkeiten:
    apache2 : Hängt ab von: apache2.2-common (= 2.2.22-13+deb7u7) aber 2.4.10-10+deb8u5 ist installiert
    apache2-mpm-prefork : Hängt ab von: apache2.2-common (= 2.2.22-13+deb7u7) aber 2.4.10-10+deb8u5 ist installiert
    Hängt ab von: apache2.2-bin (= 2.2.22-13+deb7u7) aber 2.4.10-10+deb8u5 ist installiert
    apache2.2-common : Hängt ab von: apache2 (>= 2.3~)
    dpkg : Beschädigt: man-db (< 2.6.3-6~) aber 2.6.2-1 ist installiert
    libapache2-mod-php5 : Hängt ab von: apache2 (>= 2.4)
    Hängt ab von: php5-json ist aber nicht installiert
    libapache2-svn : Hängt ab von: libapache2-mod-svn ist aber nicht installiert
    libpam-ck-connector : Hängt ab von: libck-connector0 (= 0.4.6-5) aber 0.4.5-3.1 ist installiert
    php5-apcu : Hängt ab von: php5-common (= 5.5.38-1~dotdeb+7.1) aber 5.6.24+dfsg-0+deb8u1 ist installiert
    php5-cgi : Hängt ab von: php5-common (= 5.5.38-1~dotdeb+7.1) aber 5.6.24+dfsg-0+deb8u1 ist installiert
    Hängt ab von: php5-json ist aber nicht installiert
    php5-cli : Hängt ab von: php5-common (= 5.5.38-1~dotdeb+7.1) aber 5.6.24+dfsg-0+deb8u1 ist installiert
    Hängt ab von: php5-json ist aber nicht installiert
    Empfiehlt: php5-readline ist aber nicht installiert
    php5-curl : Hängt ab von: phpapi-20121212 ist aber nicht installierbar
    Hängt ab von: php5-common (= 5.5.38-1~dotdeb+7.1) aber 5.6.24+dfsg-0+deb8u1 ist installiert
    php5-gd : Hängt ab von: phpapi-20121212 ist aber nicht installierbar
    Hängt ab von: php5-common (= 5.5.38-1~dotdeb+7.1) aber 5.6.24+dfsg-0+deb8u1 ist installiert
    php5-imagick : Hängt ab von: php5-common (= 5.5.38-1~dotdeb+7.1) aber 5.6.24+dfsg-0+deb8u1 ist installiert
    php5-imap : Hängt ab von: phpapi-20121212 ist aber nicht installierbar
    Hängt ab von: php5-common (= 5.5.38-1~dotdeb+7.1) aber 5.6.24+dfsg-0+deb8u1 ist installiert
    php5-mcrypt : Hängt ab von: phpapi-20121212 ist aber nicht installierbar
    Hängt ab von: php5-common (= 5.5.38-1~dotdeb+7.1) aber 5.6.24+dfsg-0+deb8u1 ist installiert
    php5-mysql : Hängt ab von: phpapi-20121212 ist aber nicht installierbar
    Hängt ab von: php5-common (= 5.5.38-1~dotdeb+7.1) aber 5.6.24+dfsg-0+deb8u1 ist installiert
    pkg-php-tools : Hängt ab von: php5-json ist aber nicht installiert
    E: Fehler: Unterbrechungen durch pkgProblemResolver::Resolve hervorgerufen; dies könnte durch zurückgehaltene Pakete verursacht worden sein.
    E: Abhängigkeiten konnten nicht korrigiert werden.


    Und ich hänge jetzt fest mit meiner Weisheit ...

    Hat jemand Ideen, wie ich aus dieser Situation entweder:
    a) Das Update fortsetzen kann
    b) Das Update zurücksetzen kann?

    Danke für Hilfen jedweder Art.

    Gruß
    Frank
     
  2. nofreak

    nofreak Member

    Hallo,

    ich war mal mutig:

    aptitude --full-resolver upgrade

    Jedenfalls tut sich was ... mal schauen wo es endet ...
     
  3. nofreak

    nofreak Member

    Schonmal gut ...

    im Anschluss konnte ich ein
    apt-get dist-upgrade

    Dann kamen Fehlermeldungen (s.o. Abhängigkeiten etc.)

    Dann ein
    apt-get -f install

    und es läuft weiter ...

    Spannung steigt ;-)
     
  4. nofreak

    nofreak Member

    ... so: Problem behoben ...

    War ein wenig hakelig und apt-get dist-upgrade musste ein wenig häufig gestartet werden, aber die Hilfe kam wirklich über
    aptitude --full-resolver upgrade

    Ein paar PHP5-Module wurde nicht installiert und mussten von Hand nachinstalliert werden.
    Apache2 startete dadurch nicht.

    Im Anschluss war noch ein ispconfig-Update mit Reconfigure Services notwendig...

    Und jetzt läuft alles ... Perfekt ...

    Danke für nicht ;-) Oder fürs Zuhören - hätte ja auch anders ausgehen können.

    LG
    Frank
     
    dexcom und florian030 gefällt das.

Diese Seite empfehlen