"/var/mail/getmail" riesig

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Chris, 15. Juni 2010.

  1. Chris

    Chris New Member

    Ich nutze ISPConfig in der Version 3.0.2.1 und habe das System nach diesem Tutorial eingerichtet: http://www.howtoforge.com/perfect-server-debian-lenny-ispconfig3

    Über den Bereich E-Mail->Fetchmail habe ich einige Konten angelegt um die E-Mails vom alten E-Mail-Server auf den neuen zu holen. Jetzt ist mir die Datei "/var/mail/getmail" aufgefallen, die bereits eine Größe von mehreren hundert MB angenommen hat. Die Man-Page von getmail macht nicht viel her, die Einstellungen unter /etc/getmail/ sind für jedes Postfach einzeln.
    Kann ich die Datei /var/mail/getmail einfach löschen oder noch besser wo kann ich festlegen wie groß die Datei maximal sein darf bevor sie gelöscht wird. In der Datei /var/mail/getmail sind einige Spam-Mails drin. Wer schreibt alles in diese Datei?

    Ich bin davon ausgegangen, dass die E-Mails, die per getmail abgerufen werden gleich im Maildir-Format in das angegebene Postfach transportiert werden. Warum stehen dann E-Mails im mbox-Format in der Datei /var/mail/getmail?
     
  2. Till

    Till Administrator

    Du kannst /var/mail/getmail löschen. Die Datei wird nicht verwendet. Ich vermute mal dass es sich bei den Emails darin um Bounces handelt, die von Postfix an den Linux System User getmail zugestellt wurden, weil keine richtige to: Adresse vorhanden war.
     
  3. Chris

    Chris New Member

    Vielen Dank für die schnelle Antwort. Wo muss ich die to: Adresse angeben, damit diese Datei nicht wieder erstellt wird? Ich vermute, dass es ein Parameter in der main.cf von postfix ist. Wie heißt dieser Parameter?
     
  4. Till

    Till Administrator

    Die kannst Du nirgends angeben. Das sind Bounces mit defekter Adresse.
     
  5. Chris

    Chris New Member

    Also hat das nichts mit der Einstellung "error_notice_recipient= postmaster" zu tun? Kann an dieser Stelle postmaster stehen bleiben oder sollte ich dort eine fqdn-Adresse angeben wie postmaster@mydomain.tld und diese Adresse im ISPConfig anlegen?
     
  6. Till

    Till Administrator

    Das hat mit der postmaster Einstellung von Postfux nchts zu tun.
     

Diese Seite empfehlen