/var/mail/mail läuft voll

#1
Ich kann es mir irgendwie nicht erklären, aber es ist so:

/var/mail/nobody ist vollgelaufen, weil ich zu faul war, bei meinem Bash-Script das abzustellen.
Da habe ich gesehen, daß /var/mail/mail mittlerweile auch ganz schön vollgelaufen ist...
Lustigerweise 100% Spam, also nix Wichtiges drin.
Kurioserweise nur Emails für eine Kundendomain, für die es gar keine Emailadresse gibt (leerstehende Domain), Emailempfänger: mail@domainname.de


Any clues?
 

Till

Administrator
#4
Schalte mal in der Datei /home/admispconfig/ispconfig/lib/config.inc.php den Modus für den Mailserver von sendmail auf postfix und ändere dann einen beliebigen Email account.
 
#5
Hm, hat das einen bestimmten Grund, und vor allem, was ändert sich da dann serverweit?

Nicht, daß ich mir jetzt dann ein bestehendes, und gut laufendes System zerschiesse :)
(Thema Emailaccounts putt oder so...)

So, habs mal in mein Testsystem gestellt, uiuiui, wie zu erwarten, alles hächselhächsel...

MailerDaemon, not found... und das nicht gerade wenig...

This is the mail system at host xyz.testdomain.de.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The mail system

<admispconfig@localhost.localdomain>: Host or domain name not found. Name
service error for name=localhost.localdomain type=A: Host not found
So, auch nachdem ich das wieder zurückgestellt habe, hört das mit dem MailerDaemon nicht mehr auf.

Kriegt man das noch irgendwie wieder hingebogen???

Noch eine Ergänzung:
ich habe jetzt im Log:
debian postfix/trivial-rewrite[26560]: warning: do not list domain xyz.testdomain.de in BOTH mydestination and virtual_alias_domains
 
Zuletzt bearbeitet:
#6
So, Fehler gefunden, aber keine Ahnung, wie der zu beheben ist:

Postfix guckt in die:
/etc/postfix/local-host-names

Auf dem anderen Server stehen da artig alle Domains drin, die registriert sind.
Kurios dabei aber, daß auch Domains noch drin stehen, die ich schon gelöscht habe...???

Auf dem anderen nicht.
da steht nur der Servername drin.


Frage: wie bekomme ich ISPConfig/Postfix/wenauchimmer dazu, die datei wieder ordentlich zu befüllen?
 

Till

Administrator
#7
Stell es bitte einfach so um, wie ich beschrieben habe, nach der Umstellung dürfen da auch nicht mehrdie Domains drin stehen, da es sich um einen anderen Modus handelt der nur auf die virtusertable Datei zurückgreift.

Zu Dem obigen Problem: Stells icher, dass Du localhost.localdomain in der /etc/hosts Datei drin hast und füge es ggf. am Ende der /local-host-names datei mit ein.
 

Werbung