Vhost Conf und PHP Problem

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von CodeBlue, 11. Aug. 2008.

  1. CodeBlue

    CodeBlue New Member

    Ich hab ein Problem mit der Zeile "php_admin_flag safe_mode Off" in der Vhosts_ispconfig.conf.
    Wenn ich "httpd -t" ausführe bekommen ich den Fehler "Invalid command 'php_admin_flag', perhaps mis-spelled or defined by a module not included in the server configuration".

    Wenn ich die Zeile entferne kommt der Fehler zwar nicht mehr, aber auf den Webseiten lassen sich keinen PHP-Seiten ausführen (ISPConfig funktioniert).

    Was läuft hier falsch? :(

    Meine Vhosts_ispconfig.conf
    Code:
    ###################################
    #
    NameVirtualHost 78.47.4.109:80
    <VirtualHost 78.47.4.109:80>
      ServerName localhost
      ServerAdmin root@localhost
      DocumentRoot /var/www/sharedip
      <IfModule mod_rewrite.c>    
        RewriteEngine on  
        RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
        RewriteRule .* - [F]
      </IfModule>
    </VirtualHost>
    #
    #
    ######################################
    # Vhost: www.jc-b.de:80
    ######################################
    #
    #
    <VirtualHost 78.47.4.109:80>
    SuexecUserGroup web4_admin web4
    ServerName www.jc-b.de:80
    ServerAdmin webmaster@jc-b.de
    DocumentRoot /var/www/web4/web
    ServerAlias old.jc-b.de jc-b.de admin.jc-b.de
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    Alias  /cgi-bin/ /var/www/web4/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    ErrorLog /var/www/web4/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    <Files *.php>
        SetOutputFilter PHP   
        SetInputFilter PHP
    </Files>
    <Files *.php3>
        SetOutputFilter PHP
        SetInputFilter PHP 
    </Files>
    <Files *.php4>
        SetOutputFilter PHP
        SetInputFilter PHP 
    </Files>
    <Files *.php5>
        SetOutputFilter PHP
        SetInputFilter PHP 
    </Files>
    php_admin_flag safe_mode Off
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    AddType application/vnd.wap.wmlscriptc .wmlsc .wsc
    AddType text/vnd.wap.wml .wml
    AddType text/vnd.wap.wmlscript .ws .wmlscript
    AddType image/vnd.wap.wbmp .wbmp
    Alias /error/ "/var/www/web4/web/error/"ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web4/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web4/user/$1/web/$3
    RewriteEngine on
    RewriteCond %{HTTP_HOST}   ^old\.jc-b\.de [NC]
    RewriteRule   ^/(.*)$  http://www.jc-b.de/old$1  [R]
    RewriteCond %{HTTP_HOST}   ^jc-b\.de [NC]
    RewriteRule   ^/(.*)$  http://www.jc-b.de/site$1  [R]
    RewriteCond %{HTTP_HOST}   ^admin\.jc-b\.de [NC]
    RewriteRule   ^/(.*)$  http://www.jc-b.de/admin$1  [R]
    <IfModule mod_rewrite.c>
      RewriteEngine on
      RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
      RewriteRule .* - [F]
    </IfModule>
    </VirtualHost>
    
     
  2. Till

    Till Administrator

    Stelle bitte sicher, dass Du mod_php installiert hast.
     
  3. CodeBlue

    CodeBlue New Member

    Na super. mod_php war nicht vorhanden. Ich wollte es mir einfach machen und hab die VMWare Virtualisierung mit ISPConfig genutzt. Dort war SuPHP :confused: dabei und das konnte nicht funktionieren.

    Danke für die Mühe
     
  4. Till

    Till Administrator

    Wenn Du Suphp nutzen willst, dann musst Du es in der datei /home/admispconfig/ispconfig/lib/config.inc.php einstellen. Ansonsten nimmt ISPConfig die Einstellungen für mod_php. Das VMWare Imga enimmt suphp und funktioniert auch so, aber Du hast vermutlich die ISPConfig Version upgedatet und das ISPConfig in dem VMWare Image ist eine gepatchte Variante.
     
  5. CodeBlue

    CodeBlue New Member

    Ja genau, hab ISPConfig upgedatet. Aber hab jetzt php_mod installiert und SuPHP entfernt. Jetzt passt alles. Aber gut zu wissen woran es lag.
     

Diese Seite empfehlen