VHost-Eintrag für Port 443 wird nicht geschrieben

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von win_tho, 16. März 2014.

  1. win_tho

    win_tho Member

    Hallo,

    bin gerade etwas am verzweifeln: Ich versuche auf meinem Server (Debian6 ISPC 3.0.4) für eine Website SSL zu aktivieren. Doch der entsprechende Eintrag für Port 443 in der /etc/apache2/sites-available/mydomain.de.vhost wird nicht geschrieben. Es erscheint dort nur der VirtualHost für *:80.

    Alle Tricks, die ich gefunden habe (Exklusive IP für Domain, SNI aktivieren, etc...) zeigen auch keine Wirkung.

    Das merkwürdige dabei: Habe noch mehrere Server (ebenfalls Debian) dort hatte ich noch nie solche Probleme.

    Hat jemand ein Tipp?

    Tausend Dank im Voraus!
     
  2. sence123

    sence123 New Member

    re

    wenn du kannst, mach nen Backup und upgrade die Version
    (ggf. nen Bug? )
     
  3. Till

    Till Administrator

    Der ssl teil des vhost wird nur geschrieben, wenn apache mit dem ssl teil startet, wenn nicht, wird er wieder entfernt. die häufigste Ursache ist dass das SSL cert defekt ist oder ssl cert und key nicht zusammen passen.
     
  4. win_tho

    win_tho Member

    Hallo,

    vielen Dank für die Rückmeldung. Die E-Mail-Benarichtigung ist bei mir im SPAM gelandet, daher antworte ich erst jetzt.

    Trage ich den Eintrag per Hand startet der Apache wunderbar:

    Restarting web server: apache2[Sun Mar 30 11:43:12 2014] [warn] NameVirtualHost 46.163.....:80 has no VirtualHosts
    [Sun Mar 30 11:43:12 2014] [warn] NameVirtualHost 46.163.....:443 has no VirtualHosts
    ... waiting [Sun Mar 30 11:43:13 2014] [warn] NameVirtualHost 46.163......:80 has no VirtualHosts
    [Sun Mar 30 11:43:13 2014] [warn] NameVirtualHost 46.163......:443 has no VirtualHosts
    .

    SSL Zertifikat, Key, etc... stimmen auch.

    Um zu überprüfen, ob es vielleicht zu diesem Verhalten kommt, da es ein Domain-Wildcard-Zertifikat ist, habe ich noch einmal einen weiteren einfachen Vhost angelegt, mit einem Zertifkat, etc.. das auf einem anderen ISPC-Server funktioniert. Auch hier wird der Eintrag nicht erstellt...

    Hat jemand noch eine Idee? Ein Bug kann es eigentlich nicht sein. Die gleiche Version läuft wie gesagt auf einem anderen Server ohne Probleme.
     
  5. win_tho

    win_tho Member

    Noch ein Nachtrag: Ich nehme alles zurück... Nachdem ich noch einmal auf "Save certificate" gegangen bin, scheint nun alles zu funktionieren. Zumindest bleibt der 443-Vhost bestehen, wenn die Datei von ISPConfig neu geschrieben wird.
     
  6. davidak

    davidak New Member

    Hallo, ich habe das gleiche Problem.
    Gekauftes Zertifikat von RapidSSL, SSL ist für die Webseite aktiviert, "Zertifikat speichern" wurde ausgewählt, es laufen noch andere Seiten mit SSL auf der IP, aber SNI ist aktiviert.
    Es wird kein VHost für Port 443 geschrieben.
    ---
    Ubuntu 12.04.4 LTS Server mit ISPConfig 3.0.5.4p9
     
  7. robotto7831a

    robotto7831a Member

    Gibt es vielleicht in dem VHost Verzeichnis eine err Datei?
     
  8. davidak

    davidak New Member

    Tatsächlich liegt dort für den entsprechenden VHost eine .err Datei.
    Wie kann ich herausfinden, was das Problem ist?
     
    Zuletzt bearbeitet: 7. Nov. 2016
  9. robotto7831a

    robotto7831a Member

    Dann ist in der VHost Datei ein Fehler enthalten.

    Benenn die aktuelle VHost Datei mal um und mach die err Datei zur aktuellen Datei. Dann mach mal ein Configcheck was dort falsch sein soll.
     
  10. davidak

    davidak New Member

    Ich hab einen Symlink der .err Datei nach /etc/apache2/sites-enabled/0000.vhost erstellt und apache2ctl configtest ausgeführt.

    Syntax OK

    Wenn ich den Webserver damit neustarte schlägt es fehl.
    Error-Log:
    [Mon Nov 07 18:47:39 2016] [error] [mod_pagespeed 1.11.33.4-0 @6609] Attempt to destroy unknown SHM segment [1]/var/cache/mod_pagespeed/ flush /named_locks.
    [Mon Nov 07 18:47:39 2016] [error] [mod_pagespeed 1.11.33.4-0 @6609] Attempt to destroy unknown SHM segment [1]pagespeed_default_shm/metadata_cache.
    [Mon Nov 07 18:47:39 2016] [error] [mod_pagespeed 1.11.33.4-0 @6609] Attempt to destroy unknown SHM segment [1]globalstatistics.
    [Mon Nov 07 18:47:39 2016] [error] [mod_pagespeed @6609] [1107/184739:ERROR:google_message_handler.cc(59)] Attempt to destroy unknown SHM segment [1]SharedCircularBuffer.:0.

    Das hilft mir schonmal weiter, Danke!
     

Diese Seite empfehlen