Vserver fstab Konfiguration

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von mycrotrend, 7. Feb. 2012.

  1. mycrotrend

    mycrotrend Member

    Ich habe nun erfolgreich meine Vserver angelegt. Wenn ich nun auf einen Vserver ISPConfig installieren möchte, ist meine komplette fstab Konfigurationsdatei ( /etc/fstab ) leer.

    Woher weiss ich nun genau, was ich dort eintragen muss?
     
  2. Till

    Till Administrator

    Bei OpenVZ muss in der fstab innerhalb der VM nichts eingetragen werden, da das quota durch openvz verwaltet wird.

    Stattdessen kannst Du quota mit folgender Zeile in den /etc/vz/conf/*.conf Dateien aktivieren, falls es noch nicht in der Datei steht:

    QUOTAUGIDLIMIT="1000"

    Das solltest Du dann auch in der Vorlagendatei unter /usr/local/ispconfig/interface/web/vm/templates/openvz.conf.tpl eintragen.

    Die Zeile schaltet Quota für die ersten 100 Systemuser und Gruppen innerhalb der VM an.
     
  3. mycrotrend

    mycrotrend Member

    Ah okay und noch eine Frage :)

    Wenn ich nun meinen ISPConfig von meinem Vserver in das des "master" server integrieren möchte, fragt mich die expert installation ja nach dem master mysql server.

    Dieser ist ja localhost, allerdings müsste ja der Vserver praktisch "extern" darauf zugreifen, da dieser ja ein eigener Server indemsinne ist. Somit funktioniert localhost auch nicht richtig ? Da stehe ich nämlich gerade :)
     
  4. Till

    Till Administrator

    Der Master server ist nicht localhost sondern der hostserver, Du musst als master server hostnamen also den hostnamen des host systems angeben. vserver sind wie getrennte systeme zu behandeln, also nicht denken dass ein server localhost ist nur weil er sich den prozessor und die festplatte mit einem anderen server teilt.
     
  5. mycrotrend

    mycrotrend Member

    Also ich habe jetzt versucht den VServer in der ISPConfig Installation den Master Server ( der wo alle VServer drauf laufen ) einzutragen.

    Aber der VServer kann anscheinend nicht auf die Datenbank des Master Servers connecten. Der Hostname ist der des Master Servers

    Code:
    root@130-185-109-14:~# hostname
    130-185-109-14
    Code:
    ( VServer IP: 130.185.109.22 )
    Shall this server join an existing ISPConfig multiserver setup (y,n) [n]: y
    
    MySQL master server hostname []: 130-185-109-14
    
    MySQL master server root username [root]: 
    
    MySQL master server root password []: ******
    
    MySQL master server database name [dbispconfig]: 
    
    Unable to connect to mysql server
     
  6. Till

    Till Administrator

    Das ist ja auch kein gültiger (fqdn) Hostname. Schau mal in die multiserver tutorials, da steht drin wie Du einen hostnamen setzt und die /etc/hosts Dateien auf allen beteiligetne Servern konfigurieren musst und wie Du den root User in der mysql master DB anlegst.
     
  7. mycrotrend

    mycrotrend Member

    Masterserver: ( bind-address = 127.0.0.1 ist auskommentiert mit # )
    Code:
    root@master:~# hostname --fqdn
    master.domain.de
    Webserver:
    Code:
    root@master:~# hostname --fqdn
    web.domain.de
    Die IP`s beider Server sind jeweils in der /etc/hosts eingetragen. ( Laut dem Tutorial HowtoForge Linux Tutorials » Multiserver Installation eines Debian 5.0 Server mit ISPConfig 3 )

    In beiden /etc/hosts der Server steht

    Code:
    127.0.0.1       localhost
    130.185.109.22 web.domain.de
    130.185.109.14 master.domain.de
    Ich bekomme allerdings immernoch die Meldung "Unable to connect to mysql server" bei der ISPConfig Installation, wenn ich den webserver den master zuweisen möchte. Auch habe ich einen User in der Datenbank des masters angelegt mit der ip adresse des webservers.
     
  8. Till

    Till Administrator

    Du musst einen root user mit der IP und einen 2. root user mit dem hostnamen des slave servers in der mysql DB des masters anlegen, so wie es im tutorial steht. Ein User nur mit der IP reicht bei mysql nicht. Danach musst Du mysql reloaden.
     
  9. mycrotrend

    mycrotrend Member

    Erstmal vielen Dank für deine Hilfe.

    Ich habe es nun soweit alles hinbekommen, dass alle drei Server ( web,mail,db ) installiert und alle in einem Interface angezeigt werden.

    Der FTP des web`s klappt einwandfrei. Allerdings funktionieren Datenbank und Mailserver anscheinend nicht korrekt.

    Mailserver:
    Hier stehen die Mails laut Protokoll in der Warteschlange.
    Code:
    (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    Mit meinen Email Programm kann ich mich allerdings schon mit dem Email Account verbinden und auch versenden. Dort bekomme ich keinen Fehler.


    Datenbankserver:
    Hier habe ich keinerlei Informationen. Wenn ich eine neue Datenbank anlege wird auch der Datenbank Server ausgewählt. Wenn ich mich allerdings nun mit den Daten in phpmyadmin einloggen möchte, funktioniert dies auch nicht.

    Könntest du mir noch ein letztes mal weiterhelfen? :)
     
  10. Till

    Till Administrator

    Mailserver:

    amavis is nicht gestartet.

    Datenbankserver: Ist denn die DB und der User da? Wenn nicht, siehe Debugging Anleitung in der FAQ. Der wahrscheinlichste Grund dafür wenn keine Datenbanken angelegt werden ist dass das mysql Root Passwort auf dem slave geändert wurde ohne es auch in /usr/local/ispconfig/server/lib/mysql_clientdb.conf geändert wurde.
     
  11. mycrotrend

    mycrotrend Member

    Mailserver:
    Amavis habe ich nun gestartet auf dem Mailserver

    Code:
    root@mail:/etc/init.d# /etc/init.d/amavis start
    Starting amavisd: perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    	LANGUAGE = (unset),
    	LC_ALL = (unset),
    	LANG = "de_DE.UTF-8"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    amavisd-new.
    Nun steht in der Mail Warteschlange
    Code:
    (host mail.pixelianer.de[85.13.136.130] said: 450 4.2.0 : Recipient address rejected: Greylisted, see http://postgrey.schweikert.ch/help/pixelianer.de.html (in reply to RCPT TO command))
    Datenbankserver:
    Die Datenbank liegt auf dem DB Server in "/var/lib/mysql" und ist eingetragen. Der Benutzer ist ebenfalls eingetragen für die Datenbank.
     
  12. Till

    Till Administrator

    Mailserver: Dann funktioniert ja jetzt alles. Das ist nämlich kein Fehler, sondern greylisting.

    Datenbankserver: Dannn ist ja alles in Ordnung. Welchen phpmyadmin hast Du denn genommen? Du musst den phpmyadmin des Datenbankservers nehmen, nicht den des web oder hostservers. Wenn Du den phpmyadmin des webservers nehmen möchtest, dann musst Du ihn umkonfigurieren so dass er sich auch mit dem dbserver verbinden kann.
     
  13. mycrotrend

    mycrotrend Member

    Okay nachdem ich phpmyadmin installiet und kofiguriert habe komme ich nun über das phpmyadmin des datenbankserver hinein.

    Das Problem liegt ja allerdings nun darin, dass ich auf dem Webserver z.B eine Wordpress Installation habe, die die angelegte Datenbank des Datenbankservers benutzen muss.

    Hier funktioniert die Verbindung nicht, weder mit "localhost" noch mit der IP des Datenbankservers.

    Die IP Adresse in der "/etc/mysql/my.cnf" ist auskommentiert. Also mit einer # davor.

    Mailserver:
    Nun steht im Log die Fehlermeldung
    Code:
    (host 127.0.0.1[127.0.0.1] said: 451 4.5.0 Error in processing, id=08808-02, virus_scan FAILED: AV: ALL VIRUS SCANNERS FAILED (in reply to end of DATA command))
    Ein Auszug aus dem System Log.

    Code:
    Feb 9 08:39:37 mail amavis[8808]: (08808-04) (!)ClamAV-clamd: Can't connect to UNIX socket /var/run/clamav/clamd.ctl: No such file or directory, retrying (2)
    Feb 9 08:39:43 mail amavis[8808]: (08808-04) (!)ClamAV-clamd av-scanner FAILED: run_av error: Too many retries to talk to /var/run/clamav/clamd.ctl (Can't connect to UNIX socket /var/run/clamav/clamd.ctl: No such file or directory) at (eval 105) line 373.\n
    Feb 9 08:39:43 mail amavis[8808]: (08808-04) (!!)WARN: all primary virus scanners failed, considering backups
    Feb 9 08:39:45 mail amavis[8808]: (08808-04) (!)ClamAV-clamscan av-scanner FAILED: /usr/bin/clamscan ABORTED, signal 6 (0006) at (eval 105) line 594.
    Feb 9 08:39:45 mail amavis[8808]: (08808-04) (!!)TROUBLE in check_mail: virus_scan FAILED: AV: ALL VIRUS SCANNERS FAILED
    Feb 9 08:39:45 mail amavis[8808]: (08808-04) (!)PRESERVING EVIDENCE in /var/lib/amavis/tmp/amavis-20120209T083936-08808
    Feb 9 08:39:45 mail postfix/smtp[10087]: 2E907EE1599: to=, relay=127.0.0.1[127.0.0.1]:10024, delay=2239, delays=2229/0.01/0/9.4, dsn=4.5.0, status=deferred (host 127.0.0.1[127.0.0.1] said: 451 4.5.0 Error in processing, id=08808-04, virus_scan FAILED: AV: ALL VIRUS SCANNERS FAILED (in reply to end of DATA command))
     
  14. Till

    Till Administrator

    Du musst den hostnamen des datenbankservers nehmen und nicht localhost.Localhost ist der webserver. Des weiteren must Du beim anlegen der datenbank angeben dass sie von außen zugänglich ist, denn der web und DB server sind ja unterschiedliche server und haben jeweils eine eigene ip.

    Mailserver:

    Clamav ist nicht gestartet.
     
  15. mycrotrend

    mycrotrend Member

    Super, der Datenbank Server klappt soweit, nur der Mailserver zikkt noch rum.

    Ich nehme an, um das PHPmyadmin des Datenbankserver in den Webserver einzutragen muss ich den sys link änder von
    /etc/apache2/conf.d/phpmyadmin.conf auf genau dasselbe Verzeichniss nur ebend auf dem Datenbankserver. Ich nehme an, einfach die IP davor setzen geht wohl nicht oder ? :)

    Mailserver:
    Ich habe Clamav geupdatet und gestartet

    Code:
    root@mail:/etc/init.d# freshclam
    ClamAV update process started at Thu Feb  9 09:53:36 2012
    main.cvd is up to date (version: 54, sigs: 1044387, f-level: 60, builder: sven)
    daily.cvd is up to date (version: 14423, sigs: 89268, f-level: 63, builder: guitar)
    bytecode.cvd is up to date (version: 166, sigs: 41, f-level: 63, builder: edwin)
    root@mail:/etc/init.d# freshclam -d
    allerdings ist im Log wieder der Fehler

    Code:
    (host 127.0.0.1[127.0.0.1] said: 451 4.5.0 Error in processing, id=08809-11, virus_scan FAILED: AV: ALL VIRUS SCANNERS FAILED (in reply to end of DATA command))
    Code:
    Feb 9 10:24:45 mail amavis[8808]: (08808-11) (!!)TROUBLE in check_mail: virus_scan FAILED: AV: ALL VIRUS SCANNERS FAILED
    Feb 9 10:24:45 mail amavis[8808]: (08808-11) (!)PRESERVING EVIDENCE in /var/lib/amavis/tmp/amavis-20120209T102436-08808
    Bisher sind von 6 verschickten Mails vom Mailserver nur zwei angekommen und das auch erst nach c.a 10/15 Minuten. Mails empfangen macht er garnicht.
     
    Zuletzt bearbeitet: 9. Feb. 2012
  16. Till

    Till Administrator

    Nein, Du musst die config.php oder config.inc.php (weiß nicht genau den Namen) von phpmyadmin editieren und eine Sektion für den 2. Server hinzufügen.

    Du hast freshcam gestartet, nicht clamav. Freshclam is der updater und nicht der scanner. Clamav startest Du mit dem start script in /etc/inid.d/ und dass heist calamv oder clamd oder so ähnlich, je nach Linux Distribution.

    Du solltest auch mal mit:

    cat /priv/user_beancounters

    in der mailserver VM nachsehen, ob Du der VM ausreichende resourcen zugewiesen hast.
     
  17. mycrotrend

    mycrotrend Member

    Der Befehl "cat /priv/user_beancounters" bewirkt bei mir nichts, da das Verzeichniss nicht existiert. Auch kein ähnliches.

    Bezüglich Clamav:

    Code:
    root@mail:/etc/init.d# /etc/init.d/clamav-daemon start
    Starting ClamAV daemon: clamd LibClamAV Error: [Bytecode JIT]: bad_alloc: std::bad_alloc
    LibClamAV Error: Bytecode: failed to run selfcheck in JIT mode: Can't allocate memory
    LibClamAV Error: [Bytecode JIT]: [LLVM error] Allocation failed when allocating new memory in the JIT
    Can't allocate RWX Memory: Cannot allocate memory
    LibClamAV Warning: [Bytecode JIT]: recovered from error
    LibClamAV Error: [Bytecode JIT] *** FATAL error encountered during bytecode generation
     failed!
    EDIT: Auch postfix etc. lässt sich anscheinend nicht richtig starten

    dovecot: error while loading shared libraries: libgcrypt.so.11: failed to map segment from shared object: Cannot allocate memory
    root@mail:/etc/init.d# postfix start
    postfix: error while loading shared libraries: libcrypto.so.0.9.8: failed to map segment from shared object: Cannot allocate memory
     
    Zuletzt bearbeitet: 9. Feb. 2012
  18. Till

    Till Administrator

    Soprry, muss heißen:

    cat /proc/user_beancounters

    Deine VM hat zu wenig speicher. Du musst den Speicher der VM erhöhen, ich würde min. 750MB oder sogar 1GB nehmen.
     
  19. mycrotrend

    mycrotrend Member

    Super danke dir.

    Nachdem ich den RAM des VS angehoben habe auf 1024 MB versendet er nun Emails. Auch fix, nicht wie vorher erst nach 10 Minuten.

    Allerdings werden noch keine Mails empfangen. :(

    PS: Was mir im Log auffällt etvtl.

    Feb 9 16:45:01 mail postfix/smtpd[1848]: connect from ip6-localhost[127.0.0.1]
    Feb 9 16:45:01 mail postfix/smtpd[1848]: lost connection after CONNECT from ip6-localhost[127.0.0.1]
    Feb 9 16:45:01 mail postfix/smtpd[1848]: disconnect from ip6-localhost[127.0.0.1]

    Ist das mit IP6 korrekt ?
     
    Zuletzt bearbeitet: 9. Feb. 2012
  20. Till

    Till Administrator

    Das ist alles ok, die Einträge sind vom ispconfig monitor. Laut log werdena lso keine Emails an DeinenSErver geschickt.Prüfe also mal die DNSRecords der verwendeteten Domain, ob Du dort den MX bzw. den A-Record auf den der MX Verweis auch auf die neue IP der Mailserver VM umgestellt hast. Denk auch daran dass änderungen im DNS durcahsu 24 Stunden benötigen.
     

Diese Seite empfehlen