Webadv nicht möglich

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von SandMan, 21. März 2009.

  1. SandMan

    SandMan New Member

    Hi, habe das letzte update gemacht wodurch ja webadv möglich sein soll, habe es in isp für den Reseller sowie Kunden eingestellt und bei dem User. Nun wollte ich von meinem PC aus (Vista 64) eine Verbindung aufbauen, aber da kommt immer die gleiche Fehlermeldung

    "Der eingegebene Ordner ist ungültig. Wählen sie einen anderen Ordner."

    Den Server habe ich folgendermaßen angegeben: http://mein-server.xy bei ftp://mein-server.xy gehts! Aber das ist ja dann keien webadv Verbindung...

    ist das was bekannt woran es liegt?
     
  2. planet_fox

    planet_fox Super-Moderator

    Ist Webdav als apache modul eingerichtet unter mods-enable ? oder hast nur das update durch geführt. ich kanns noch nicht selbst prüfen da ich grad erst das update mache. Aber ich schau mir das an
     
  3. SandMan

    SandMan New Member

    ich habe nur das update ausgeführt, da es in der changelog steht gehe ich davon aus das webdav danach auch fix und fertig eingerichtet sein sollte?
     
  4. planet_fox

    planet_fox Super-Moderator

    Schau mal ob die module geladen sind hier

    Code:
    a2enmod dav_fs
    a2enmod dav
     
  5. Taz_Tasmania

    Taz_Tasmania New Member

    Hallo,

    jetzt habe ich mich extra angemeldet, damit ich hier eine Antwort schreiben kann.
    Ich selber habe ISPConfig am Freitag aktualisiert, damit ich die WebDAV Unterstützung nutzen kann.

    Wie bereits planet_fox geschrieben hat, sollte man prüfen, ob die Module
    dav_fs
    dav
    aktiviert sind. Sollten die Module nicht aktiviert werden, gibt es keine Fehlermeldung, da Apache den Eintrag von ISPConfig ignoriert, dank ISPConfig, sonst würde der Webserver nach einen Neustart nicht mehr funktionieren.

    Einen kleinen Fehler habe ich gefunden, der Apache kann die passwd.dav nicht lesen, da die Rechte nicht richtig gesetzt sind und die Datei nicht der Gruppe des entsprechenden Webs zugehört.
    Die Datei liegt im Verzeichnis der Webseite /var/www/webX/.
    Code:
    chgrp webX passwd.dav
    chmod 664 passwd.dav
    
    ACHTUNG: Sobald etwas in ISPConfig für das Web geändert wird, müssen die Rechte der passwd.dav wieder angepasst werden!!!

    Ich denke, dass muss man als root machen, sonst geht es nicht. Das sind im übrigen die selben Rechte und Gruppenzuweisung wie die .htpasswd, die für den Login nach Webalizer zuständig ist.

    Jetzt kann man unter http://www.meinedomain.de/webdav/ sich verbinden. Das Documenroot Verzeichnis ist aber /var/www/webX/web.

    Leider konnte ich keine Dateien anlegen, für mein iCal reicht es aber, wenn man die Datei auf dem Server anlegt und folgende Rechte vergibt.
    Code:
    cd web
    touch Kalender.ics
    chgrp webX Kalender.ics
    chmod 666 Kalender.ics
    
    Ich hoffe geholfen zu haben.

    Bis dann,
    Timo
     
  6. celocore

    celocore Member

    Hallo SandMan,

    nachdem ich meine Antwort schon gestern verfaßt hatte und die Nachricht erhielt, daß sie erst vom Admin geprüft und dann freigeschaltet wird, dies aber bisher nicht passiert ist (evtl. Fehler hier im System?!?!), versuche ich den Wortlaut nochmal zusammen zu bekommen ;)

    Nach meinen Erfahrungen beruht Dein Problem nicht auf dem Server, sondern an Deinem lokal verwendeten OS. Ich habe mehrere WebDAV-Server zu laufen, die wunderbar funktionieren, außer... unter Windows Vista! Bevor Du jetzt ewig lange an Deinem Server herumkonfigurierst, solltest Du mal versuchen mit einem anderen OS (z.B. Windows XP oder 2k) auf Deinen WebDAV-Ordner zuzugreifen.
    Windows Vista hat, auch bei Microsoft, bekannte Problem beim Zugriff auf WebDAV-Ordner. Noch schlimmer werden diese, wenn die WebDAV-Ordner via https erreichbar sind.
    Als "Workaround" empfehle ich unter Vista die Nutzung von TotalCommander mit WebDAV-Plugin. Da weiß ich wenigstens, das das klappt. Es geht aber sicher auch andere Dritt-Software. Die native Anbindung habe ich trotz vieler getester Anpassungen (auch denen aus der MS Knowledge Base) nicht hinbekommen. Der Tenor in den Foren war für mich... man kann Glück haben, daß es unter Vista geht, muß man aber nicht.

    Falls Du es doch schaffen solltest, dann wäre ich an den Systemeinstellungen interessiert :)

    P.S.: Links darf ich hier nicht posten, darum habe ich ihn Dir via PN geschickt. Ich hoffe das er da ankommt.
     
  7. planet_fox

    planet_fox Super-Moderator

Diese Seite empfehlen