webdav HTTP/1.1 405 Method Not Allowed

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Schwan, 2. Sep. 2016.

  1. Schwan

    Schwan New Member

    Hallo Zusammen
    Ich habe ein Problem mit dem webdav Zugriff auf meiner ISPConfig Version 3.0.5.4p9 unter Debian 7.11.
    Versuche etwas hochzuladen auf den webdav Server scheitern mit der Meldung "webdav HTTP/1.1 405 Method Not Allowed".
    Anbei die Logdatei vom Client

    Code:
    Probing for WebDAV support ...
    Resolving host name "www.schwan.ch" ...
    Connecting ( www.schwan.ch => ip: 80.254.71.103, port: 80 )
    Connected (80.254.71.103:80)
    <<< OPTIONS / HTTP/1.1
    <<< Host: www.schwan.ch
    <<< User-Agent: BitKinex/3.2.3
    <<< Accept: */*
    <<< Pragma: no-cache
    <<< Cache-Control: no-cache
    <<< Translate: f
    >>> HTTP/1.1 200 OK
    >>> Date: Fri, 02 Sep 2016 12:29:21 GMT
    >>> Server: Apache/2.2.22 (Debian)
    >>> Allow: GET,HEAD,POST,OPTIONS
    >>> Vary: Accept-Encoding
    >>> Content-Length: 0
    >>> Content-Type: text/html
    WebDAV not supported.
    <<< GET / HTTP/1.1
    <<< Host: www.schwan.ch
    <<< User-Agent: BitKinex/3.2.3
    <<< Accept: */*
    <<< Pragma: no-cache
    <<< Cache-Control: no-cache
    >>> HTTP/1.1 200 OK
    >>> Date: Fri, 02 Sep 2016 12:29:21 GMT
    >>> Server: Apache/2.2.22 (Debian)
    >>> Last-Modified: Thu, 13 Jun 2013 19:15:01 GMT
    >>> ETag: "12d892-745-4df0df2633740"
    >>> Accept-Ranges: bytes
    >>> Content-Length: 1861
    >>> Vary: Accept-Encoding
    >>> Content-Type: text/html
    <<< HEAD /favicon.ico HTTP/1.1
    <<< Host: www.schwan.ch
    <<< User-Agent: BitKinex/3.2.3
    <<< Accept: */*
    <<< Pragma: no-cache
    <<< Cache-Control: no-cache
    <<< Translate: f
    >>> HTTP/1.1 200 OK
    >>> Date: Fri, 02 Sep 2016 12:29:21 GMT
    >>> Server: Apache/2.2.22 (Debian)
    >>> Last-Modified: Thu, 13 Jun 2013 19:15:01 GMT
    >>> ETag: "12d893-1cbe-4df0df2633740"
    >>> Accept-Ranges: bytes
    >>> Content-Length: 7358
    >>> Content-Type: image/vnd.microsoft.icon
    FIN received
    Connection closed
    Resolving host name "www.schwan.ch" ...
    Connecting ( www.schwan.ch => ip: 80.254.71.103, port: 80 )
    Connected (80.254.71.103:80)
    <<< GET / HTTP/1.1
    <<< Host: www.schwan.ch
    <<< User-Agent: BitKinex/3.2.3
    <<< Accept: */*
    <<< Pragma: no-cache
    <<< Cache-Control: no-cache
    >>> HTTP/1.1 200 OK
    >>> Date: Fri, 02 Sep 2016 12:31:58 GMT
    >>> Server: Apache/2.2.22 (Debian)
    >>> Last-Modified: Thu, 13 Jun 2013 19:15:01 GMT
    >>> ETag: "12d892-745-4df0df2633740"
    >>> Accept-Ranges: bytes
    >>> Content-Length: 1861
    >>> Vary: Accept-Encoding
    >>> Content-Type: text/html
    <<< HEAD /favicon.ico HTTP/1.1
    <<< Host: www.schwan.ch
    <<< User-Agent: BitKinex/3.2.3
    <<< Accept: */*
    <<< Pragma: no-cache
    <<< Cache-Control: no-cache
    <<< Translate: f
    >>> HTTP/1.1 200 OK
    >>> Date: Fri, 02 Sep 2016 12:31:58 GMT
    >>> Server: Apache/2.2.22 (Debian)
    >>> Last-Modified: Thu, 13 Jun 2013 19:15:01 GMT
    >>> ETag: "12d893-1cbe-4df0df2633740"
    >>> Accept-Ranges: bytes
    >>> Content-Length: 7358
    >>> Content-Type: image/vnd.microsoft.icon
    FIN received
    Connection closed
    Resolving host name "www.schwan.ch" ...
    Connecting ( www.schwan.ch => ip: 80.254.71.103, port: 80 )
    Connected (80.254.71.103:80)
    <<< GET / HTTP/1.1
    <<< Host: www.schwan.ch
    <<< User-Agent: BitKinex/3.2.3
    <<< Accept: */*
    <<< Pragma: no-cache
    <<< Cache-Control: no-cache
    >>> HTTP/1.1 200 OK
    >>> Date: Fri, 02 Sep 2016 12:37:02 GMT
    >>> Server: Apache/2.2.22 (Debian)
    >>> Last-Modified: Thu, 13 Jun 2013 19:15:01 GMT
    >>> ETag: "12d892-745-4df0df2633740"
    >>> Accept-Ranges: bytes
    >>> Content-Length: 1861
    >>> Vary: Accept-Encoding
    >>> Content-Type: text/html
    <<< HEAD /favicon.ico HTTP/1.1
    <<< Host: www.schwan.ch
    <<< User-Agent: BitKinex/3.2.3
    <<< Accept: */*
    <<< Pragma: no-cache
    <<< Cache-Control: no-cache
    <<< Translate: f
    >>> HTTP/1.1 200 OK
    >>> Date: Fri, 02 Sep 2016 12:37:02 GMT
    >>> Server: Apache/2.2.22 (Debian)
    >>> Last-Modified: Thu, 13 Jun 2013 19:15:01 GMT
    >>> ETag: "12d893-1cbe-4df0df2633740"
    >>> Accept-Ranges: bytes
    >>> Content-Length: 7358
    >>> Content-Type: image/vnd.microsoft.icon
    <<< PUT /Fonts_OK.PNG HTTP/1.1
    <<< Host: www.schwan.ch
    <<< User-Agent: BitKinex/3.2.3
    <<< Accept: */*
    <<< Pragma: no-cache
    <<< Cache-Control: no-cache
    <<< Content-Length: 969139
    <<< Content-Type: application/octet-stream
    <<< Translate: f
    >>> HTTP/1.1 405 Method Not Allowed
    >>> Date: Fri, 02 Sep 2016 12:37:02 GMT
    >>> Server: Apache/2.2.22 (Debian)
    >>> Last-Modified: Thu, 13 Jun 2013 19:15:01 GMT
    >>> ETag: "12d88e-712-4df0df2633740"
    >>> Accept-Ranges: bytes
    >>> Content-Length: 1810
    >>> Vary: Accept-Encoding
    >>> Content-Type: text/html
    Connection closed
    Resolving host name "www.schwan.ch" ...
    Connecting ( www.schwan.ch => ip: 80.254.71.103, port: 80 )
    Connected (80.254.71.103:80)
    <<< PUT /Fonts_OK.PNG HTTP/1.1
    <<< Host: www.schwan.ch
    <<< User-Agent: BitKinex/3.2.3
    <<< Accept: */*
    <<< Pragma: no-cache
    <<< Cache-Control: no-cache
    <<< Content-Length: 969139
    <<< Content-Type: application/octet-stream
    <<< Translate: f
    >>> HTTP/1.1 405 Method Not Allowed
    >>> Date: Fri, 02 Sep 2016 12:37:02 GMT
    >>> Server: Apache/2.2.22 (Debian)
    >>> Last-Modified: Thu, 13 Jun 2013 19:15:01 GMT
    >>> ETag: "12d88e-712-4df0df2633740"
    >>> Accept-Ranges: bytes
    >>> Content-Length: 1810
    >>> Vary: Accept-Encoding
    >>> Content-Type: text/html
    Connection closed
    Warum bekommt der Client beim Einloggen ein "WebDAV not supported." zurück und woher kann der 405 kommen?

    Mit freundlichen Grüssen
    Schwan
     
  2. Schwan

    Schwan New Member

    Ich sehe dass in der .vhost Datei etwas fehlt, habe mir soeben die Config neu schreiben lassen indem ich an der Quota etwas geändert habe, aber es fehlt immer noch die Settings für WebDAV:

    Code:
                    <IfModule mod_dav_fs.c>
                    # Do not execute PHP files in webdav directory
                            <Directory /var/www/clients/client1/web1/webdav>
                                    <ifModule mod_security2.c>
                                            SecRuleRemoveById 960015
                                            SecRuleRemoveById 960032
                                    </ifModule>
                                    <FilesMatch "\.ph(p3?|tml)$">
                                            SetHandler None
                                    </FilesMatch>
                            </Directory>
                            DavLockDB /var/www/clients/client1/web1/tmp/DavLock
                            # DO NOT REMOVE THE COMMENTS!
                            # IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
          # WEBDAV BEGIN
                            # WEBDAV END
                    </IfModule>
    
    Warum wird die Anweisung für WebDAV nicht geschrieben ?
     
  3. Till

    Till Administrator

    lege mal einen neuen webdav user an, warte 1 minute und dann schau nochmal in die Datei.
     
  4. Schwan

    Schwan New Member

    okay jetzt ist da eine Config reingeschrieben worden in die Datei, und der Zugriff über WebDAV funktioniert nun :)

    Danke Till
     

Diese Seite empfehlen