Webseite des Servers abschalten

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von wiseguy, 21. Dez. 2008.

  1. wiseguy

    wiseguy New Member

    Hallo,

    ist es in ISPConfig3 möglich die Webseite des Servers abzuschalten? Das nur noch die über ISPConfig angelegten Seiten sichtbar erreichbar sind?

    Momentan ist es so, dass die standardwebseite des Servers (die, die nach der apache2 Installation "It Works" zeigt) immer angezeigt wird, wenn:
    1. direkt die Domain des Servers selbst im Browser aufgerufen wird (ich habe noch die Subdomain www. - da komme ich dann in die von ISPConfig verwaltet Seite/User/Verzeichnis... wie auch immer)
    2. eine Seite deaktiviert ist und eigentlich gar nicht erreichbar sein soll
    Ich nehme mal an, man kann das auch direkt in der /etc/apache2/apache2.conf entsprechend ändern bzw. eben nicht einstellen. Aber erstens hab ich den nötigen Eintrag nicht gefunden und zweitens bin ich mir unsicher inwiefern ISPConfig damit evtl. ein Problem bekommen kann.
     
  2. wiseguy

    wiseguy New Member

    Sorry;
    1. gehört der Post eher nach Allgemein und
    2. hab ich jetzt auch gefunden, wie man das macht: Den symlink 000-default/etc/apache2/sites-enabled/ entfernen. Das sollte das ISPConfig nicht stören
     
  3. wiseguy

    wiseguy New Member

    Was aber trotzdem nicht klappt, ist eine deaktivierte Site. Hab eine Domain angelegt, die ich aber einstweilen deaktivieren will: Sie soll dann auch überhaupt nicht erreichbar sein - auch nicht auf die standardwebseite des Servers zeigen.
    Momentan (symlink /etc/apache2/sites-enabled/000-default hab ich ja gelöscht) zeigt sie auf die seite /var/clients/client1/web1/web. (Das ist der Ort, worauf die Site zeigt, die den Namen des Servers selbst trägt - also die Server eigene Domain hatte ich als erstes im ISPConfig eingerichtet)
     
  4. Till

    Till Administrator

    Wenn DU eine Webseite deaktivierts wird der Symlink auf dem Vhost in sites-enabled gelöscht, die Seite ist somit nicht mehr erreichbar. In /var/clients/client1/web1/web darf natürlich nichts gelöscht oder geändert werden, sonst wären die Web Daten weg!Wenn Du /etc/apache2/sites-enabled/000-default löschst dann bedeutet dass, dass es keine standardwebsite mehr gibt und in diesem Fall wird die erste Webseite des Servers angezeigt, wenn nichts anderes definiert ist. Du musst Dir also eine eigene Standardwebseite anlegen, wenn Du /etc/apache2/sites-enabled/000-default deaktivierst.
     
  5. Till

    Till Administrator

    Hier ein kleines Update. Das Problem behebst Du am einfachsten wie Folgt:

    1) Den Symlink /etc/apache2/sites-enabled/000-default wieder erstellen

    2) Dann die Datei editieren und die Zeilen:

    NameVirtualHost *
    <VirtualHost *>

    ändern in:

    NameVirtualHost *:80
    <VirtualHost *:80>
     
  6. wiseguy

    wiseguy New Member

    Damit hab ich jetzt aber nicht folgendes Problem beheben können:
    • Der Server selbst heißt beispielsweise server1.de
    • Im ISPConfig hab ich nun unter anderem auch eine Site server1.de, die zum Client0 gehört und auf web1 zeigt, angelegt
    • Auf diese soll auch verwiesen werden, wenn man im Browser http://server1.de eingibt.
    Momentan ist es aber so:
    • Gebe ich im Browser http://server1.de ein, gelange ich auf die standard apache Seite mit dem Inhalt "It works".
    • Gebe ich hingegen z.B. http://www.server1.de ein, gelange ich wie gewünscht auf die im ISPConfig angelegte Site (/var/clients/client0/web1/web)
     
  7. Till

    Till Administrator

    Das hat aber damit überhaupt nichts zu tun. Du hast nur die Domain www.server1.de in ISPConfig angelegt und nicht server1.de + subdomain www.server1.de. Du musst die Domains schon anlegen damit sie auf das richtige Web zeigen, der apache kann das ja nicht selber wissen, welche Domain auf welches Web zeigen soll.
     

Diese Seite empfehlen