Webseite https auf http

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von kangoo, 10. Feb. 2011.

  1. kangoo

    kangoo New Member

    Hallo,

    ich hatte ein SSL Problem mit StartSSL. Nun habe ich ein selbst signiertes Zertifikat gemacht und die Webseite ist über https erreichbar. Da das aber natürlich nicht schön ist, wenn da immer nicht vertrauenswürdig kommt, möchte ich auf http zurück stellen. Wenn ich nun aber im Kontrollpanel das Zertifikat lösche und dann SSL deaktiviere, dann ist die Seite nicht mehr erreichbar. Weder mit http noch mit https, wobei letzteres ja eigentlich klar ist. Aber warum geht da http nicht mehr. Es scheint so als ob der dienst nicht laufen würde. Aber wenn ich Apache neu starte scheint alles korrekt zu sein.
    Ach ja, ich hatte noch ein Rewrite im Kontrollpanel eingerichtet, http auf https, aber das habe ich eigentlich gelöscht.

    LG

    Kangoo
     
    Zuletzt bearbeitet: 11. Feb. 2011
  2. Till

    Till Administrator

    Zum deaktivieren von SSL in einer webseite bitte nur den Haken bei SSL in den Web-Einstellungen raus nehmen.
     
  3. kangoo

    kangoo New Member

    Hallo,

    wenn ich die Rewrite Rule herausnehme und dann bei SSL den Haken wegnehme kann ich auf die Seite nicht mehr zugreifen. Im Firefox bekomme ich diese Fehlermeldung
    Wenn ich dann SSL wieder aktiviere und die Rule wieder reinschreibe komme ich wieder auf die Seite.

    LG

    Kangoo
     
  4. Till

    Till Administrator

    Laut dem Fehlercode greifst Du weiterhin über ssl zu, was natürlich nicht geht wenn ssl deaktiviert ist. Du kannst nur über http und nicht https auf die Seite zugreifen, wenn ssl deaktiviert ist.
     
  5. kangoo

    kangoo New Member

    Ja, nur im Browser gebe ich http ein. Warum leitet es mich dann auf https weiter obwohl ich die Rewrite Rule entfernt habe und SSL deaktiviert habe?

    LG

    Kangoo
     
  6. Till

    Till Administrator

    Schau nochmal in den vhost, da muss ja noch irgend was zur Umleitung auf https drin stehen.

    Oder hast Du irgen ein cms oder blog system in der website? Dann kann es sein dass das cms die Umleitung macht. das ist z.B. bei wordpress der Fall.
     
  7. kangoo

    kangoo New Member

    Hallo,

    hier die vhost Datei;

    Im Panel ist SSL deaktiviert und Rewrite Rule herausgenommen. Kein Zugriff auf die Webseite. Wieder der SSL Fehler. Es gibt dann noch eine vhost datei mit einer ~ am Ende.

    LG
    Kangoo
     
  8. Till

    Till Administrator

    Der vhost ist ok. Dann liegt es an einer der anderen Sachen, die ich oben gepostet habe.
     
  9. kangoo

    kangoo New Member

    Hallo,

    ich habe in der Zwischenzeit ein 30 Tage Testzertifikat von RapidSSL ausgestellt und damit klappt alles wieder. Wie ist das aber wenn ich nun ein "richtiges" SSL Zertifikat von RapidSSL will. Kann ich da einfach den bestehenden SSL Request verwenden und dann das neue Zertifikat in die Verwaltungskonsole kopieren? Also dann einfach auf speichern. Oder muss ich einen komplett neuen Request machen und warten bis das neue Zertifikat ausgestellt ist.

    LG
    Kangoo
     
  10. Till

    Till Administrator

    Ja, genau so geht das.
     

Diese Seite empfehlen