Webseite nur über www erreichbar

Dieses Thema im Forum "Tipps - Tricks - Mods" wurde erstellt von Rolli-Ronny, 30. Dez. 2010.

  1. Rolli-Ronny

    Rolli-Ronny New Member

    Gerade habe ich gesehen das meine Webseite nur über www erreichbar ist aber ohne www nicht.Woran könnte das liegen und wie repariere ich das?
     
  2. Moestchen

    Moestchen New Member

    Wie sehen denn deine DNS-Einträge für die Domaine aus?
    Im Normalfall sollte es ungefähr so aussehen:
    Code:
    @                        IN A       DEINEIP
    www                      IN A       DEINEIP
    Wenn deine Domain nicht ohne www aufrufbar ist, klingt es so als
    würde der A-Record für @ wo anders hinzeigen!?
    Mache doch mal eine
    Code:
    nslookup DEINEDOMAIN.DE
    und
    Code:
    nslookup www.DEINEDOMAIN.DE
    und kontrolliere welche IPs zurück gegeben werden.


    Viele Grüße
    Moestchen

    EDIT: Und wie hast du deine Domain in ISPConfig angelegt (mit www oder ohne)?
    Diese musst du ohne www, also nur 'DEINEDOMAIN.DE' anlegen und dann 'www' als Auto-Subdomain auswählen.
     
    Zuletzt bearbeitet: 30. Dez. 2010
  3. Rolli-Ronny

    Rolli-Ronny New Member

    Das Ergebniss ist

    Ich lege die Domain ohne www. und Auto-Subdomain stelle ich auf www. ein.Den DNS Eintrag knn ja nur der Hoster des vServers ändern.
     
  4. Moestchen

    Moestchen New Member

    Hm, ich gehe davon aus, das trotz der ausge-x-ten IPs diese übereinstimmen.
    Und anlegen tust du die Domain ja auch richtig in ISPConfig.

    Da fällt mir auf Anhieb keine weitere Fehlerquelle ein.
    Steht denn was im Log des VHOST?

    Viele Grüße
    Moestchen
     
  5. Moestchen

    Moestchen New Member

    Bei welchem Hoster bist du denn?
    In aller Regel kannst du dir doch, auch bei vServen, über die beinhaltete Verwaltungsoberfläche (Plesk ?) die DNS-Einträge deiner Domain verwalten
    und u.a. Subdomains oder den rDNS anlegen?
     
  6. Rolli-Ronny

    Rolli-Ronny New Member

    Doe LOG Dateien geben nichts her da habe ich als erstes geschaut ob Fehlermeldungen etc drin stehen.Mal sehen ob noch jemand eine Idee hat ansonsten frage ich mal beim Hoster nach ob dieser eine gescheite Idee dazu hat.
     
  7. Moestchen

    Moestchen New Member

    Naja. sofern DEINEDOMAIN.DE und WWW.DEINEDOMAIN.DE auf die gleiche IP zeigen, ist es kein Problem des Hosters. Dann liegt es am Apache bzw. die Konfiguration des VHOST.

    Hast du auf deinem VHOST mehrere IPs zu laufen?
    Hast du noch andere Domains gehostet - wie sieht es da aus mit der Funktionsweise? Hast du evtl. eine .htaccess im Web-Root zu liegen?
    Poste doch mal die Konfiguration deines entsprechenden VHOSTS.

    Viele Grüße
    Moestchen
     
  8. Rolli-Ronny

    Rolli-Ronny New Member

    Wenn ic die Domain ohne www aufrufe wird die index.html aufgerufen welche in /var/www liegt,aufgerufen werden soll aber die im /var/www/clients/client1/web1/web liegt.Jetzt muss ich mal schauen wo ich das gerade biegen kann.Könnte es ein Konfigfehler von ISPconfig sein?
     
  9. Moestchen

    Moestchen New Member

    Ist bei dir zufällig noch die default-VHOST vom Apachen aktiv?
    Was für ein OS nutzt du?

    Poste mal bitte die Ausgabe von 'apache2ctl -S' und schaue ob im
    Verzeichnis von '/etc/apache/sites-enabled' noch eine VHOST-Konfiguration namens '000-default' vorhanden ist; klingt ziemlich danach.
    Was für Content wird denn angezeigt, wenn du deine Domain ohne www aufrust: "It's works"?

    Viele Grüße
    Moestchen
     
  10. Rolli-Ronny

    Rolli-Ronny New Member

    Wenn ich die Domain ohne www aufrufe wird mir "It Works"angezeigt.In /etc/apache2/sites-enabled sind folgende Dateien enthalten

    Die Domains sind ein und die selbe nur die Endung ist anders.Als System läuft Debian Lenny und ISPconfig mit diverser anderer Software.
     
  11. Moestchen

    Moestchen New Member

    Jup, habe ich es mir gedacht.
    Führe ein 'a2dissite 000-default' aus (zum deaktivieren des Standard-Apache - VHOST) und starte den Apache neu ( /etc/init.d/apache2 restart ).
    Dann freu dich das es funktioniert. ;)


    Viele Grüße
    Moestchen
     
  12. Till

    Till Administrator

    Dann wurde wahrscheinlich die Webseite der Domain nicht richtig angelegt. Kontrollier die Webseiten einstellungen, dort mus "domain.de" und nicht "www.domain.de" im Domain Feld stehen und beu Auto-subdomain muss "www" ausgewählt sein.

    Das deaktivieren des Default vhost würde ich Dir nicht empfehlen, damit deaktivierts Du auch gleich webmail und phpmyadmin und es behebt den Fehler auch nicht sondern leitet die Anfragen einfach auf den ersten vhost in alphabetischer Reihenfolge um, was nicht unbedingt der richtige sein muss.
     
  13. Moestchen

    Moestchen New Member

    Das schrieb er hat er getan, also habe ich mich darauf verlassen.

    Also bei mir funktioniert es einwandfrei und ohne jegliche Probleme.
    Habe bei mir den Standard-VHOST (000-default) vom Apachen von anfang an deaktiviert und dann ISPc3 installiert - verlief alles ohne Probleme.
    Das damit phpmyadmin deaktiviert wird stimmt so nicht. Ich habe mich bei der Installation an http://wiki.nixhelp.de/howto/ispconfig3-megainstall gehalten und dort wird entsprechend der Symlink angelegt.
    Und webmail habe ich (entsprechend einiger Beiträge hier im Forum) wie hier http://www.howtoforge.de/forum/showpost.php?p=21237&postcount=2 geschildert eingebunden.

    Und ich kann nur nochmals sagen, alles läuft ohne Probleme.


    Viele Grüße
    Moestchen
     
  14. Rolli-Ronny

    Rolli-Ronny New Member

    @ Moestchen die Dateien qwelche ich aufgelistet habe sind alles Symlinks!Habe die selbe Anleitung genommen wie du.

    @Till das habe ich ja schon geschrieben das ich die Domains ohne www anlege und Auto-subdomain auf www. Und deaktivieren tue ich nicht zumal ich noch einige Programme zusätzlich eingetragen habe.


    Kopfkratz wo liegt jetzt der Fehler?:confused:
     
  15. Moestchen

    Moestchen New Member

    Ich weiß, der VHOST 000-default verweist auf /etc/apache2/sites-available/default und die anderen dementsprechend auch auf die jeweilige Konfiguration.

    Das ist ja der geniale Vorteil - durch 'a2dissite 000-default' kannst du gar nichts kaputt machen, denn intern wird lediglich der Symlink gelöscht.
    Sollte es dann nicht funktionieren bzw. deine anderen Programme nicht mehr laufen, dann aktivierst du den VHOST einfach wieder per 'a2ensite default' und restartest den Apache. Dann hast du den Ursprungszustand wieder. Versuchs einfach aus - bei mir läuft es ohne Probleme.

    Viele Grüße
    Moestchen

    PS: Hast du deine zusätzlichen Programme denn im default-VHOST angelegt? Dann erstelle hierfür ggfs. eigene Konfigurationsdateien.
     
  16. Rolli-Ronny

    Rolli-Ronny New Member

    Die lösung mag zwar funktionieren ist aber nicht das Gelbe vom Ei.Am liebsten ist mir eine Lösung wo eben diese Datei erhalten bleibt.Ich werde mal den Ersteller der Mega Installation dazu befragen.
     
  17. Rolli-Ronny

    Rolli-Ronny New Member

    Übrigens da selbe kommt auch wenn ich nur die IP eingebe It Works
     
  18. Moestchen

    Moestchen New Member

    Sie mag dir nicht logisch erscheinen, ist sie aber. Denn in der 000-default wird der DocumentRoot auf /var/www gelegt. Deswegen wird dir "It Works" angezeigt. Deine Subdomain wird aber durch ISPc3 verwaltet und hier wird der DocumentRoot korrekterweise auf dein Web-Verzeichnis gesetzt.

    EDIT:
    Dann schaue dir doch mal an, was im default-VHOST steht und was für Content du unter /var/www hostest. Doch im Normalfall gar nichts, denn dafür setzt du ja ISPc3 ein. Und dieses ersetllt dir für jede Domain den VHOST und legt den DocumentRoot an.
    Der default-VHOST wird also nicht gebraucht und phpmyadmin / webmail funktioniert wie oben beschrieben bzw. in der megainstall-Anleitung geschildert.

    EDIT2:
    Glaube mir, ich arbeite siet über 10 Jahren mit dem Indianer (Apache) und habe noch nie den default-VHOST verwendet. Das ist das erste, was ich nach einer Installation von Apache deaktiviere und mir dann meine eigenen VHOST erstellt habe.
     
    Zuletzt bearbeitet: 30. Dez. 2010
  19. Moestchen

    Moestchen New Member

    Das ist korrekt und richtig so. Denn in deiner Konfiguurationsdatei für deine Domain ist der Servername und für die Subdomain der Serveralias angegeben.
    Solltest du - angenommenerweise alle Domains in einer Config verwalten - würde der Apache nun von oben anfangen und bei jedem VHOST den aufgerufenen Domainnamen im Browser mit dem Servername im VHOST vergleichen und wenn diese übereinstimmen, die entsprechende Seite ausliefern.
    Bei Eingabe der IP stimmt der Severname ja nicht überein, also übernimmt der default-VHOST wieder, denn der nimmt für alle IPs an und liefert die Seite in /var/www aus - also "It Works".
     
  20. Moestchen

    Moestchen New Member

    Einen schönen guten Morgen,
    was mir noch einfällt ist, um sicher zu gehen das ISPc3 den VHOST korrekt angelegt hat, kontrolliere doch bitte mal deine Konfigurationsdatei für die Domain.
    Code:
    /etc/apache2/sites-enabled/DEINEDOMAIN.DE.vhost
    Ist dort als
    Code:
    ServerName = DEINEDOMAIN.DE
    und als
    Code:
    ServerAlias = www.DEINEDOMAIN.DE
    eingetragen?
    Wenn ja, ist diese durch ISPc3 korrekt angelegt und es liegt wirklich am default-VHOST. Und wie gesagt, es gibt wirklich keine Probleme damit.


    Viele Grüße
     

Diese Seite empfehlen