Webseiten via PHP-FPM funktionieren nicht

#1
Hallo zusammen,

ich verwende die ISPConfig Version 3.0.5.4p1
Alles funktioniert soweit wunderbar und ich bin sehr zufrieden.

Nun wollte ich bei eine Webseite mit PHP-FPM betreiben.
Leider wird mir beim Aufrufen der Seite nur der Quellcode angezeigt.

Folgendes habe ich bisher versucht.
PHP-FPM ist auf jedenfall installiert und läuft:
# php5-fpm -v
PHP 5.4.4-14+deb7u11 (fpm-fcgi) (built: Jun 13 2014 13:54:51)
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2012 Zend Technologies

# /etc/init.d/php5-fpm status
[ ok ] php5-fpm is running.

Die Pfade in ISPConfig stimmen auch.
Folgende Linux Version wird verwendet
Linux 3.2.0-4-amd64 #1 SMP Debian 3.2.57-3+deb7u2 x86_64 GNU/Linux

Ich habe unter Optionen bereits verschiedene Möglichkeiten durchprobiert
- Benutze Socket für PHP-FPM: An/Aus
- PHP-FPM FastCGI Prozess Manager: dynamisch, statisch und ondemand

Wenn ich die Option "Benutze Socket für PHP-FPM" ausschalte, sieht die "webx.conf" folgendermaßen aus:

Code:
[web7]

listen = 127.0.0.1:9016
listen.allowed_clients = 127.0.0.1

user = web7
group = client1

pm = dynamic
pm.max_children = 10
pm.start_servers = 2
pm.min_spare_servers = 1
pm.max_spare_servers = 5
pm.max_requests = 0

chdir = /

php_admin_value[open_basedir] = /var/www/clients/client1/web7/web:/var/www/clients/client1/web7/private:/var/www/clients/client1/web7/tmp:/var/www/test.testdomain.de/web:/srv/www/test.testdomain.de/web:/usr/share/php5:/usr/share/php$
php_admin_value[session.save_path] = /var/www/clients/client1/web7/tmp
php_admin_value[upload_tmp_dir] = /var/www/clients/client1/web7/tmp
php_admin_value[sendmail_path] = "/usr/sbin/sendmail -t -i -fwebmaster@test.testdomain.de"
ein netstat -4tnl | grep ":9016 .* LISTEN" liefert folgendes:
tcp 0 0 127.0.0.1:9016 0.0.0.0:* LISTEN

Leider bin ich so langsam mit meinen Ideen am Ende,
vielleicht weiß noch jemand von euch Rat.
 
#3
Hallo nachfolgend die .vhost Datei
Code:
<Directory /var/www/test.testdomain.de>
		AllowOverride None
				Order Deny,Allow
		Deny from all
		</Directory>

<VirtualHost *:80>
					DocumentRoot /var/www/clients/client1/web7/web
			
		ServerName test.testdomain.de
		ServerAdmin webmaster@test.testdomain.de

		ErrorLog /var/log/ispconfig/httpd/test.testdomain.de/error.log

		Alias /error/ "/var/www/test.testdomain.de/web/error/"
		ErrorDocument 400 /error/400.html
		ErrorDocument 401 /error/401.html
		ErrorDocument 403 /error/403.html
		ErrorDocument 404 /error/404.html
		ErrorDocument 405 /error/405.html
		ErrorDocument 500 /error/500.html
		ErrorDocument 502 /error/502.html
		ErrorDocument 503 /error/503.html

		<IfModule mod_ssl.c>
		</IfModule>

		<Directory /var/www/test.testdomain.de/web>
				Options +FollowSymLinks
				AllowOverride All
								Order allow,deny
				Allow from all
						</Directory>
		<Directory /var/www/clients/client1/web7/web>
				Options +FollowSymLinks
				AllowOverride All
								Order allow,deny
				Allow from all
						</Directory>




		# cgi enabled
	<Directory /var/www/clients/client1/web7/cgi-bin>
						Order allow,deny
			Allow from all
					</Directory>
		ScriptAlias  /cgi-bin/ /var/www/clients/client1/web7/cgi-bin/
		<FilesMatch "\.(cgi|pl)$">
			SetHandler cgi-script
		</FilesMatch>
		# suexec enabled
		<IfModule mod_suexec.c>
			SuexecUserGroup web7 client1
		</IfModule>
		# Clear PHP settings of this website
		<FilesMatch ".+\.ph(p[345]?|t|tml)$">
				SetHandler None
		</FilesMatch>
		<IfModule mod_fastcgi.c>
				<Directory /var/www/clients/client1/web7/cgi-bin>
										Order allow,deny
					Allow from all
								    </Directory>
				<FilesMatch "\.php[345]?$">
					SetHandler php5-fcgi
				</FilesMatch>
                Action php5-fcgi /php5-fcgi
				Alias /php5-fcgi /var/www/clients/client1/web7/cgi-bin/php5-fcgi-*-80-test.testdomain.de
                FastCgiExternalServer /var/www/clients/client1/web7/cgi-bin/php5-fcgi-*-80-test.testdomain.de -idle-timeout 300 -host 127.0.0.1:9016 -pass-header Authorization
		</IfModule>


		# add support for apache mpm_itk
		<IfModule mpm_itk_module>
			AssignUserId web7 client1
		</IfModule>

		<IfModule mod_dav_fs.c>
		# Do not execute PHP files in webdav directory
			<Directory /var/www/clients/client1/web7/webdav>
				<ifModule mod_security2.c>
					SecRuleRemoveById 960015
					SecRuleRemoveById 960032
				</ifModule>
				<FilesMatch "\.ph(p3?|tml)$">
					SetHandler None
				</FilesMatch>
			</Directory>
			DavLockDB /var/www/clients/client1/web7/tmp/DavLock
			# DO NOT REMOVE THE COMMENTS!
			# IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
      # WEBDAV BEGIN
			# WEBDAV END
		</IfModule>


</VirtualHost>
 

Till

Administrator
#4
Schau mal nach ob Du auch das apache modul mod_fastcgi installiert hast, das ist nicht mod_fcgid, auch wenn es ähnlich klingt.
 
#5
Hallo,

vielen Dank für den Hinweis.
War nicht installiert, habe das Paket "libapache2-mod-fastcgi" aus den non-free Quellen installiert.

Hat leider keine Änderung gebracht, nach wie vor wird nur der Quellcode angezeigt.
 

Werbung