WebServer in VBox und Webseiten in der hosts von Windows umrouten wie macht man das?

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von M. Zink, 16. Okt. 2009.

  1. M. Zink

    M. Zink New Member

    Ich habe nach dem Howto einen Debian Webserver mit ISPC3 aufgesetzt. In ISPC3 habe ich eine Site angelegt und einen FTP Nutzer und eine Datenbank und natürlich einen Client. Mit dem FTP kann ich mich verbinden und die Dateien ins Web Verzeichnis schieben. Mit PHPMyAdmin kann ich die Datenbank füllen aber wenn ich in meiner hosts von Windows die lokale IP vom Server angebe und die Domäne dahin umroute (eine Subdomäne) komme ich egal was ich mache nicht da raus bzw. ich bekomme immer ein 403 Forbidden. Habe ich einen Denkfehler in meiner Konfiguration oder geht das auf diese Art gar nicht so einfach?
     
  2. Burge

    Burge Member

    es sind namensbasierende vhost in ispconfig
    Also kannst mit der ip nix auflösen.

    Leite die Seite auf die Ip weiter des vhost das ist ok.
    Erstelle in deiner host datei im windows ein eintrag da dann lautet. sub.domain.tld - ip deiner vbox

    So fern du dann das ispconfig richtig eingerichtet hast sollte es gehen.
     
  3. M. Zink

    M. Zink New Member

    Normal geb ich nicht gerne Domänennamen bekannt aber in dem Fall ist es mal egal. Folgendermaßen habe ich das konfiguriert.

    hosts in Windows enthält den Eintrag

    dev.cmb-pav.de 192.168.178.205

    Und das ist auch die IP vom Server.

    ISPC auf dem Server hab ich so eingerichtet, dass alle Subdomains entgegen genommen werden sollten also *.cmb-pav.de und wie gesagt per FTP komme ich drauf und PHPMyAdmin geht ebenfalls. Rufe ich nun aber diese Subdomain auf dann sehe ich nur "It Works" also sprich die Standard index.html die der Apache unter /var/www/ ablegt. Unter /etc/apache2/sites-aviable/ gibts die vhost dabei und da steht auch alles korrekt drin. Kann es sein das der Server nicht so ganz so einwandfrei arbeitet weil er so gesehen in unserem Netzwerk hier nur Client ist? Ne feste IP hat er schon aber er ist ja trotzdem netzwerkintern unterwegs und DNS und DHCP ist unser großer Windowsserver. Wobei ich ja durch die hosts in Windows den virtuellen Server direkt per IP anspreche.

    Noch jemand nen Vorschlag oder weiß was falsch läuft?
     
  4. Till

    Till Administrator

    Stell bitte sicher dass Du in den Einstellungen der Webseite die IP 192.168.178.205 ausgewählt hast und nicht *
     
  5. M. Zink

    M. Zink New Member

    Ich hab unter System glaube ich war es die IP in ISPC eingetragen und auch bei der Seite ausgewählt. Aber auch das ändert nichts. Es ist fast so als würde der Webserver warum auch immer die Anfrage einfach nur auf seine IP erkennen aber nicht mit bekommen, dass eine Domain aufgerufen wurde. Denn auch eine zweite Seite die ich einfach zum test eingerichtet habe landet auf der IT WORKS von Apache. Im VHost Eintrag steht aber der richtige Doc Root drin und auch die IP und das alles. Ist mir schleierhaft wie das sein kann.
     

Diese Seite empfehlen