Webserver kann nicht mehr gestartet werden

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Falloutboy6, 10. März 2011.

  1. Falloutboy6

    Falloutboy6 Member

    Hi,

    ich kann meinen Apache2 nicht mehr neu starten. Will ich neu starten erhalte ich die Meldung

    Warum ist das auf einmal nicht mehr erlaubt? Wer kann mir helfen?

    Und lösche ich die Zeile mal raus und starte neu erhalte ich


    Ispconfig Version: 2.2.36
    Debian

    Danke
     
    Zuletzt bearbeitet: 10. März 2011
  2. Till

    Till Administrator

    Was hast Du denn gemacht, bevor die Probleme auftraten und was steht im apache error.log?
     
  3. Falloutboy6

    Falloutboy6 Member

    Ich habe dann in den Logfiles gesehen, dass von manchen Webs die Error-Logs nicht geschrieben werden konnten. Dann hab ich dir Ordner erstellt und dann gings wieder. Jetzt auf einmal habe ich das Problem wieder, dass die Seiten nicht geladen werden können.
    Ispconfig funktioniert wunderbar und auch schnell. Sprich es muss wohl irgendwas mit dem Webserver sein richtig?

    Ich erhalte folgende Meldung:

    Danke für eure Hilfe.

    Gruß
    Benny
     
  4. Till

    Till Administrator

    Ich denke da gibt es 2 Möglichkeiten, entweder ein anderes programm läuft auf port 80 oder aber ein zombie Prozess des apache läuft dort und kann nicht vom normalen restart gekillt werden. Poste mal die Ausgabe von:

    netstat -tap

    und

    ps aux | grep apache
     
  5. Falloutboy6

    Falloutboy6 Member

    Irgendwie scheint was gewaltig kaputt zu sein bei mir. Nun kann ich keine Mails mehr verschicken, die Seiten laufen alle sehr sehr langsam. Will ich einen Apache Neustart machen erhalte ich

     
  6. Till

    Till Administrator

    Hast Du mal den ganzen Server neu gestartet? Und auch mal das system mit rkhunter, top, netstat etc. gecheckt?
     
  7. Falloutboy6

    Falloutboy6 Member

    Ja Neustart habe ich durchgeführt.

    top:
    netstat:
    Code:
    tcp        0      0 servername:ssh 70.88.142.203:63570     SYN_RECV
    tcp        0      0 servername:pop3 pd95c12d9.dip0.t-:24144 TIME_WAIT
    tcp        0      0 servername:imap2 80.187.106.164:32268    VERBUNDEN
    tcp        0      0 servername:imap2 80.187.106.164:62827    VERBUNDEN
    tcp        0      0 servername:pop3 pd95c12d9.dip0.t-:24151 TIME_WAIT
    tcp        0      0 servername:imap2 84.151.212.107:49199    VERBUNDEN
    tcp        0      0 servername:www 217.226.38.141:34060    TIME_WAIT
    tcp        0      0 servername:imap2 84.151.212.107:49200    VERBUNDEN
    tcp        0      0 servername:imap2 80.187.106.164:43213    VERBUNDEN
    tcp        0      0 servername:www 217.226.38.141:34063    TIME_WAIT
    tcp        0      0 servername:imap2 80.187.106.164:43213    VERBUNDEN
    tcp        1      0 servername:smtp pd95c12d9.dip0.t-:34374 CLOSE_WAIT
    tcp        0      0 servername:imap2 80.187.106.164:39557    VERBUNDEN
    tcp        0      0 servername:imap2 80.187.106.164:57424    VERBUNDEN
    tcp        0      0 servername:pop3 pd95c12d9.dip0.t-:24167 TIME_WAIT
    tcp        0      0 servername:pop3 pd95c12d9.dip0.t-:24169 TIME_WAIT
    tcp        0      0 servername:imap2 80.187.106.164:53262    VERBUNDEN
    tcp        0      0 servername:imap2 84.151.212.107:49197    VERBUNDEN
    tcp        0      0 servername:pop3 pd95c12d9.dip0.t-:24163 TIME_WAIT
    tcp        0      0 servername:imap2 80.187.106.164:56538    VERBUNDEN
    tcp        0      0 servername:imap2 80.187.106.164:36638    VERBUNDEN
    tcp        0      0 servername:pop3 pd95c12d9.dip0.t-:24164 TIME_WAIT
    tcp        0      0 servername:pop3 pd95c12d9.dip0.t-:24161 TIME_WAIT
    tcp        0      0 servername:imap2 84.151.212.107:49534    VERBUNDEN
    tcp        0      0 servername:imap2 84.151.212.107:49208    VERBUNDEN
    tcp        0      0 servername:pop3 pd95c12d9.dip0.t-:24160 TIME_WAIT
    tcp        0      0 servername:pop3 pd95c12d9.dip0.t-:24162 TIME_WAIT
    tcp        0      0 servername:imap2 80.187.106.164:52437    VERBUNDEN
    
     
  8. Till

    Till Administrator

    LKässt Du gerade backups erstellen, oder was sind das für tar Prozesse. Des weiteren ist die Frage, ob Du perl cgi scripte nutzt, oder stammt das vom hack einer website?

    Zum netstat, das scheint nur ein Teil der Ausgabe zu sein, der Anfang fehlt.
     
  9. Falloutboy6

    Falloutboy6 Member

    hm es scheint so, dass sich das BackupScript mal wieder aufgehängt hat ;-(

    Ich verwende ReoBack. Aber es scheint mit der Datenmenge nicht mehr zurecht zu kommen.

     
  10. Till

    Till Administrator

    Na dann haben wir das problem ja gefunden :)
     
  11. Falloutboy6

    Falloutboy6 Member

    sieht so aus. Dann hoffe ich mal, dass das nicht wieder vorkommt. Danke dir.
    Jetzt habe ich noch ein Problem, dass die Statistik (awstats) nicht mehr generiert wird. Cronjob ist vorhanden. Auch wenn ich die Generierung manuell anstoße wird nichts neues generiert. Wie könnte ich da rausfinden was da los ist?
    Ich hab natürlich jetzt auch das Problem, dass ich die Statistik noch für ein paar Tage nachgenerieren müsste. Der letzte Stand ist vom 13.03.

    Danke.
     
  12. Till

    Till Administrator

    Ich wüsste jetzt auf Anhieb nicht was dort bei awstats kaputt gegangen sein könnte. Vermutlich fehlen einfach die Einträge im logfile, da die Platte ja voll war.
     
  13. Falloutboy6

    Falloutboy6 Member

    Hi,

    ich kämpfe immer noch mit awstats. Awstats generiert einfach nichts mehr. Weder eine Config-Datei wenn ich ein Web neu anlege noch die Statistik.
    Habs auch schon neu installiert aber es bringts einfach nicht. Wie könnte ich rausfinden wo das Problem liegt.

    Danke an alle für eure Hilfen und Tipps.

    Gruß
    Benny
     
  14. Till

    Till Administrator

    Werden Fehler ausgegeben wenn Du folgenden Befehl ausführst?:

    /usr/local/ispconfig/server/cron_daily.sh
     
  15. Falloutboy6

    Falloutboy6 Member

    diesen Pfad gibt es bei mir nicht.
     
  16. Till

    Till Administrator

    Ok. Hab gerade gesehen dass Du ja noch ispconfig 2 verwendest. Der obige Pfad ist für ipconfig 3.

    Welce Awstats Implementierung nimmst Du denn? Die von ispconfig oder hast Du irgend wann mal ein Addon dafür installiert?
     
  17. Falloutboy6

    Falloutboy6 Member

  18. Till

    Till Administrator

    Ok. Ich vermute mal das dieses Plugin mit der in ISPConfig 2 seit einiger zeit integrierten eigenen awstats Funktion kollidiert. Da ich dieses externe Plugin noch nie verwendet habe, kann ich Dir baer auch nicht genau sagen was es sein kann.

    Hast Du denn in den Webseiteneinstellungen awstats als Statistiksoftware für das web eingestellt?
     

Diese Seite empfehlen