Webserver mit Php5, eAccelerator

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von KamiKatze88, 4. März 2009.

  1. KamiKatze88

    KamiKatze88 New Member

    hallo, ich habe mir nen Apache2 aufgesetzt(In Suse Linux 11.0), mit Php5 und brauche noch die Erweiterung eAccelerator. Besorgt hab ich sie mir schon, installiert auch. Wenn ich phpinfo starte, wird auch der eAccelerator angezeigt als erweiterung, funktioniert aber nicht, hab gegoogelt und dann rausgefunden das ich in die php.ini die Extension mitreinschreiben muss, wegen Cache etc, so habe ich getan (Apache jedes mal neugestartet) geht nicht, dann ist mir aufgefallen das die Config die ich geändert habe nicht geladen wird, ich kann die parameter verändern wie ich will in der php.ini in phpinfo bleiben die gleich, der pfad stimmt überigens, ist dersselbe der in der phpinfo bei : Loaded Config File drinsteht, nur woher kommen den die Standardwerte wenn vor meinem Eintrag nichts von eAccelerator in der php.ini stand?

    Weiß jemand wie ich das ding zum laufen bekomme?
     
  2. Till

    Till Administrator

    Vermutlich hast Du die falsche php.ini editiert. schau mal im phpinfo output nach, welche php.ini dort verwendet wird und ändere dann diese.
     
  3. KamiKatze88

    KamiKatze88 New Member

    hab ich gehofft,leider ist es exakt der selbe Pfad! =(
     
  4. Till

    Till Administrator

    Hast Du auch den apache webserver nach den Änderungen neu gestartet?
     
  5. KamiKatze88

    KamiKatze88 New Member

    ja klar, steht auch oben in meinem Post, habe mittlerweile wo gelesen das sich der eAccelerator in der Version 0.9.5 nicht mit PHP verträgt...möglich?
     
  6. Till

    Till Administrator

    eaccelerator ist ein php plugin, dass es sich nicht mit php verträgt ist also ausgeschlossen. Es kann ebr immer sein dass sich eine bestimmte Version von eaccelerator mit einer bestimmten php Version nicht verträgt. das ist aber auch sehr unwahrscheinlich und ich habe es in den letzten jahren nicht erlebt.
     
  7. KamiKatze88

    KamiKatze88 New Member

    hab da was falsch verstanden, also es ist so das game ist mit 0.9.3 codiert worden, also brauche ich auch 0.9.3 , aber die lässt sich nicht kompilieren.

    folgende fehler kommen immer:
    z.b: eaccelerator.c:1640:error:'align_test' undeclared (first use these function)
    ...

    kann mir jemand helfen?
     
  8. woop

    woop New Member

    versuche es doch mal mit der php.ini im cgi verzeichnis.

    woop
     

Diese Seite empfehlen