Website nach IP-Wechsel nicht mehr erreichbar

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von webghost, 8. Okt. 2013.

  1. webghost

    webghost New Member

    Hallo,

    einer Domain wollte ich eine eigene IP zuweisen für den Betrieb mit SSL. Ich bin nach Handbuch vorgegangen. Die Option "Netzwerkkonfiguration" ist aktiv, müsste ja auch gehen da es ein Ubuntuserver ist.

    Nun wird auf die richtige IP geleitet aber die Seite ist nicht mehr erreichbar.
    http://domain.tld verweist auf das Standartverzeichnis von Apache "it works" kommt
    https://domain.tld gibt FEHLER 403 - Unzulässig!
    https://domain.tld/backend/ gibt FEHLER 404 - Nicht gefunden!

    Bevor ich jetzt in den Konfigurationsdateien Änderungen mache, wollte ich wissen ob es eine andere Lösung gibt? oder ob jemand weiss was ich falsch gemacht habe?

    ich denke an der DNS kann es nicht liegen. Der letzte Eintrag ist für den Server selbt also server.domain.tld
    Di IP mit 80 ist die allgemeine IP, die mit 79 für SSL

    Code:
            86400	IN	A	0	79.143.xxx.xxx	
            86400	IN	MX	10	mail.domain.net.	 
    *	86400	IN	A	0	79.143.xxx.xxx	
    mail	86400	IN	A	0	80.241.xxx.xxx	 
    server	86400	IN	A	10	80.241.xxx.xxx
     
    Zuletzt bearbeitet: 8. Okt. 2013
  2. Till

    Till Administrator

    Die Ip-Adresse der Webseite muss mit der IP der domain übereinstimmen, ist das nicht der fall zeigt apache die default seite an, da es dann keinen passenden vhost mit ip + domain Kombination gibt. Wenn der server hinter einem router steht, dann muss in der webseite die interne Ip und nicht die externe ip verwendet werden.
     
  3. webghost

    webghost New Member

    Sollte das nicht von ISPConfig automatisch gemacht werden? Ich hab ja die DNS angepasst und die IP in ISPConfig für die Website hinterlegt.

    Dann wird wohl das, das Problem sein. Wie finde ich aber heraus wie die interne IP lautet?
    Was ich weiss ist folgendes:
    IP: 79.143.xxx.xx
    Netzadresse: 80.241.xxx.0
    Gateway: 80.241.xxx.1
    Broadcast: 80.241.xxx.255
    Netmask: 255.255.255.0
     
  4. Till

    Till Administrator

    Wenn Du die richtige IP in den Webseiteneinstellungen in ispconfig angegeben hast, dann wird diese auch im vhost stehen. Welche die richtige IP istm habe ich Dir oben beschrieben.

    z.B.:

    ifconfig

    oder schau in Deinen router, auf welche Ip Du port 80 und 443 weitergeleitet hast.
     
  5. webghost

    webghost New Member

    hat sich erledigt, sorry.. Problem war der Provider hat mir eine falsche IP angegeben. Die richtige IP eingetragen und schon läuft alles wie es soll.

    danke für die Hilfe
     

Diese Seite empfehlen