Website nicht mehr erreichbar, falscher Pfad?

Dieses Thema im Forum "Allgemein" wurde erstellt von Germanius, 8. März 2010.

  1. Germanius

    Germanius New Member

    Hallo,

    ich hab die 3.0.2. RC1 laufen und hab eben bei einer Website der Statistik ein Passwort gegeben und bin dann auf speichern gegangen.

    Die Statistik lässt sich auch wunderbar aufrufen, allerdings funktioniert nun nichts mehr der restlichen Seite. Wenn ich z.B. direkt die Domain aufrufe kommt folgender Fehler

    Code:
    [B]Warning[/B]:  Unknown: open_basedir restriction in effect.  File(/var/www/domain.de/web/index.php) is not within the allowed  path(s):  (/var/www/clients/client[client_id]/web1/web:/var/www/clients/client[client_id]/web1/tmp:/usr/share/php5:/tmp:/usr/share/phpmyadmin)  in [B]Unknown[/B] on line [B]0[/B]
    
    [B]Warning[/B]:  Unknown: failed to open stream: Operation not permitted  in [B]Unknown[/B] on line [B]0[/B]
    
    [B]Fatal error[/B]:  Unknown: Failed opening required  '/var/www/domain.de/web/index.php'  (include_path='.:/usr/share/php:/usr/share/pear') in [B]Unknown[/B] on  line [B]0[/B]
    Bei den Websiteeinstellungen gibt es ja noch den Reiter "Optionen", da kann man einen Pfad eingeben. Ist es möglich, dass sich dieser geändert hat und beim Speichern des Statistikpassworts mitgespeichert wurde? Ich habe an dem Pfad nichts verändert.
    Bei mir steht drin

    Code:
    /var/www/clients/client[client_id]/web1/web:/var/www/clients/client[client_id]/web1/tmp:/usr/share/php5:/tmp:/usr/share/phpmyadmin
    Danke für die Hilfe
     
  2. Till

    Till Administrator

    Der Pfad sollte sich nicht von selbst ändern. Füge doch mal bitte:

    :/var/www/domain.de/web

    zu dem Pfad hinzu. Dann ptüfe, ob alles wieder geht und danach ändere nochmal das statistik Passwort und überprüfe, ob sich der Pfad geändert hat.
     
  3. Germanius

    Germanius New Member

    Danke, funktioniert wieder!

    Aber nun tritt der Fehler nicht mehr auf, wenn ich nochmal das Statistikpasswort ändere. Sehr seltsam, bin mir absolut sicher, dass ich nicht an irgendwelchen Pfaden rumgefummelt habe.
     
  4. Till

    Till Administrator

    Du hast vermutlich 3.0.1.6 vorher installiert gehabt? Die möglichkeit das open basedir zu setzen gibt es erst ab 3.0.2, es wurde da also beim setzen des stats Passwortes ein default eingertragen, da es das Feld ja vorher garnicht gab. Ich sehe mir das nochmal an, da im default der eine Pfad zu fehlen scheint.
     
  5. Germanius

    Germanius New Member

    Ja, das würde es natürlich erklären. Dann fehlt der eine Pfad.

    Auf dem System habe ich die 3.0.1.6 installiert, dann auf die 3.0.2 beta geupdated und schließlich auf die RC1.
     
  6. Germanius

    Germanius New Member

    Habe gerade auch noch festgestellt, dass beim Besitzer dieser Website alle Limits auf 0 gesetzt wurden.
    Die Mastervorlage hat sich auf Custom geändert, obwohl ich vorher ein erstelltes Template genutzt habe.
     

Diese Seite empfehlen