Weiterleitung in einen Unterordner funktioniert bei mir nicht

Dieses Thema im Forum "Allgemein" wurde erstellt von M. Zink, 18. Nov. 2007.

  1. M. Zink

    M. Zink New Member

    Ich habe ein Projekt da möchte ich nun ein Update durchführen. Dazu muss ich einen Ordner erstellen und die Software so gesehen neu installieren. Damit das nachher auch alles so ist wie ich das haben will muss ich jetzt die Domain vom ursprünglichen Verzeichnis in das neue Unterverzeichnis leiten. Laut Dokumentation geht das ganz easy indem ich in das Feld Weiterleitung lediglich den Ordnernamen eintrage. Das hab ich gemacht und gespeichert allerdings passiert bei mir rein gar nichts. Die Domain landet immer noch im Web Ordner des Webs und nicht in dem Unterordner. Muss ich da noch irgendwas anderes machen was nicht in der Dokumentation steht?

    EDIT:
    Hier grad noch das Log von ISPConfig falls da jemand schon sieht was los ist. Ich hab absolut keine Idee wo ich überhaupt anfangen sollte zu suchen.
    EDIT2:
    In der Vhosts... wurde auch ein Eintrag gemacht der eigentlich die Domain in den Ordner weiter leiten sollte wie ich das haben wollte.
    Kann das sein, dass bei mir mod_rewrite nicht da ist? Wenn das so ist wie bekomme ich das raus und wie ändere ich das? Ich hab mich an das HowTo gehalten für den Server und da war irgendwo was mit Rewrite was ich auch so eingetragen hab.

    EDIT3:
    Ich glaub ich kann mir denken wo das Problem ist. Bei Co-Domain ist ein Eintrag drin mit einem leeren Host Feld, und bei Domain steht einfach nur domain.tld drin. Die Weiterleitung greift also nur bei einem Aufruf ohne www. Ich dachte mir jetzt ich füge bei Co-Domain einfach noch einen Eintrag dazu mit www.domain.tld aber dann sieht das in der Vhost... so aus.
    Und damit bekomme ich bei meinem Firefox einen Fehler "Umleitungsfehler - Die aufgerufene Website leitet die Anfrage so um, dass sie nie beendet werden kann."
    Wenn dann müsste da was in der Art stehen wie
    RewriteCond %{HTTP_HOST} ^(domain|www\.domain)\.info [NC]
    RewriteRule ^/(.*)$ http://www.domain.info/wbb3/$1 [R]
    Dann würde das Skript für die Domain mit und ohne www greifen. Das www ist so gesehen ja auch nur ne Sub Domain aber trotzdem soll das beides funktionieren.

    EDIT4:
    Also irgendwie ist das alles nichts. Selbst wenn das mit dem Rewrite geht ist das absolut nicht so wie ich mir das vorstelle. In der Browserzeile soll weiterhin www.domain.tld stehen und nicht durch die Umleitung dann der Unterordner mit in der Zeile. Das heißt ich muss den DocumentRoot ändern nur irgendwo hier im Forum hab ich gelesen an der Vhost... soll man auf keinen Fall manuell rum schrauben. Wie mache ich das dann?
     
    Zuletzt bearbeitet: 19. Nov. 2007
  2. Till

    Till Administrator

  3. M. Zink

    M. Zink New Member

    Ich hatte mit dem Begriff "Weiterleitung" gesucht und das von Dir verlinkte Thema sowie noch ein weiteres gefunden. In beiden schien es mir aber so, dass es nicht um das geht was ich meine. Ich bin mir da auch jetzt noch nicht sicher. In dem Thema was Du verlinkt hast geht es darum mehrere Domains in den gleichen Web Ordner zu lenken und die Weiterleitung in den Ordner cms zu bewerkstelligen. Bei der Lösung ist als das Ergebnis das in der Browserzeile das cms als Unterordner mit drin steht. Aber genau das ist nicht das was ich gerne hätte. Das heißt bei mir liegt auch die ganze Seite in nem Unterordner wbb3 und ich möchte in der Browserzeile z.B. http://www.domain.tld/index.php stehen haben und nicht den Unterordner mit dabei. Ich war der Meinung das deswegen diese Lösung für mich nicht funktioniert. Oder kann ich das trotzdem so anwenden und für mich entsprechend umbauen?
     
  4. Till

    Till Administrator

    Ob die Domains in den gleichen oder verschiedene Ordner umgelenkt werden, macht keinen Unterschied. Du musst halt nur den richtigen Pfad angeben.
     

Diese Seite empfehlen