Weiterleitung mit Sonderzeichen

Dieses Thema im Forum "Allgemein" wurde erstellt von daniel.weber, 2. Nov. 2015.

  1. daniel.weber

    daniel.weber New Member

    Hallo zusammen,
    ich würde gerne eine Weiterleitung auf eine andere Adresse einrichten. Die Adresse beinhaltet Sonderzeichen
    bspw. %28 für (
    oder %29 für )
    Wird nun die Weiterleitung aufgerufen werden die Zeichen %2 verschluckt.
    Versuche ich die Klammern direkt in den Link zu schreiben, erhalte ich von ISPConfig eine Fehlermeldung (Ungültiger Weiterleitungspfad.)
    Escapen mag es scheinbar auch nicht.
    ich müsste u.A. auch auf Dateien weiterleiten können, bspw. name.pdf, hier scheint dann der Punkt das Problem zu sein?
    Was könnte man tun.
    (Weiterleitungstyp habe ich versucht "Kein Flag" und "R=301,L")

    Vielen Dank.

    Grüße
    Daniel
     
  2. Till

    Till Administrator

    Wenn es nicht über ispconfig geht dann kannst Du es in eine .htaccess datei einfügen.
     
  3. daniel.weber

    daniel.weber New Member

    Hallo Till,
    vielen Dank für die schnelle Antwort.
    Ich konnte es jetzt erstmal darüber lösen, dass ich in der vhost Datei die Weiterleitung mittels Escapezeichen manuell eingetragen habe.
    Gibt es einen Grund warum ISPConfig den eingegebenen String nicht selbstständig mit Escapezeichen versieht? Oder anders gefragt warum ist die Eingabe von \ nicht gestattet?
    Dem Kunden die direkte Eingabe in die .htaccess Datei zu zumuten sehe ich als nicht so förderlich ;)
     

Diese Seite empfehlen