weiterleitungen

Dieses Thema im Forum "Allgemein" wurde erstellt von sebastianh, 21. Okt. 2008.

  1. sebastianh

    sebastianh Member

    Hallo

    ich habe ein problemm mit isp3, ich habe nen paar domains, die zeigen alle per a-record auf den server wo auch isp liegt, nun möchte ich diese ja alle in unterschiedliche ordner weiterleiten, jedoch sthe eich genau dort vor dem problemm. Es ist nur die standart seite von apache zu sehen, die domains werden also nicht weitergereicht zu den ordnern. Wo genau liegt dort mein Fehler? Muss ich noch etwa manuell einstellen?
    Bei ISP2 ging das glaube ich doch auch einfach so, dort habe ich doch auch nur die domain´s eingetragen und habe ich die index seite von isp von dem ordner gesehen.

    Benötige ich zusätzlich noch nen DNS eintrag, bin aber eigentlich der meinung das dies ja nicht weiter nötig sein sollte wenn der A-Record schon auf den server zeigt. Stehe ab solut auf dem Schlauch:confused:

    Da ich selbt der Meinung bin das 99% der Fehler vor dem Bildschirm sitzen seit nicht zu hart;)

    LG
     
  2. Till

    Till Administrator

    Lege bitte für jede Domain eine Webseite undet Sites > Websites > Domain an. Vei IP Kannst Du am einfachsten * auswählen.
     
  3. sebastianh

    sebastianh Member

    Hallo,

    dies habe ich bereits getan, jede domain hat somit ja theoretisch ihren eigenen ordner
    e.g. /var/clients/client1/web1
    jedoch liegt genau dort das problemm, da alle domains lediglich auf
    /var/www/apache2-default
    zeigen wenn ich sie per browser aufrufe.
    Landen also alle nur im standart verzeichniss obwohl das Documentroot: auf /var/clients/... zeigt.

    Also sollte der Fehler doch eigentlich im Apache liegen, oder?

    LG
     
  4. Till

    Till Administrator

    Apache zeigt auf den Default Ordner, wenn es ekinen besser passenden Ordner gibt. Und Du hast '*' bei IP ausgewählt?
     
  5. sebastianh

    sebastianh Member

    jop, das '*' ist drinne, habe alle noch einmal überprüft und auch in db geschaut.

    .:EDIT.:
    habe gerade mal per konsole geschaut, der ordner clients ist nichts vorhanden, wurde also nicht erzeugt. an was kann das liegen?

    .:EDIT:.
    Habe gerade noch nen Thema gefunden mit dem selben problemm
    -> http://www.howtoforge.de/forum/showthread.php?t=945

    Habe dann mal ispconfig_update_from_svn.sh aufgerufen, wie es dort steht, SVN ist bereits die neuste version.
    Hat sich aber nichts geändert.
     
    Zuletzt bearbeitet: 21. Okt. 2008
  6. Till

    Till Administrator

    Poste bitte mal die Ausgabe von:

    ls -la /var/clients
     
  7. sebastianh

    sebastianh Member

    Ich hatte mein server noch mal komplette neu gemacht, ist ja an sich nicht so das ding, dann musste ich feststellen, das die install der benötigten programme für ISPConfig nen probklemm gemacht hat,
    MYDNS war der übeltäter, das programm meinte bei der installation das es keine datenbank verbindung aufbauen konnte, obwohl die vorher eingegebenen Daten 100%ig richtig waren. Dann habe ich noch mal alles zurückgesetzt um mir noch mal sicher zu gehen. Nun denke ich, das das problemm an dem servernamen gelegen hat. Dieser wird bei meinem server automatisch gesetzt und diesen habe ich dann gleich nach der installation in
    -> /etc/hosts und
    -> /etc/hostname
    geändert. und auch noch mit
    -> hostname NEUERNAME
    gesetzt.
    Jedoch hatte ich vergessen den MYSQL user auch auf den neuen server namen zu setzen.
    Ich denke dort liegt das problemm. MYDNS hat versucht sich mit dem neuen namen in mysql einzuloggen, aber da dort der name moch der alte war, passierte dort nichts weiter. Jedoch hätter der Fehler nicht passieren dürfen, da mydns ja selbst nach den Daten vorhre noch fragt und dort habe ich root und nicht den servernamen angegeben, und die daten haben gestimmt, also hätte der login klappen müssen, der der login aber schief ging, nehme ich an das nicht root als loginnmae genommen wurde sondern der server name.
    Desweiteren denke ich solte ISP bei diesem Fehler abbrecjen wenn MYDNS nen Fehler schon wirft.

    Lange rede kurzer sinn....
    habe dann alles noch mal neu gemacht den nutzernamen noch geändert und dann ging das auch ohne problemme.
    Domains kann ich nun alle anlegen und alles passt wie es soll.

    Habe zwar noch nen anderes Problemm mit meinen Emails, da dort noch nichts passiert, aber da schaue ich mal was ich dort falsch gemacht habe, ggf melde ich mich dazu noch mal.

    LG Sebastian
     
  8. sebastianh

    sebastianh Member

    Wie ich gerade feststellen musste besteht das problemm immer noch, habe server noch mal neu aufgesetzt. Aber bleibe nun bei der install. von mydns hängen.
    Code:
    Setting up mydns-mysql (1.1.0-7etch1) ...
    /etc/mydns.conf created/modified. See mydns.conf(5) for details.
    A backup of the old config file is at /etc/mydns.conf.dpkg-old. Values
    were preserved, except for database (database,db-*)
    and distribution-specific information (user, group, pidfile).
    ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)
    Creating database...
    mysqladmin: connect to server at 'localhost' failed
    error: 'Access denied for user 'root'@'localhost' (using password: YES)'
    dpkg: error processing mydns-mysql (--configure):
     subprocess post-installation script returned error exit status 1
    Errors were encountered while processing:
     mydns-mysql
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    
    Ich weiß nicht warum die daten nicht stimmen sollen, die sind 100%ig richtig eingegeben.

    Für MYDNS habe ich die Verbindungsdaten in /etc/mydns.conf auch gefunden, dort stehen aber nur die daten die mydns dann benutzt. Aber bei der installation wird ja noch mit root gearbeitet, wo zieht der die daten dann wieder her. also ich das paket installiert habe sollte ich die ja eingeben, da ich aber nen fehler bei der install hatte, habe ich mydns noch mal deinstalliet und dann noch mal "versucht" neu zu installieren, jedoch werde ich dann nich mahr nach den daten gefragt, also werden die bereits irgendwo liegen. Konnte ich aber nicht finden.
     
  9. Till

    Till Administrator

    Der mydns installer ist da zielmlich nervig. Ich hatte das Problem auch mal und konnte die falschen daten nicht finden, hatte dann einfach den Server nochmal neu aufgesetzt. Als Alternative deinstallier einfach mydns und installier ihn neu von sourcen wie es ind er Anleitung für Ubuntu 8.04 steht.
     
  10. sebastianh

    sebastianh Member

    ok, das ist gut zu wissen, denke aber das es dann sinvoll ist in isp config die installation dann abzubrechen, da dann sowie so kein sauberer betrieb möglich ist

    LG Sebastian

    PS.: Danke für die Antwort, denke Thema ist dann erledigt.
     

Diese Seite empfehlen