Wenn neue Domain per DNS eingerichtet, zeigt diese zuerst auf eine bestehende

Dieses Thema im Forum "Allgemein" wurde erstellt von pee, 23. Dez. 2009.

  1. pee

    pee New Member

    Hallo,

    wenn ich per DNS mit einer neuen Domain auf meinen Server zeige und diese noch nicht im Adminpanel konfiguriert habe, so zeigt diese auf eine bestehende Domain.

    Wie kann ich bestimmen, auf welchen Ort neue Domains zeigen sollen?
     
  2. Burge

    Burge Member

    gar nicht, aber eigentlich sollte doch die sharedhost default seite aufgrufen wenn der eintrag noch gar nicht existiert oder hast du da was umgestellt?
     
  3. pee

    pee New Member

    In meiner default Datei unter /etc/apache2/sites-available steht folgendes drin:

    Es lässt sich hiermit meines Erachtens auf keine Seite schließen, die standardmäßig aufgerufen wird. Fällt euch hier etwas auf?
     
  4. Burge

    Burge Member

    doch dort
    DocumentRoot /var/www/

    sollte halt die datei liegen die default aufgerufen wird denke ich.

    Bei ispconfig 3 liegt doch die "it's works" drin und und ispconfig 2 hat noch extra ein dir "sharedip" wo sicher aber auch der vhost drauf verweist. Bin zufaul jetzt nachzuschaun.
     
  5. pee

    pee New Member

    Ab ISPC 3.0.1.6 ist es ja so, dass aus Sicherheitsgründen der Zugriff auf /var/www/ von außen verboten ist.

    Aber danke für den Tipp, habe nun in die default Datei

    eingetragen. Dort hab ich auch schon phpMyAdmin und Squirrelmail hinkopiert, da so über http://server-adresse:8080/blar der Aufruf nicht verboten wird.
     
  6. pee

    pee New Member

    Habe nun wieder eine neue Domain angelegt und gemerkt, dass die Einstellung in der default Datei unter /etc/apache2/sites-available nichts gebracht hat.

    Die Änderung der 000-default unter /etc/apache2/sites-enabled half nach dem Webserver-Neustart auch nicht. So sieht die Datei derzeit aus:

    Die neue Domain zeigt auf eine bestehende. Sobald ich sie ins ISPConfig eintrage, wird ein VHost erstellt. Doch ist mir die Einstellung mit dem Zeigen auf die bestehende Domain trotzdem ein Dorn im Auge.

    Ich würde mich sehr darüber freuen, wenn mir hier jemand weiterhelfen könnte.
     
  7. Till

    Till Administrator

  8. pee

    pee New Member

    Till, ich finde da nichts explizit zu Default-Host.

    Die DocumentRoot Einstellungen helfen nicht. Auch wenn ich überall bei <Directory /> meinen Ordner angebe, wird die Startseite des Vhosts aufgerufen, dessen Bezeichnung alphabetisch am höchsten liegt. Google findet auch nichts.

    Meine default-Datei unter /etc/apache2/sites-available (vielleicht fällt ja einem von euch etwas auf):

     
  9. Till

    Till Administrator

    Da hast Du Dir die Seite aber nicht genau durchgelesen, da ist ein kompletter Abschnitt dabei über default vhosts. Zitat:

     

Diese Seite empfehlen