Wenn neue Domain per DNS eingerichtet, zeigt diese zuerst auf eine bestehende

pee

New Member
#1
Hallo,

wenn ich per DNS mit einer neuen Domain auf meinen Server zeige und diese noch nicht im Adminpanel konfiguriert habe, so zeigt diese auf eine bestehende Domain.

Wie kann ich bestimmen, auf welchen Ort neue Domains zeigen sollen?
 
#2
gar nicht, aber eigentlich sollte doch die sharedhost default seite aufgrufen wenn der eintrag noch gar nicht existiert oder hast du da was umgestellt?
 

pee

New Member
#3
In meiner default Datei unter /etc/apache2/sites-available steht folgendes drin:

<VirtualHost *:80>
ServerAdmin webmaster@localhost

DocumentRoot /var/www/
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>
<Directory /var/www/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access.log combined

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
Options Indexes MultiViews FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>

</VirtualHost>
Es lässt sich hiermit meines Erachtens auf keine Seite schließen, die standardmäßig aufgerufen wird. Fällt euch hier etwas auf?
 
#4
doch dort
DocumentRoot /var/www/

sollte halt die datei liegen die default aufgerufen wird denke ich.

Bei ispconfig 3 liegt doch die "it's works" drin und und ispconfig 2 hat noch extra ein dir "sharedip" wo sicher aber auch der vhost drauf verweist. Bin zufaul jetzt nachzuschaun.
 

pee

New Member
#6
Habe nun wieder eine neue Domain angelegt und gemerkt, dass die Einstellung in der default Datei unter /etc/apache2/sites-available nichts gebracht hat.

Die Änderung der 000-default unter /etc/apache2/sites-enabled half nach dem Webserver-Neustart auch nicht. So sieht die Datei derzeit aus:

<VirtualHost *:80>
ServerAdmin webmaster@localhost

DocumentRoot /var/www/ispconfig/newDomainIndexFile/
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>
<Directory /var/www/ispconfig/newDomainIndexFile/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access.log combined

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
Options Indexes MultiViews FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>

</VirtualHost>
Die neue Domain zeigt auf eine bestehende. Sobald ich sie ins ISPConfig eintrage, wird ein VHost erstellt. Doch ist mir die Einstellung mit dem Zeigen auf die bestehende Domain trotzdem ein Dorn im Auge.

Ich würde mich sehr darüber freuen, wenn mir hier jemand weiterhelfen könnte.
 

pee

New Member
#8
Till, ich finde da nichts explizit zu Default-Host.

Die DocumentRoot Einstellungen helfen nicht. Auch wenn ich überall bei <Directory /> meinen Ordner angebe, wird die Startseite des Vhosts aufgerufen, dessen Bezeichnung alphabetisch am höchsten liegt. Google findet auch nichts.

Meine default-Datei unter /etc/apache2/sites-available (vielleicht fällt ja einem von euch etwas auf):

<VirtualHost *:80>
ServerAdmin webmaster@localhost

DocumentRoot /var/www/ispconfig/newDomainIndexFile
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>
<Directory /var/www/ispconfig/newDomainIndexFile/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access.log combined

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
Options Indexes MultiViews FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>

</VirtualHost>
 

Till

Administrator
#9
Da hast Du Dir die Seite aber nicht genau durchgelesen, da ist ein kompletter Abschnitt dabei über default vhosts. Zitat:

Using _default_ vhosts


  • Setup 1: Catching every request to any unspecified IP address and port, i.e., an address/port combination that is not used for any other virtual host. Server configuration:
    ...
    <VirtualHost _default_:*>
    DocumentRoot /www/default
    ...
    </VirtualHost>

    Using such a default vhost with a wildcard port effectively prevents any request going to the main server.
    A default vhost never serves a request that was sent to an address/port that is used for name-based vhosts. If the request contained an unknown or no Host: header it is always served from the primary name-based vhost (the vhost for that address/port appearing first in the configuration file).
    You can use AliasMatch or RewriteRule to rewrite any request to a single information page (or script).​
  • Setup 2: Same as setup 1, but the server listens on several ports and we want to use a second _default_ vhost for port 80. Server configuration:
    ...
    <VirtualHost _default_:80>
    DocumentRoot /www/default80
    ...
    </VirtualHost>

    <VirtualHost _default_:*>
    DocumentRoot /www/default
    ...
    </VirtualHost>

    The default vhost for port 80 (which must appear before any default vhost with a wildcard port) catches all requests that were sent to an unspecified IP address. The main server is never used to serve a request.​
  • Setup 3: We want to have a default vhost for port 80, but no other default vhosts. Server configuration:
    ...
    <VirtualHost _default_:80>
    DocumentRoot /www/default
    ...
    </VirtualHost>

    A request to an unspecified address on port 80 is served from the default vhost any other request to an unspecified address and port is served from the main server.​
 

Werbung

Top