while performing the EHLO handshake

Dieses Thema im Forum "Server Administration" wurde erstellt von wasdim, 12. Nov. 2015.

  1. wasdim

    wasdim Member

    Nochmals Hallo liebes Forum
    The Perfect Server - Ubuntu 14.04 (Apache2, PHP, MySQL, PureFTPD, BIND, Dovecot, ISPConfig 3)
    Bekomme seit kurzem folgende Meldungen im Log vom ISPConfig 3.0.5.4p8.
    Habe schon mit Google gesucht und gesucht und komme nicht auf die Lösung wo der fehler ist ob bei mir oder beim Empfänger.
    Mail Queue
    1038E1941371 1834 Thu Nov 12 08:03:39 mbeltrando@tankmaterial.ch
    (lost connection with mx.ridart.it[62.149.128.154] while performing the EHLO handshake)
    dmeneghini@ridart.it

    Nov 12 16:42:45 server1 postfix/smtp[19993]: AEC0E1941E99: to=<dmeneghini@ridart.it>, relay=mx.ridart.it[62.149.128.151]:25, delay=4545, delays=4538/0.03/7.2/0, dsn=4.4.2, status=deferred (lost connection with mx.ridart.it[62.149.128.151] while performing the EHLO handshake)

    208081941E7A 5161 Thu Nov 12 11:08:44 narca@xiweb.ch
    (lost connection with in.widestore.net[62.149.157.166] while performing the EHLO handshake)
    loris.drigo@sigecservice.com
     
    Zuletzt bearbeitet: 12. Nov. 2015
  2. Till

    Till Administrator

    Das bedeutet dass der Server mx.ridart.it die Verbindung zu Deinem Server abrupt unterbrochen hat. Schau mal ob Deine Server IP auf irgendwelchen Blacklists steht.
     
  3. wasdim

    wasdim Member

  4. Till

    Till Administrator

    Tritt das nur bei dem einen empfänger server auf?
     
  5. wasdim

    wasdim Member

    Anhänge:

  6. wasdim

    wasdim Member

    Hat jemand noch einen Tipp oder Idee?
    Wäre sehr dankbar.
     
  7. wasdim

    wasdim Member

    Nochmals Hallo Zusammen
    Mein Problem ist immer noch vorhanden. Ich benötige hilfe.
    The mail system

    <d.xxxx@xxx-magdeburg.de>: lost connection with
    mailcleaner.itcon.info[xx.xx.xx.xxx] while performing the EHLO handshake

    Ich suche mich schon fast zu TODE für eine Lösung.
    Wäre SUPER NETT und LIEB wenn mir da einer die hand bieten würde.
    Besser noch wenn jemand auf meinen server einen blick werfen könnte. Danke Vorab
     
  8. nowayback

    nowayback Well-Known Member

    schau mal nach ob dein hostname irgendwas sinnvolles ist, z.b. server.domain.endung oder ob das irgendwas wie sdafdas324234.clients.domain.endung ist. (cat /etc/hostname)

    das sehen einige mailserver nämlich nicht gerne.

    als 2. muss in der main.cf unter myhostname der gleiche name stehen.

    solltest du außerdem einen eintrag in der main.cf haben der smtp_helo_name heißt, dann sollte der den gleichen namen haben wie der hostname

    als letztes ist noch der reverse dns eintrag zu prüfen. der muss genauso wie der hostname für die lauten.

    wenn das alles erledigt ist, sollte es von deiner seite aus kein problem geben.

    grüße
    nwb
     
  9. wasdim

    wasdim Member

    Hallo und Danke für deine schnelle antwort
    /etc/hostname
    server1.xiweb.ch

    main.cf
    # See /usr/share/postfix/main.cf.dist for a commented, more complete version
    # Debian specific: Specifying a file name will cause the first
    # line of that file to be used as the name. The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname

    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no

    # appending .domain is the MUA's job.
    append_dot_mydomain = no

    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h

    readme_directory = /usr/share/doc/postfix

    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/smtpd.cert
    smtpd_tls_key_file = /etc/postfix/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.

    smtpd_relay_restrictions = permit_mynetworks permit_sasl_authenticated defer_un$
    myhostname = mail.xiweb.ch
    alias_maps = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
    alias_database = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
    myorigin = /etc/mailname
    mydestination = mail.xiweb.ch
    relayhost =
    mynetworks = 127.0.0.0/8 [::1]/128
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    html_directory = /usr/share/doc/postfix/html
    virtual_alias_domains =
    virtual_alias_maps = hash:/var/lib/mailman/data/virtual-mailman, proxy:mysql:/e$
    virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
    virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
    virtual_mailbox_base = /var/vmail
    virtual_uid_maps = static:5000
    virtual_gid_maps = static:5000
    inet_protocols = all
    [ Zeile 1/83 (1%), Spalte 1/77 (1%), Zeichen 0/3986 (0%) ]
    ^G Hilfe ^O Speichern ^R Datei öffn^Y Seite zurü^K Ausschneid^C Textmarke
    ^X Beenden ^J Ausrichten^W Wo ist ^V Seite vor ^U Ausschn. r^T Rechtschr.

    so hier mal die beiden angaben
    Gruss und danke vorab
     
  10. nowayback

    nowayback Well-Known Member

    Bitte benutze zukünftig die Code Tags, dann liest es sich einfach.

    Dein Problem liegt warscheinlich an dem was ich oben schrieb:
    Code:
    /etc/hostname
    server1.xiweb.ch
    Code:
    myhostname = mail.xiweb.ch
    Die beiden müssen gleich sein. also entweder server1 oder mail.

    außerdem hast du auch einen abweichenden eintrag:
    Code:
    mydestination = mail.xiweb.ch
    einfach dafür sorgen das überall das gleiche steht ;-)

    Grüße
    nwb
     
  11. wasdim

    wasdim Member

    hallo und danke für deine hilfe.
    an welcher stelle in der main.cf setze ich das ein ? smtp helo name da es nicht vorhanden ist.
    das mit dem code entschuldige.
    gruss michi
    PS: soeben in der ISPConfig 3.0.5.4p8 Log
    Jan 16 17:28:37 server1 postfix/smtp[2497]: 302E71941DE4: to=<frederic.andres@ulrichimboden.ch>, relay=alpha3.officeco.ch[194.209.35.21]:25, delay=185663, delays=185661/0.61/0.8/0, dsn=4.4.2, status=deferred (lost connection with alpha3.officeco.ch[194.209.35.21] while performing the EHLO handshake)
     
    Zuletzt bearbeitet: 16. Jan. 2016
  12. nowayback

    nowayback Well-Known Member

    du hast in der mail.cf folgenden eintrag:
    Code:
    myhostname = mail.xiweb.ch
    den änderst du in:
    Code:
    myhostname = server1.xiweb.ch
    außerdem hast du in der main.cf folgenden eintrag:
    Code:
    mydestination = mail.xiweb.ch
    den änderst du in:
    Code:
    mydestination = server1.xiweb.ch
    desweiteren zeigt dein reverse dns eintrag dann noch auf den falschen hostname. das heißt, den musst du bei deinem provider auch noch ändern in server1.xiweb.ch

    danach postfix neu starten und dann sollte alles laufen
     
  13. wasdim

    wasdim Member

  14. nowayback

    nowayback Well-Known Member

    ich weiß, deshalb hab ich geschrieben, dass du das ändern sollst in server1.xiweb.ch
     
  15. wasdim

    wasdim Member

    ok könnte ich das auch anders lösen?
     
  16. nowayback

    nowayback Well-Known Member

    ja,

    ändere den hostname in mail.xiweb.ch

    dann kontrolliere ob in der main.cf noch
    Code:
    myhostname = mail.xiweb.ch
    mydestination = mail.xiweb.ch
    
    steht. wenn du das schon geändert haben solltest, dann musst du es zurück ändern sodass die einträge so aussehen.

    danach sollte also an allen 4 positionen (hostname (/etc/hostname/), myhostname (/etc/postfix/main.cf), mydestination (/etc/postfix/main.cf), reversedns (dein provider)) als eintrag mail.xiweb.ch stehen
     
  17. robotto7831a

    robotto7831a Member

    Und folgendes nicht vergessen.
    Code:
    /etc/init.d/hostname.sh start
    /etc/init.d/postfix restart
    
     
  18. wasdim

    wasdim Member

    habe ich nun auch so angepasst.
    kann ich nun auch noch das in der main.cf smtp helo name setzen. an welcher stelle kommt das nun hin?
    smtp_helo_name = mail.xiweb.ch
     
  19. nowayback

    nowayback Well-Known Member

    kannst du, brauchst du aber nicht zwingend. daher würde ich das erstmal lassen
     
  20. wasdim

    wasdim Member

    ja wieso wird dann die mail vom empfänger vom server abgelehnt?
    Jan 16 19:03:16 mail postfix/smtp[3030]: E011E1941E85: to=<frederic.andres@ulrichimboden.ch>, relay=alpha3.officeco.ch[194.209.35.21]:25, delay=209919, delays=209918/0.03/0.85/0, dsn=4.4.2, status=deferred (lost connection with alpha3.officeco.ch[194.209.35.21] while performing the EHLO handshake)
     

Diese Seite empfehlen