Wie fange ich an?

Dieses Thema im Forum "Allgemein" wurde erstellt von Lieselotte, 26. Mai 2010.

  1. Lieselotte

    Lieselotte New Member

    Guten Abend :)

    Ich habe eine Menge Fragen, die für die meisten hier warscheinlich ziemlich dumme Fragen sind (Es gibt bestimmt wohl dumme Fragen).

    Nun gleich mal zu meinem Anliegen: Ich betreibe eine ziemlich gut besuchte Webseite (www.webseite.tld) und ein dazugehöriges Forum (forum.webseite.tld). Derzeit ist alles noch bei so einem großen Provider gehostet, den ich aber mangels Service verlassen will. Dazu habe ich mir bei einem kleinen kundenfreundlichen Unternehmen einen VServer gemietet mit einer festen IP. Darauf habe ich seit heute Debian Lenny 64bit mit neusten Updates installiert und nun, da ich es mir für die Zukunft einfach machen will, auch noch ISPConfig 3.0.2.1.
    Was vielleicht noch wichtig wäre zu erwähnen ist, das ich erst alles hübsch einrichten will für den Umzug, so das ich im Anschluß nur noch die Domain nachholen muß. Wie ich feststellen mußte ist es unmöglich etwas einzurichten wenn man keinen Namen für die IP hat, somit hab ich heute von meinem VServer-Anbieter einen Namen bekommen ala name.provider.tld, damit kann ich den Server auch ansprechen.

    Nun hab ich mich also eingeloggt in das Panel und stehe da wie der Ochs vorm Berg, hab mit der großen Suchmaschine nach einer ausführlichen Anleitung gesucht, bin aber für die neue Version nicht fündig geworden. Ist warscheinlich alles noch zu neu. Ich hab ehrlich gesagt nicht so wirklich die Ahnung wo ich nun anfangen soll um mein Ziel (siehe oben) zu erreichen, und das ganze auch noch ohne was kaputt zu machen.

    Gibt es vielleicht jemanden mit ein wenig Geduld der mir etwas auf die Sprünge hilft? (damit meine ich nicht wegjagen :))

    Mein Ziel soll am Ende sein:
    eine Webseite (www.webseite.tld)
    eine Subdomain (forum.webseite.tld)
    (und einfaches Einrichten von beliebig vielen Subdomains)
    Einrichtung von Emails (bzw. Email-Weiterleitungen)

    Vorhanden sind:
    eine feste IP-Adresse für die VServer
    ein vom (Provider "ausgeliehener" FQDN)
    Root-Zugriff in der Konsole
    eine FQDN (die wird dann auf den VServer draufgeschaltet)

    So das ich mich am Ende möglichst nur noch als "Kunde" selbst verwalten kann und als Admin nur noch im Notfall fungiere.

    Und nu bitte nicht ganz so laut lachen, ich bin wirklich gewillt das zu können :eek:

    LG Lieselotte
     
  2. Burge

    Burge Member

    Moin,

    keine Angst lacht keiner.

    Schau mal hier das sollte dir für viele einfache Sachen weiterhelfen.

    Dein Plan ist auch Nachvollziehbar und machbar. Nur ein Tip für das was du sagst als Subdomain, lege dafür dann einfach extra webs an und nutze als domain dann einfach die subdomain deiner wahl. Sprich richte dann zu deinem normalen Web halt ein fach noch ein web ein mit der tld forum.domain.tld .

    Das bringt dich auch Sicherheitskritisch weiter weil durch ein gehacktes forum dann dein Webseite nicht gleich geleakt ist .
     
  3. Lieselotte

    Lieselotte New Member

    Vielen Dank erstmal für die schnelle Antwort *freu*

    In dem Wiki war ich schon, danke trotzdem für den Link und die Mühe, mein größtes Problem ist die Angst das Sytem zu semmeln, ich hab in 5 Tagen gefühlte 3546 mal das komplette System neu aufgesetzt, weil eigentlich versuche ich immer selbst zum Ziel zu kommen.

    Ich habe mir gestern abend dieses hübsche Handbuch vorgenommen von ISPConfig2, das war sehr ausführlich, aber für die neue Version von ISPConfig hilft es mir nicht wirklich weiter.

    Der Wikilink ist für Menschen die schonmal mit älteren Versionen zu tun hatten sicherlich ganz klasse, er geht auf die Oberfläche ein, aber eben nicht ausführlicher auf die Dinge die man da einstellt und warum.

    Ich bin nun grad eingeloggt im Panel und hab noch nix verstellt, wo fange ich an um meinem Ziel näher zu kommen? gibt es wichtige Sicherheitseinstellungen die ich zu allererst vornehmen sollte (außer das Passwort, das zu ändern versteht sich von selbst)?

    Kann ich von der Admin-Oberfläche aus direkt einen Kunden anlegen und den Reseller gleich überspringen?

    LG Lieselotte

    an die Edith: kann es sein das es den Reseller nun gar nicht mehr gibt?
     
    Zuletzt bearbeitet: 27. Mai 2010
  4. Burge

    Burge Member

    Ja Reseller sind nicht nötig kannst direkt den Kunden anlegen.

    Zur Sicherheit -> Passwort ändern ist klar. Ansonsten wenn du dich nach einem howto für die Einrichtung gehalten hast sollte dein System schon erstmal medium sicher sein (durch rkhunter und fail2ban etc).

    Ansonsten mach als erstes die Einstellungen vom server, fdqn eintragen, einschalten was du machen ftp, dns usw...

    Dann legst client an. Dann legst du Webdomain an und dann die Maildomain.

    zu beachten ist bei der 3. das web und mail getrennt sind.

    Wegen den kaputt machen, keine Angst ich glaub im ispconfig selber kannst nix verhunzen was man nicht wieder hinbekommt.
     
  5. F4RR3LL

    F4RR3LL Member

    Habe einen Großteil dessen geschrieben und kenne ältere Versionen Ispconf2 nichtmal ;)

    Aber ich finde es gut was du sagst ... du willst was zum Warum... ok schreib ich mir hinter die Ohren und wenn ich weiß wie ichs formuliere auch ins Wiki ;)

    Ist halt schwer ne Anleitung hinzubekommen die Adressatengerecht ist ... nicht schwallt .. nichts weglässt aber auch ned auf wichtiges verzichtet. Liegt immer im Auge des Betrachters. Aber ist aufgenommen.

    Gruß Sben
     
  6. Lieselotte

    Lieselotte New Member

    Es ist mir wenig geholfen wenn ich Schritt für Schritt einfach was nachmache (halt ein Nachmach-Tutorial), das hilft zwar auf die Schnelle, jedoch bin ich anschließend genauso dumm wie vorher, und die Fehlersuche, falls es einen Fehler gibt, ist nahezu aussichtslos wenn man nicht weiß was man wo eingestellt hat. Zumindest wenn man sich selbstständig auf Fehlersuche begibt. ;) Es freut mich aber das es Menschen gibt die sich freiwillig in ihrer Freizeit darum kümmern das es am Ende auch ne tolle Anleitung gibt *Daumen hoch*

    LG Lieselotte
     
  7. Lieselotte

    Lieselotte New Member

    So, hab mich getraut.... Der admin war ja schon automatisch da, ich hab nun einen neuen Benutzer angelegt. Der Benutzer ist "user" und das Häkchen bei "aktiv" hab ich auch angemacht.

    Die Webseite name.provider.tld ist so auch aufrufbar, ich hab sie dem Benutzer zugefügt. Dann bin ich auf die Benutzerseite gewechselt und habe dort eine Subdomain angelegt wie dort ganz unten beschrieben:
    im Verzeichnis www (dort wo die index.html für die webseite liegt) habe ich auch einen Ordner /forum angelegt.

    Nun nachdem ich in /etc/apache2/sites-enabled die "@000-default" händisch entfernt habe, geht domain.de von ISPConfig aber forum.domain.de will immer noch nicht ...

    LG, Lieselotte
     
  8. planet_fox

    planet_fox Super-Moderator

    Ich weiß nicht wir da anders machen könnten, damit du was lernst dabei oder so. Du hast recht mit dem was du im Punkto zu den kleinen schritten gesagt hast, aber das hat F4RR3LL schon aufgenommen. Was würdest du denn haben alternativ ein Buch oder was meinst du damit.

    Was soll forum.seite.de sein eine weiterleitung auf haupseite.de/forum oder eine eigene domain ?.
     
  9. Lieselotte

    Lieselotte New Member

    :eek: also ich bin schon lernfähig...

    Ich meinte damit eingentlich das ich etwas gegen Schritt-für-Schritt-Nachmach-Tutorials ohne jegliche Erklärungen habe, da man eben einfach nur die Dinge nachmacht, und am Ende eigentlich genauso schlau ist wie vorher auch.... ist aber nur meine persönliche Meinung.... Das mag jeder für sich selbst entscheiden. Es war keine Kritik an die fleißigen Anleitungsschreiber, vor denen ziehe ich meinen Hut....
    --------------
    Ja, ich möchte einmal

    www.hauptseite.tld haben, die Adresse haben wir schon, und subdomain.hauptseite.tld soll in www.hauptseite.tld/subdomainordner/ enden ....

    Das mit www.hauptseite.tld habe ich schon hinbekommen, aber die Subdomain will irgendwie nicht.

    LG Lieselotte
     
  10. Burge

    Burge Member

    Lege dafür ein ein extra Web an für den gleichen Kunden.

    Mache es nicht per Subdomain.

    Bei dem Web was du anlegst gibst als domain dann ein forum.domain.tld

    so hast auch sicherheitsrelevant die sachen getrennt denn die heutigen Foren wenn werden schnell geknackt.
     
  11. Feanwulf

    Feanwulf Member

  12. Lieselotte

    Lieselotte New Member

    Ein dickes Dankeschön...

    alsooo:

    dank der Unterstützung von Burge läuft nu alles so wie es soll, (an dieser Stelle nocheinmal ein dickes Dankeschön :) ) hab auch für die Subdomain ein extra Web angelegt, und eigentlich sah es nur schwieriger aus als es war, einfach nur aufm Knopf drücken und schon läuft Email, FTP, und alles was ich sonst noch so haben will. Sogar ein SMF hab ich so zum testen schon installiert, alles problemlos :)

    Ebenfalls ein dickes Dankeschön an die Macher von ISPConfig, und an den Falko für seine tolle Anleitung für den perfekten Debian-Server :)

    und weil es so schön war darf ich jetzt alles neu machen, weil ich mir in geistiger Umnachtung mitten in der Nacht mit geschlossenen Augen die root-permission in der Konsole verboten habe weil wegen der Sicherheit dabei aber vergessen habe (bitte nicht lachen, es war schon spät) vorher einen User anzulegen der Shellzugriff hat :eek: *schäm*

    LG Lieselotte
     

Diese Seite empfehlen