WordPress .htaccess Problem

Dieses Thema im Forum "Smalltalk" wurde erstellt von Falcon37, 12. Apr. 2009.

  1. Falcon37

    Falcon37 New Member

    Das betrifft zwar nicht ISPConfig / Linux, aber im PHP Forum & im WordPress Forum konnte es auch keiner lösen, deswegen dacte ich versuche ich es hier mal ;)
    Den Inhalt der .htaccess Datei die ich für WordPress verwende habe ich im ISPConfig Panel in die Apache Direktiven geschrieben, funktioniert alles auch astrein, nur legt das Script mit jedem neuen Artikel den ich erstelle die .htaccess-Datei neu an, und dann muss ich diese immer manuell löschen. Denn wenn er eine .htaccess anlegt läuft nichts mehr, Fehler 500.

    Es weiß wohl keiner zufällig wie ich das lösen kann? Folgende Rechte habe ich für die Datei bereits erfolglos versucht: 755, 777, 644, 664
     
  2. Till

    Till Administrator

    Das lässt sih doch sehr einfach lösen. Du schaust einfach in das error log der webseite welchen Fehler wordpress auslöst und dann behebst Du den.
     
  3. Falcon37

    Falcon37 New Member

    Aja stimmt ja gute Idee, also die Meldung ist jetzt klar - allerdings lösen konnte ich es nicht:
    Code:
    [Mon Apr 13 16:25:06 2009] [crit] [client XX.XXX.XX.XXX] (13)Permission denied: /var/www/clients/client0/web1/web/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable, referer: http://www.domain/wp-admin/page.php?action=edit&post=2
    [Mon Apr 13 16:25:06 2009] [crit] [client XX.XXX.XX.XXX] (13)Permission denied: /var/www/clients/client0/web1/web/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable, referer: http://www.domain/wp-admin/page.php?action=edit&post=2
    [Mon Apr 13 16:25:30 2009] [crit] [client XX.XX.XXX.X] (13)Permission denied: /var/www/clients/client0/web1/web/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable
    [Mon Apr 13 16:25:30 2009] [crit] [client XX.XX.XXX.X] (13)Permission denied: /var/www/clients/client0/web1/web/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable
    Anscheinend hat er die falschen/keine Rechte, oder ?
     
  4. Till

    Till Administrator

    Ja, der apache sagt dass er die Datei nicht lesen kann. Versuch es mal mit:

    chmod 755 /var/www/clients/client0/web1/web/.htaccess
     
  5. Falcon37

    Falcon37 New Member

    Ok, habe ich gesetzt, kommt aber auch Internal Server Error.
     
  6. Till

    Till Administrator

    Schau bitte ins log, ob es die exakt gleiche Fehlermeldung ist.
     
  7. Falcon37

    Falcon37 New Member

    Sorry wollte ich gerade nochmal den Post editieren, jetzt schreibt es ins Log:
    Code:
    [Mon Apr 13 16:36:26 2009] [alert] [client XX.XXX.XX.XXX] /var/www/clients/client0/web1/web/.htaccess: RewriteEngine not allowed here, referer: http://www.domain.com/wp-admin/page.php?action=edit&post=2
    [Mon Apr 13 16:36:31 2009] [alert] [client XX.XXX.XX.XXX] /var/www/clients/client0/web1/web/.htaccess: RewriteEngine not allowed here
    [Mon Apr 13 16:36:31 2009] [alert] [client XX.XXX.XX.XXX] /var/www/clients/client0/web1/web/.htaccess: RewriteEngine not allowed here
    [Mon Apr 13 16:36:33 2009] [alert] [client XX.XXX.XX.XXX] /var/www/clients/client0/web1/web/.htaccess: RewriteEngine not allowed here
    [Mon Apr 13 16:36:33 2009] [alert] [client XX.XXX.XX.XXX] /var/www/clients/client0/web1/web/.htaccess: RewriteEngine not allowed here
    [Mon Apr 13 16:37:41 2009] [alert] [client XX.XXX.XX.XXX] /var/www/clients/client0/web1/web/.htaccess: RewriteEngine not allowed here
    [Mon Apr 13 16:37:41 2009] [alert] [client XX.XXX.XX.XXX] /var/www/clients/client0/web1/web/.htaccess: RewriteEngine not allowed here
    [Mon Apr 13 16:37:42 2009] [alert] [client XX.XXX.XX.XXX] /var/www/clients/client0/web1/web/.htaccess: RewriteEngine not allowed here
    [Mon Apr 13 16:37:42 2009] [alert] [client XX.XXX.XX.XXX] /var/www/clients/client0/web1/web/.htaccess: RewriteEngine not allowed here
    [Mon Apr 13 16:37:42 2009] [alert] [client XX.XXX.XX.XXX] /var/www/clients/client0/web1/web/.htaccess: RewriteEngine not allowed here
    [Mon Apr 13 16:37:42 2009] [alert] [client XX.XXX.XX.XXX] /var/www/clients/client0/web1/web/.htaccess: RewriteEngine not allowed here
    [Mon Apr 13 16:37:43 2009] [alert] [client XX.XXX.XX.XXX] /var/www/clients/client0/web1/web/.htaccess: RewriteEngine not allowed here
    [Mon Apr 13 16:37:43 2009] [alert] [client XX.XXX.XX.XXX] /var/www/clients/client0/web1/web/.htaccess: RewriteEngine not allowed here
    
     
  8. Till

    Till Administrator

    Ok, dass liegt daran dass ISPConfig per Default die Option FileInfo deaktiviert hat, da man damit neben den rewrite rules auch die Interpreter für Scriptsprachn ändern bzw. aktivieren kann. Wenn Wordpress das braucht, dann musst Du es bei Dir halt aktivieren.

    Dazu suchst Du in der datei /usr/local/ispconfig/server/conf/vhost.conf.master

    nach der Zeile:

    AllowOverride Indexes AuthConfig Limit

    und ersetzt sie mit:

    AllowOverride Indexes AuthConfig Limit FileInfo

    Die Zeile gibt es 4 mal in der datei, Du mussst alle 4 ersetzen. danach änderst Du eine Einstellung in dem Web, z.B. quota und klickst auf speichern. Nach ca. einer minute sollte er 500er Fehler dann weg sein.
     
  9. Falcon37

    Falcon37 New Member

    WOW, vielen Dank Till geht !! :)
    Dachte schon hätte Server falsch aufgesetzt.
     
    Zuletzt bearbeitet: 13. Apr. 2009
  10. mascoxx

    mascoxx New Member

    Bezieht sich das auf ispconfig2, denn unter 3 ist diese Zeile nicht vorhanden?!
     
  11. Till

    Till Administrator

    Das bezieht sich auf sehr alte Versionen bei ISPConfig 3, bei aktuellen ISPConfig 3 Versionen ist das nicht mehr notwendig.
     

Diese Seite empfehlen