X-Spam-Status in Mails ohne autolearn

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von baschti, 6. Apr. 2009.

  1. baschti

    baschti New Member

    Der Autolearnvorgang selber funktioniert, wenn ich die Mails local auf dem Server prüfe. Nur scheinen die Mails in den angelegten Mailaccounts die Autolearn-Funktion nicht zu nutzen. Im Header der geprüften Mails ist unter X-Spam-Status auch nichts von autolearn zu entdecken. Wie kann man dieses Feature einschalten?
    Danke für Eure Tips!

    Es handelt sich bei meinem System um ISPConfig 3.0.1. auf Lenny.
     
    Zuletzt bearbeitet: 6. Apr. 2009
  2. Till

    Till Administrator

    Schau mal in die spamassassin loacl.cf Datei, ob dort autolearn und bayes Filtern aktiviert ist. das kann dort mit den Folgenden Direktiven aktiviert werden:

    Code:
    use_bayes 1 #   Bayesian classifier auto-learning (default: 1)
    #
    bayes_auto_learn 1
     #   Set headers which may provide inappropriate cues to the Bayesian
    #   classifier
    #
    # bayes_ignore_header X-Bogosity
    # bayes_ignore_header X-Spam-Flag
    # bayes_ignore_header X-Spam-Status
    bayes_auto_learn_threshold_nonspam 1
    bayes_auto_learn_threshold_spam 6
     
  3. baschti

    baschti New Member

    Hallo Till,
    vielen Dank für die Antwort:

    Meine local.cf hatte ich folgendermaßen angepasst:

    # Use Bayesian classifier (default: 1)
    #
    use_bayes 1


    # Bayesian classifier auto-learning (default: 1)
    #
    bayes_auto_learn 1


    # Set headers which may provide inappropriate cues to the Bayesian
    # classifier
    #
    # bayes_ignore_header X-Bogosity
    # bayes_ignore_header X-Spam-Flag
    # bayes_ignore_header X-Spam-Status

    # kleiner oder grosser Spam Report
    #remove_header all Report

    add_header all Status "_YESNO_, score=_SCORE_ required=_REQD_ tests=_TESTS_ autolearn=_AUTOLEARN_ version=_VERSION_"

    # Abgleich Absenderadresse und tatsächlicher Absender
    dns_available yes

    # lernt email als SPAM, wenn Punkte > 2
    bayes_auto_learn_threshold_spam 2.0

    # lernt email als NONSPAM, wenn Punkte < 0.1
    bayes_auto_learn_threshold_nonspam 0.1

    # Autolernen bei mindestens 10 SPAM-Mails in der Bayes-Datenbank
    bayes_min_ham_num 10
    bayes_min_spam_num 10

    use_razor2 1
    #use_dcc 1
    use_pyzor 1

    Im debud-Modus wird auch der Autolearner angeworfen (klar in der X-Spam-Status Zeile mit autolearn=yes zu sehen), nur für meine Mailaccounts scheint die Einstellung in der local.cf nicht zu greifen, zumindest wird autolearn im X-Spam-Status nicht angezeigt. So sieht die betreffende Zeile im Report im Header bei mir aus:

    X-Spam-Status: Yes, score=14.379 tagged_above=3 required=4
    tests=[BAYES_99=3.5, HTML_IMAGE_ONLY_20=1.546, HTML_MESSAGE=0.001,
    HTML_SHORT_LINK_IMG_3=0.001, MSGID_FROM_MTA_HEADER=0.803,
    RAZOR2_CF_RANGE_51_100=0.5, RAZOR2_CF_RANGE_E8_51_100=1.5,
    RAZOR2_CHECK=0.5, SPF_FAIL=0.693, URIBL_AB_SURBL=1.86,
    URIBL_JP_SURBL=1.501, URIBL_SC_SURBL=0.474, URIBL_WS_SURBL=1.5]

    Evtl. gehört etwas in der /usr/sbin/amavisd-new oder in einem anderem Template getweakt?

    Danke für eure Tips!
     
  4. Till

    Till Administrator

    So auf Anhieb weiß ich jetzt auch nicht ob Du da noch was anderes einstellen müsstest, es gibt aber eine ganze menge Treffer bei Google zum Theme anavisd und autolearn, vielleicht da einfach mal durchsehen. ISPConfig verwendet ein ganz normales standard setup von amavisd mit postfix.
     

Diese Seite empfehlen