yet another spamassassin topic

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von nefti, 30. März 2010.

  1. nefti

    nefti New Member

    Hi!

    ich hab folgendes Problem: Mein Spamassassin macht was er will

    Dies äußert sich dadurch, dass neuerdings keine Mails mehr mit *****SPAM***** markiert und die Einstellungen von ISP-Config ignoriert werden.

    Im ISP-Config ist eingestellt, dass eine Mail erst ab Spam-Level 6 als SPAM erkannt werden soll.

    Folgender Header findet sich jedoch in der Mail:
    Code:
        X-Spam-Flag: YES
    X-Spam-Checker-Version: SpamAssassin 3.2.5 (2008-06-10) on kosh.xyz.ab
    X-Spam-Level: *****
    X-Spam-Status: Yes, score=5.6 required=5.0 tests=AWL,HTML_MESSAGE,
        J_CHICKENPOX_12,MSGID_MULTIPLE_AT,RDNS_NONE,SARE_GIF_ATTACH,SARE_OEM_SOFT_IS,
        SARE_RMML_Stock9,TW_KN,TW_KT,TW_KZ,TW_NZ,TW_PF,TW_RW,TW_XZ,TW_ZR
        autolearn=disabled version=3.2.5
    
      
    Das Problem tritt seit heute früh auf, nachdem ich ISP-Config mittels "/usr/local/bin/ispconfig_update.sh" auf den neuesten Stand gebracht habe.

    Ich habe bereits in sämtlichen *.cf-Files gesucht und auch in den amavisd-configs rumgestöbert, jedoch hat keine Änderung diverser Levels einen Effekt gezeigt (ja, ich habs danach wieder auf die Ausgangswerte zurückgesetzt).

    Software im Einsatz:
    ISP-Config 3.0.2.1
    Debian Lenny

    Die Spam-Regeleinstellung sind wie folgt:
    Code:
    SPAM tag Level: 6
    SPAM tag2 Level: 9
    SPAM kill Level: 20
    SPAM dsn cutoff Level: 0
    SPAM quarantine cutoff Level: 0
    SPAM ändert Betreff: Yes
    SPAM Betreff Markierung tag: *****SPAM*****
    SPAM Betreff Markierung tag2: *****SPAM_RULE*****
    
    Falls jemand nen Lösungsansatz hat würde ich mich über kostruktive Beiträge freuen.

    Danke & lg
     
  2. Till

    Till Administrator

    Der spam tag den Du da hast kommt auch nicht von ispconfig. Ich vermute mal, Du hast da noch irgendwie ein anderes mail setup drauf, das spamassassin direkt einbindet und nicht über amavisd wie bei ispconfig. Daher werden auch die Einstellungen von ispconfig ignoriert.

    Die spamheader von ispconfig sehen so aus:

    X-Virus-Scanned: Debian amavisd-new at your.hostname.de
    X-Spam-Flag: YES
    X-Spam-Score: 8.902
    X-Spam-Level: ********
    X-Spam-Status: Yes, score=8.902 tagged_above=3 required=3.501
    tests=[BAYES_95=3, DATE_IN_FUTURE_96_XX=1.439, HTML_MESSAGE=0.001,
    MIME_HTML_ONLY=1.457, NORMAL_HTTP_TO_IP=0.001, RAZOR2_CHECK=0.5,
    RCVD_IN_PBL=0.905, RDNS_DYNAMIC=0.1, URIBL_SBL=1.499]

    Der relevante Unterschied ist:

    X-Spam-Checker-Version: SpamAssassin 3.2.5 (2008-06-10) on kosh.xyz.ab

    bei Dir im Vergleich zu:

    X-Virus-Scanned: Debian amavisd-new at your.hostname.de

    bei ispconfig3 unter debian Lenny.
     
  3. nefti

    nefti New Member

    hi!

    danke für deine Antwort. Habe den Fehler dadurch gefunden.
    In einer Filterregel wurden alle Mails nochmal direkt an den spamd geschickt - k.a warum.

    lg
     

Diese Seite empfehlen