Zend Optimizer im IspConfig 3 System Installieren

Dieses Thema im Forum "Allgemein" wurde erstellt von maxi, 21. Apr. 2011.

  1. maxi

    maxi New Member

    Hallo Leute,

    ich habe ein kleines Problem und zwar möchte ich, um Gsales installieren zu können, Zend Optimizer. Nunja also hab ich die aktuelle ZendOptimizer auf der http://www.zend.com/de/products/guard/downloads Webseite, Zend Optimizer 3.3.3 für ein 64 Bit System gedownloadet und auf dem Server entpackt. Ich habe die richtige SO datei im /usr/local/Zend/lib/ Verzeichnis reinkopiert. Ein aufruf des Befehls

    zeigt mir kein fehler an. Nun habe ich unter ISPCONFIG3 eine Domain erstellt nur mit de php.ini Änderung:

    Fehler nach reload:

    der error 500
    mach ich hingegen:

    klapt alles Wudnerbar. Mache ich irgendwas falsch?

    System:
    Debian
    Linux 2.6.33.7-vs2.3.0.36.30.4-netcup
    x86_64
    Apache/2.2.9 (Debian) DAV/2 PHP/5.2.6-1+lenny10 with Suhosin-Patch mod_ruby/1.2.6 Ruby/1.8.7(2008-08-11) mod_ssl/2.2.9 OpenSSL/0.9.8g

    Könnt ihr mir bitte helfen ;)

    mfg
    Maxi
     
  2. Till

    Till Administrator

    Schau ins error.log der Webseite, dort steht der Grund für den 500er Fehler drin.
     
  3. maxi

    maxi New Member

    In den logs:

    und

    ok Das Problem ist mir schon klar ;) Aber in der php.ini wird die extension erst ganz zum schluss geladen. Also bei welcher php.ini datei muss ich was umstellen, damit alles in der richtigen reihenfolge gestartet wird?
     
    Zuletzt bearbeitet: 21. Apr. 2011
  4. olma

    olma New Member

    Ich glaube, die Antwort hast Du bereits selbst gegeben.

    Du schreibst, dass die Extension als Letztes in der php.ini geladen wird.
    IonCube meckert aber, dass der Eintrag nicht in der ersten Zeile der php.ini zu finden ist. ;)

    Versuch's mal mit der ersten Zeile...
     
  5. maxi

    maxi New Member

    leider immernoch :rolleyes: error 500
     
  6. maxi

    maxi New Member

    Sorry für den doppelpost:

    Ich habe wieder die Fehlöermeldung erhalten:

    Ich habe in folgenden php.ini
    PHP:
    zend_extension=/usr/local/Zend/lib/ZendOptimizer.so 
    oben eingesetzt.

    /etc/php5/apache2/php.ini - error500 - fehlerausgabe wie oben
    /etc/php5/cgi/php.ini - error500 - fehlerausgabe wie oben

    und in der conf Datei der jeweiligen Domain

    Ich kenne mich leid ermit der struktur von ISPConfig 3 aus, aber in welcher php.ini soll ich jetzt
    PHP:
    zend_extension=/usr/local/Zend/lib/ZendOptimizer.so 
    reinsetzen bevor zend ioncube ladet/startet?
     
  7. gOOvER

    gOOvER Member

    Wieso legst Du nicht unter /etc/php5/conf.d ne neue ini an, z.b. zend.ini ?

    Dort trägst Du dann die Zeile ein, mit der Du die Zend Lib aufrufst ;)

    Code:
    zend_extension=/usr/local/Zend/lib/ZendOptimizer.so
    
    Damit ist Zend dann für alle Webs verfügbar ;)

    Für Ioncube machste das selbe, z.b. ioncube.ini. Dort dann auch nur die Zeile zum Aufruf einfügen

    Apache restarten nicht vergessen; fertig :D

    Btw: Das ganze hat nichts mit der Struktur von ispconfig zu tun. ;)
     
    Zuletzt bearbeitet: 23. Apr. 2011
  8. maxi

    maxi New Member

    ^^ Danke gOOvER hat alles geklapt. Jetzt funktionierts.
     

Diese Seite empfehlen